i965 TVout quirk needed [1043,8265]

Bug #201257 reported by tuxo on 2008-03-12
8
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Bryce Harrington
Hardy
Medium
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

Tested Ubuntu version: Hardy Alpha 6
Platform: Santa Rosa, i965 graphics chipset

Bug description: The GNOME panels are smaller than the actual screen resolution. See attached screenshot. I guess this bug is due to a wrongly recognized TV out (see xrandr output below). I have also attached the Xorg.0.log and the xorg.conf files.

What sort of TV out connector does the laptop have?
- None

Do you I have anything plugged into it?
- No, there is no TV output socket.

Related bugs: At least the following two bug are related: Bug #131646 and Bug #152416

--------------------
Ubuntu release version:

ubuntu@ubuntu:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

----------------------
Xorg Intel video driver version:

buntu@ubuntu:~$ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.2.1-1ubuntu2
  Candidate: 2:2.2.1-1ubuntu2
  Version table:
 *** 2:2.2.1-1ubuntu2 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

--------------------
xrandr output:

ubuntu@ubuntu:~$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 286mm x 179mm
   1280x800 59.9*+ 60.0
   1280x768 60.0
   1024x768 60.0
   800x600 60.3
   640x480 59.9
TV connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768 30.0*
   800x600 30.0
   848x480 30.0
   640x480 30.0

------------------------
lspci output:

ubuntu@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
02:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
06:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
06:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
06:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
06:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev ff)

tuxo (beat-fasel) wrote :

Attached xorg.conf file.

tuxo (beat-fasel) wrote :

Attached Xorg.0.log file.

unggnu (unggnu) wrote :

Thanks for reporting. According to Bug #152416 this issue was fixed after release of Hardy Alpha 6 so if you have tested only the Live CD it is possible that your issue is already fixed. You can update the Intel driver package on the LiveCD with the command "sudo apt-get update" and then "sudo apt-get install xserver-xorg-video-intel" and an X restart with ctrl + alt + backspace.

Changed in xserver-xorg-video-intel:
status: New → Incomplete

Thanks for answering my bug report. I updated the Intel driver package as you suggested and restarted X. However, the panels still do not span the whole desktop. So unfortunately, this bug is not fixed for me.

----- Original Message ----
> From: unggnu <email address hidden>
> To: <email address hidden>
> Sent: Wednesday, March 12, 2008 1:36:00 PM
> Subject: [Bug 201257] Re: [Hardy] i965 TVout Interference: Gnome panel smaller than detected resolution
>
> Thanks for reporting. According to Bug #152416 this issue was fixed
> after release of Hardy Alpha 6 so if you have tested only the Live CD it
> is possible that your issue is already fixed. You can update the Intel
> driver package on the LiveCD with the command "sudo apt-get update" and
> then "sudo apt-get install xserver-xorg-video-intel" and an X restart
> with ctrl + alt + backspace.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: New => Incomplete
>
> --
> [Hardy] i965 TVout Interference: Gnome panel smaller than detected resolution
> https://bugs.launchpad.net/bugs/201257
> You received this bug notification because you are a direct subscriber
> of the bug.
>

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Here is the xorg intel driver version after I did the update:

ubuntu@ubuntu:~$ sudo apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.2.1-1ubuntu4
  Candidate: 2:2.2.1-1ubuntu4
  Version table:
 *** 2:2.2.1-1ubuntu4 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

I attached also the new Xorg.0.log file.

Timo Aaltonen (tjaalton) wrote :

What laptop is it?

tuxo (beat-fasel) wrote :

 Timo Aaltonen wrote 5 hours ago:
> What laptop is it?

It is a Littlebit Sepia X35, see
http://www.littlebit.ch/notebook/sepia_x35/sepia_x35.cfm

The technical specs are listed under Technische Daten. This notebook is actually a rebranded Asus Z37E, see e.g. here:
http://www.avadirect.com/product_details_configurator.asp?PRID=9904
http://store.alphapcstore.com/asz3noba13in.html

Bryce Harrington (bryce) on 2008-03-15
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
tuxo (beat-fasel) wrote :

Just tested Ubuntu 8.04 Beta. Unfortunately, this bug is still present.

wjl (wolfgang-lonien) wrote :

I can confirm this with Hardy 8,04 beta and all updates until yesterday. Laptop is the same (Asus resp. Asmobile S37E with Intel Santa Rosa chip set).

cheers,
Wolfgang
http://wolfgang.lonien.de/
http://blog.thedebianuser.org/
http://www.zareason.de/ (we offer these notebooks with Ubuntu preinstalled, so it's really important for us to get this solved)

Bryce Harrington (bryce) on 2008-04-19
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
importance: Undecided → Medium
status: Confirmed → Triaged
tuxo (beat-fasel) wrote :

I just tested with Kubuntu RC 8.04, this bug is still present. Like with Ubuntu, the panel does not span the whole desktop.

wjl (wolfgang-lonien) wrote :

A workaround which worked for us at ZaReason is:

In xorg.conf,

In section "Section "Device""
add the line:

    Option "monitor-TV" "TV"

Also, add the following new section:

    Section "Monitor"
        Identifier "TV"
        Option "Ignore" "True"
    EndSection

Strange that this is also necessary on Notebooks which actually *don't have* a TV-Out...

cheers,
wjl

tuxo (beat-fasel) wrote :

Thanks a lot for the tip wjl! Indeed, this workaround works for me too. However, I think this bug is still not resolved yet as this should work correctly out-of-the-box.

tuxo (beat-fasel) wrote :

The Hard Heron 8.04 Live CD still has this bug and the panels in Gnome do not span the whole desktop. All my reported assessment so far have been done using Live CDs.

Ok, now I upgraded my installed Gutys Gibbon version to Hardy Heron. As I still used the vesa driver, things were looking normal. In a next step I moved the /etc/X11/xorg.conf file away and did a sudo dpkg-reconfigure -phigh xserver-xorg to regenerate a new xorg.conf file with the native intel driver and rebooted the computer. KDM appeared and I logged in. The screen turned black and stayed black. I heard that the desktop was being loaded while the harddrive was busy (I am using the KDE dekstop here but the same is true for the Gnome desktop).

So what happened is that the display was apparently shown on my non-existing TV out output while my screen stayed black. Not good. What I did next is to generate by hand a new xorg.conf file, adding the workaround proposed by wjl and rebooted. Now everything works fine. I attach my xorg.conf file for those being interested.

I still hope that this bug will be fixed during the live time of Hardy Heron.

Steve Langasek (vorlon) on 2008-05-03
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Committed

> Accepted into -proposed, please test and give feedback here
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu Hardy)
> Status: Triaged => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> i965 TVout quirk needed [1043,8265]
> https://bugs.launchpad.net/bugs/201257
> You received this bug notification because you are a direct subscriber
> of the bug.

I tested this update first with a Hardy Heron 8.04 live CD and then on my existing Hardy Heron 8.04 installation (in order to do so I removed my previous xorg.conf file). It worked perfectly in both cases! This update fixes the bug for me, thanks a lot!

      ____________________________________________________________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package xserver-xorg-video-intel - 2:2.2.1-2ubuntu1

---------------
xserver-xorg-video-intel (2:2.2.1-2ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/patches
      + 01_fix_compiz_video.diff:
        use xf86XVFillKeyHelperDrawable() to fix video playback with
        compositing enabled.
      + 03_dell_1535_quirk.diff:
        Add a quirk for Dell Inspiron 1535 so it does not configure
        against the HDMI port instead of the LCD's native resolution
        (LP: 187860).
      + 04_dell_1735_quirk.diff:
        Another HDMI port quirk, for the Dell Inspiron 1735.
        (LP: 188204)
      + 05_intel_exa_force_greedy.patch:
        Force use of greedy mode on i965 hardware.
        (LP: 177492, 148247, 152206)
      + 08_945gm_quirk.diff:
        Adds quirk for another laptop model with a tv out detection bug.
        (LP: 152416)
      + 10_hw_overlay.diff:
        Replace explicit checks for G965 for having no overlay since it
        has one, with general check for future chips that may have no
        overlay. (LP: 201596, 152206)
      + 11_hw_overlay_option.diff:
        Add a Boolean "TexturedVideo" option with default 'true' value
        to be able to turn textured video off.
        (LP: 201596, 152206)
      + 12_quirk_sync.patch: Add some quirks from current git
        upstream, and a quirk for Dell Latitude D630 (LP: 197740)
      + 13_dpms_low_power_overlay.patch:
        Fix crash triggered by dpms low power mode with hardware overlay
        running (LP: 160309)
      + 14_sysfs_fujitsu_backlight.patch:
        Add sysfs backlight support for Fujitsu laptops (LP: 197620)
      + 15_quirk_sony_vaio_vgn-sz4mn.patch:
        Another Pipe A quirk - not already included - for the Sony Vaio
        VGN-SZ4MN. (LP: 212163)
      + 16_legacy_backlight_blc_pwn_ctl.patch:
        Fixes issue where gdm, opengl apps, and vlc resets brightness to
        xbacklight value on i915, by switching from BCM_LEGACY to
        BCM_COMBO. (LP: 201933)
      + 17_lockup_virtual_size_2048.patch:
        Fixes crash if Virtual set to >2048 by disabling DRI in this case,
        prior to initializing the DRI subsystem. (LP: 188178)
    - debian/control:
      + Change the maintainer address.
      + Add lpia to the list of architectures.
      + Nuke Conflicts and Replaces related to -i810.
      + Nuke /usr/lib/xorg/modules/drivers/i810_drv.so symlink
      + Nuke /usr/share/man/man4/i810.4 conflict
      + Don't conflict with 915resolution, since it breaks upgrades
        where people are still using i810 with widescreen resolutions.
        (LP: 206167)
    - debian/rules:
      + Don't build the intel_reg_dumper tool, since libpciaccess is in
        universe.
      + Allow xserver-xorg-video-i810 and xserver-xorg-video-intel to
        coexist until -intel is able to replace it completely.
  * debian/patches/18_quirks.patch:
    - Add quirks for pipe A and tv output bugs.
      (Closes LP: #204603, #216490, #201257, #224102)
  * debian/patches/19_check_exa_pitch_to_fix_rotate_crash.patch:
    - Fixes crash on xrandr rotation by checking EXA pitch size.
      EXA w...

Read more...

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers