gnome-display-properties crashed with SIGSEGV in screen_info_new() - i855, fglrx, radeonhd

Bug #198951 reported by Florent Mertens on 2008-03-06
164
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-desktop (Fedora)
Fix Released
Low
gnome-desktop (Ubuntu)
High
Sebastien Bacher
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-control-center

Starting gnome-display-properties crash at startup.

I got this from standart output :
Resource Timestamp: 39771
Resource Configuration Timestamp: 39771
CRTC 49 Timestamp: 39771
CRTC 4a Timestamp: 39771
Output 4b Timestamp: 39771

I should add that xrandr 1.2 is running correctly from the terminal.
I can change my resolution without problems :

flo@flo-laptop:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 768
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 228mm
   1024x768 60.0*+
   800x600 60.3
   640x480 59.9
TMDS disconnected (normal left inverted right x axis y axis)
flo@flo-laptop:~$ xrandr --output LVDS --mode 800x600
flo@flo-laptop:~$ xrandr --output LVDS --auto
flo@flo-laptop:~$

Laptop : Dell 510m
Graphic card: intel 855GM

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Thu Mar 6 01:29:30 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gnome-display-properties
NonfreeKernelModules: cdrom
Package: gnome-control-center 1:2.21.92-0ubuntu2
PackageArchitecture: i386
ProcCmdline: gnome-display-properties
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=fr_FR.UTF-8
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 screen_info_new (screen=<value optimized out>)
 rw_screen_new (gdk_screen=0x80710b0,
 main ()
Title: gnome-display-properties crashed with SIGSEGV in screen_info_new()
Uname: Linux 2.6.24-11-generic i686
UserGroups: adm admin audio cdrom dialout dip fax usernameppy fuse lpadmin mythtv plugdev sambashare scanner tape

Florent Mertens (givre) wrote :

StacktraceTop:screen_info_new (screen=<value optimized out>)
rw_screen_new (gdk_screen=0x80710b0,
main (argc=110376, argv=0xbf949c34) at xrandr-capplet.c:871

Changed in gnome-control-center:
importance: Undecided → Medium
Changed in gnome-control-center:
assignee: nobody → bryceharrington

gnome-display-properties crashes for me too. If I ran it via Terminal, I get the following error message:

kaarel@kaarel-desktop:~$ gnome-display-properties
The program 'gnome-display-properties' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 96 error_code 1 request_code 151 minor_code 6)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

Chris S. (chrisork) wrote :

I can confirm that bug on another Intel 855GM notebook (Toshiba Sattelite 1130-Z31).

From the Terminal:

atlan@chris-laptop:~$ gnome-display-properties
Resource Timestamp: 108103
Resource Configuration Timestamp: 108103
CRTC 49 Timestamp: 108103
CRTC 4a Timestamp: 108103
Output 4b Timestamp: 108103
Segmentation fault (core dumped)
atlan@chris-laptop:~$

Download full text (5.4 KiB)

Description of problem:

Booting the new kernel with "i915.modeset=1" causes gnome-settings-daemon to
crash after logging in.

From kernel changelog:

* Thu Mar 06 2008 Dave Airlie <email address hidden>
- Add initial i915 drm modesetting tree - needs i915.modeset=1 on command
  line + new libdrm + new intel driver to actually be useful

Version-Release number of selected component (if applicable):

gnome-settings-daemon-2.21.92-2.fc9.x86_64
kernel-2.6.25-0.101.rc4.git3.fc9.x86_64
libdrm-2.4.0-0.9.fc9.i386
libdrm-2.4.0-0.9.fc9.x86_64
xorg-x11-drv-evdev-1.99.1-0.1.fc9.x86_64
xorg-x11-drv-i810-2.2.1-9.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.x86_64

How reproducible:

always

Steps to Reproduce:
1. boot above kernel version with i915.modeset=1 command line
2. log into GNOME, note dialog about gnome-settings-daemon failing to start
3. try running "/usr/libexec/gnome-settings-daemon" manually

Actual results:

> /usr/libexec/gnome-settings-daemon
** (gnome-settings-daemon:3497): DEBUG: Successfully connected to D-Bus
** (gnome-settings-daemon:3497): DEBUG: Starting settings manager
** (gnome-settings-daemon:3497): DEBUG: Loading settings plugins from dir:
/usr/lib64/gnome-settings-daemon-2.0/
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/sound.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/sound for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/clipboard.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/clipboard for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/media-keys.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/media-keys for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/xrandr.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/xrandr for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/xrdb.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/xrdb for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/font.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/font for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/typing-break.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/typing-break for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/xsettings.gnome-settings-plugin
** (gnome-settings-daemon:3497): DEBUG: Monitoring dir
/apps/gnome_settings_daemon/plugins/xsettings for changes
** (gnome-settings-daemon:3497): DEBUG: Loading plugin:
/usr/lib64/gnome-settings-daemon-2.0/key...

Read more...

Created attachment 297368
run through strace and gdb with backtrace

jhansonxi (jhansonxi) wrote :

I'm also seeing this on a Toshiba M35X-S114 with a 855GME.

unggnu (unggnu) wrote :

I guess it is not the drivers fault.

Changed in xserver-xorg-video-intel:
status: New → Invalid
Jared (jared-thanhandjared) wrote :

Dell 610m

Has been working on Hardy up til an apt-get upgrade about 24 hours ago. Havent upgraded though for a day or two as I have been travelling over seas.

jared@bantam:~$ gnome-display-properties
Resource Timestamp: 34394
Resource Configuration Timestamp: 34394
CRTC 49 Timestamp: 34394
CRTC 4a Timestamp: 34394
Output 4b Timestamp: 34394
Segmentation fault (core dumped)

Chris Oattes (cjo20) wrote :

I get the same behaviour as Jared while trying to run gnome-display-properties from the command line, but with all the timestamps replaced with 31366

Bryce Harrington (bryce) on 2008-03-10
Changed in gnome-control-center:
importance: Medium → High
status: New → In Progress
Bryce Harrington (bryce) on 2008-03-11
description: updated
description: updated
Bryce Harrington (bryce) wrote :

I believe this issue is due to bugs in xrandr rather than an issue in gnome-settings-daemon itself. I've backported several bug fixes from upstream that look relevant to making xrandr work properly - these are from one of the radeonhd developers, so will be especially relevant for radeonhd users (and I suspect also relevant for other users).

Please install the three X server debs from this url which have been patched with the fixes, re-test, and let me know if it improves things:

  http://people.ubuntu.com/~bryce/Testing/XrandrGui/

Florent Mertens (givre) wrote :

Hi Bryce,

X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Ubuntu (xorg-server 2:1.4.1~git20080131-1ubuntu5~b
wh1)
Current Operating System: Linux flo-laptop 2.6.24-12-generic #1 SMP Mon Mar 10 1
5:32:00 UTC 2008 i686
Build Date: 10 March 2008 11:54:37PM

With intel 855GM, no change. Crashing at the exact same point.

On Tue, 2008-03-11 at 01:01 +0000, Bryce Harrington wrote:
> I believe this issue is due to bugs in xrandr rather than an issue in
> gnome-settings-daemon itself. I've backported several bug fixes from
> upstream that look relevant to making xrandr work properly - these are
> from one of the radeonhd developers, so will be especially relevant for
> radeonhd users (and I suspect also relevant for other users).
>
> Please install the three X server debs from this url which have been
> patched with the fixes, re-test, and let me know if it improves things:
>
> http://people.ubuntu.com/~bryce/Testing/XrandrGui/
>
Installed the three .debs as requested and rebooted the machine. Upon
activating the xrandr plugin in gnone_settings_daemon experienced the
same crash as before...i.e., I observed no change in behavior.

ATI X1950XTX, radeonhd (latest from git) on Hardy.

Ron Morse

Bryce Harrington (bryce) wrote :

Darn. Well, could you please install and test this deb, which includes a test for xrandr 1.2, and let me know if it still crashes or not.

http://people.ubuntu.com/~bryce/Testing/XrandrGui/gnome-control-center_2.21.92-0ubuntu3_i386.deb

Chris Oattes (cjo20) wrote :

I tried installing the latest test deb, and it does not install, citing dependancy issues. It claims to depend on libgnome-window-setting1 (= 1:2.21.92-0ubuntu3), but I only have libgnome-window-setting1 (= 1:2.21.92-0ubuntu2). My system is up to date (it can find no more updates to apply from the repos)

Changed in gnome-settings-daemon:
status: New → Invalid
rbmorse (rbmorse) wrote :

On Tue, 2008-03-11 at 03:30 +0000, Bryce Harrington wrote:
> Darn. Well, could you please install and test this deb, which includes
> a test for xrandr 1.2, and let me know if it still crashes or not.
>
> http://people.ubuntu.com/~bryce/Testing/XrandrGui/gnome-control-
> center_2.21.92-0ubuntu3_i386.deb
>
Bryce, sorry to report that attempting to install
gnome-control-center_2.12.92-0ubuntu3_i386.deb results in a dependency
not satisfied error with libgnome-window-settings1. Per synaptic the
installed version is 1:2.21.92-0ubuntu2 (hardy).

Ron Morse

rbmorse (rbmorse) wrote :

On Tue, 2008-03-11 at 18:37 +0000, Bryce Harrington wrote:
> Ah, sorry missed that:
>
> http://people.ubuntu.com/~bryce/Testing/XrandrGui/libgnome-window-settings-dev_2.21.92-0ubuntu3_all.deb
> http://people.ubuntu.com/~bryce/Testing/XrandrGui/libgnome-window-settings1_2.21.92-0ubuntu3_i386.deb
>

Hi Bryce.

Those .debs cleared up the dependency issue with the
gnome-control-center .deb you pushed earlier, but I regret to inform
that gnome-settings-daemon still crashes as soon as I enable the xrandr
plugin.

The system works fine if the xrandr plugin is disabled. Standing-by for
the next test

Bryce Harrington (bryce) wrote :

rbmorse, those gnome-control-center debs are only intended for addressing the crash in gnome-display-properties, *not* the crash in gnome-settings-daemon.

description: updated
Bryce Harrington (bryce) wrote :

rbmorse, the gnome-settings-daemon crash you're experiencing is covered in bug 199960. Sorry for the confusion.

I'll second what rbmorse said. Dependencies are cleared up, but things will still not work.

Let me clarify: I still cannot start-up gnome-display-properties. Didn't read all of what rbmorse said.

I still get:

Resource Timestamp: 59462
Resource Configuration Timestamp: 59462
CRTC 41 Timestamp: 59462
CRTC 42 Timestamp: 59462
Output 43 Timestamp: 59462
Segmentation fault (core dumped)

rbmorse (rbmorse) wrote :

On Tue, 2008-03-11 at 20:21 +0000, Bryce Harrington wrote:
> rbmorse, those gnome-control-center debs are only intended for
> addressing the crash in gnome-display-properties, *not* the crash in
> gnome-settings-daemon.
>
Maybe I'm confused, too. In any case, gnome-display-properties still
crashes, too.

Bryce Harrington (bryce) wrote :

Hey, by any chance are you guys running Xgl?

(You can check by running xvinfo | grep Xgl )

Chris Oattes (cjo20) wrote :

I tried running the xvinfo command:

cjo20@clappy:~$ xvinfo | grep Xgl
cjo20@clappy:~$

rbmorse (rbmorse) wrote :

On Tue, 2008-03-11 at 23:30 +0000, Bryce Harrington wrote:
> Hey, by any chance are you guys running Xgl?
>
> (You can check by running xvinfo | grep Xgl )
>

xvinfo returns:

hardy@hardy:~$ xvinfo
X-Video Extension version 2.2
screen #0
 no adaptors present
hardy@hardy:~$

I am using radeonHD drivers, so nope, I'm not using XGL or anything of the sort.

Bryce Harrington (bryce) wrote :

Okay, thanks, that rules that out.

Next thing to test - run `xrandr --output default --mode 1024x768`.
a. Does it change the resolution properly?
b. Do you get an X Error message about BadMatch (major opcode 158, minor 7)? Or a different X Error?

Chris Oattes (cjo20) wrote :

As my laptop is already running at 1024x768, I tried it with 800x600 and 640x480, neither of which had any effect - the resolution stayed the same

cjo20@clappy:~$ xrandr --output default --mode 800x600
cjo20@clappy:~$

cjo20@clappy:~$ xrandr --output default --mode 640x480
cjo20@clappy:~$

cjo20@clappy:~$ xrandr --output default --mode 1024x768
cjo20@clappy:~$

I got no X errors while running either of these commands.

rbmorse (rbmorse) wrote :

On Wed, 2008-03-12 at 01:25 +0000, Bryce Harrington wrote:
> Okay, thanks, that rules that out.
>
> Next thing to test - run `xrandr --output default --mode 1024x768`.
> a. Does it change the resolution properly?
> b. Do you get an X Error message about BadMatch (major opcode 158, minor 7)? Or a different X Error?
>
I had the same result as did Chris...running the command from a terminal
resulted in a return to the prompt with no error messages, screen
resolution did not change.

ATI X1950XTX with radeonhd (latest from git).

I also get no errors (or any other output), but it doesn't change the resolution at all.

Bryce Harrington (bryce) wrote :

Try replacing <default> with whatever your default output is (e.g. VGA-1, DVI0, etc.) You can run xrandr with no args to see a list of what outputs are available.

Chris Oattes (cjo20) wrote :

I replaced <default> with <LVDS>, and it successfully changed the resolution with no error messages.

rbmorse (rbmorse) wrote :

On Wed, 2008-03-12 at 06:43 +0000, Bryce Harrington wrote:
> Try replacing <default> with whatever your default output is (e.g.
> VGA-1, DVI0, etc.) You can run xrandr with no args to see a list of
> what outputs are available.
>
Bryce, same result when specifying output (DVI-I_1/digital). No error,
no change in screen resolution.

ATI X1950XTX on radeonhd

Chris Oattes (cjo20) wrote :

> I replaced <default> with <LVDS>, and it successfully changed the resolution with no error messages.

I'm using an Intel btw.

blah@blah-laptop:~$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 768, maximum 1280 x 1280
VGA_1 disconnected
PANEL connected 1280x768+0+0 0mm x 0mm
   1280x768 60.0*+
blah@blah-laptop:~$ xrandr --output PANEL --mode 1024x768
xrandr: cannot find mode 1024x768
blah@blah-laptop:~$

RadeonHD

*** Bug 437185 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) wrote :

Thanks, although unfortunately it's inconclusive whether xrandr 1.2 is supported.

So... I decided to code up a big workaround (disable the daemon on drivers that won't support it). This won't fix the gnome-display-properties crash, but if you are experiencing the daemon crash, please see bug 199960, where I've posted the deb for this (hopeful) fix. If it works out, then it gives me some ideas on how to solve the config tool as well. Please see that bug and test the deb.

Still happens on these versions:

gnome-settings-daemon-2.22.0-1.fc9.x86_64
kernel-2.6.25-0.113.rc5.git2.fc9.x86_64
libdrm-2.4.0-0.9.fc9.i386
libdrm-2.4.0-0.9.fc9.x86_64
xorg-x11-drv-evdev-1.99.1-0.4.fc9.x86_64
xorg-x11-drv-i810-2.2.1-10.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-5.20080310.fc9.x86_64

Is it related to .gnome2/monitors.xml ? What does such a file look like?

open("/home/torel/.gnome2/monitors.xml", O_RDONLY) = -1 ENOENT (No such file or
directory)
fstat(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x7f2247615000
write(1, "parse error\n", 12parse error
) = 12

Btw, I have FX 570M gfx and using nv driver. Trying to compile latest nvidia
driver, but there are some changes to kernel. So I think this is more general
that i915. Maybe Xinerama related? It do not crash if I turn of xinerama.

Peter Husen (phusen) wrote :

Like many others, I experience the crash with an 855 and the "intel" driver. Let me add that I can use xrandr 1.2 features using the command line tool, i.e.
$ xrandr --output VGA --pos 0x200
extends the screen downwards to my external display. I have mostly used it for a clone configuration, but just tried this also, and it worked. Of course I cannot conclude that the support in the driver is complete and bug-free, but it seems to work pretty reliably. I would be a bit sad if this will never be supported in the graphical tool.

Bryce Harrington (bryce) wrote :

Assigning to seb128 since he needs to either accept the gnome-settings-daemon patch I sent, or propose an alternate patch, or provide additional troubleshooting information including detailed backtraces before I can do anything more.

Changed in gnome-control-center:
assignee: bryceharrington → seb128
Sebastien Bacher (seb128) wrote :

Bryce, the bug has a detailled backtrace, valgrinds shows an incorrect read there and build libgnome-desktop-2 using -O0 seems to workaround the issue

Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :

I'll have a look at getting informations but I'm not the one who added those changes and I'm not responsive for the issue

Changed in gnome-control-center:
assignee: seb128 → nobody
milestone: none → ubuntu-8.04-beta
Sebastien Bacher (seb128) wrote :

valgrind log showing the issue

==24278== Use of uninitialised value of size 4
==24278== at 0x5609ECA: output_initialize (randrwrap.c:606)
==24278== by 0x56095E8: fill_out_screen_info (randrwrap.c:267)
==24278== by 0x56096F7: screen_info_new (randrwrap.c:297)
==24278== by 0x5609771: screen_update (randrwrap.c:322)
==24278== by 0x5609AA2: rw_screen_refresh (randrwrap.c:449)
==24278== by 0x5608D07: configuration_apply_stored (monitor-db.c:783)
==24278== by 0x559D63E: gsd_xrandr_manager_start (gsd-xrandr-manager.c:126)
==24278== by 0x559D37E: impl_activate (gsd-xrandr-plugin.c:78)
==24278== by 0x804C3D0: gnome_settings_plugin_info_activate (gnome-settings-plugin-info.c:481)
==24278== by 0x804B1FD: maybe_activate_plugin (gnome-settings-manager.c:92)
==24278== by 0x4927D60: g_slist_foreach (in /usr/lib/libglib-2.0.so.0.1600.1)
==24278== by 0x804B462: gnome_settings_manager_start (gnome-settings-manager.c:246)

Changed in gnome-desktop:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

Alright, I've figured the issue and will upload a fix soon

Changed in gnome-control-center:
assignee: nobody → seb128
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

The issue was due to "RWOutput *output = rw_output_by_id (output->info, info->clones[i]);", the same variable name is used for the new rwoutput and as function parameter which creates a conflict and breaks the argument used there

The new upload fixes the gnome-settings-daemon issue, testing on an i855 and a xnest configurations

The debdiff is not trivial but those are mostly context changes (the previous change was not likely a cdbs-edit-patch one), the code change is this one

" --- gnome-desktop-2.22.0/libgnome-desktop/randrwrap.c 2008-03-17 15:39:41.000000000 +0100
+++ gnome-desktop-2.22.0.new/libgnome-desktop/randrwrap.c 2008-03-17 15:39:10.000000000 +0100
@@ -603,10 +603,10 @@
     a = g_ptr_array_new ();
     for (i = 0; i < info->nclone; ++i)
     {
- RWOutput *output = rw_output_by_id (output->info, info->clones[i]);
+ RWOutput *rwoutput = rw_output_by_id (output->info, info->clones[i]);

- if (output)
- g_ptr_array_add (a, output);
+ if (rwoutput)
+ g_ptr_array_add (a, rwoutput);
     }
     g_ptr_array_add (a, NULL);
     output->clones = (RWOutput **)g_ptr_array_free (a, FALSE);"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop - 1:2.22.0-0ubuntu2

---------------
gnome-desktop (1:2.22.0-0ubuntu2) hardy; urgency=low

  * debian/patches/100_gd-add-randr-12.patch:
    - don't use conflicting variable name, fix the gnome-settings-daemon
      and gnome-display-properties xrandr crashers (lp: #198951)

 -- Sebastien Bacher <email address hidden> Mon, 17 Mar 2008 14:54:04 +0100

Changed in gnome-desktop:
status: Fix Committed → Fix Released
Florent Mertens (givre) wrote :

Sebastien you are my hero !

Jeff Schroeder (sejeff) wrote :

Sorry Seb, but it doesn't seem like it was fixed on my box.

jeff@jschroeder2:~/svn/systems/scripts/misc$ dpkg -l | grep gnome-desktop
ii gnome-desktop-data 1:2.22.0-0ubuntu2 Common files for GNOME 2 desktop apps
ii libgnome-desktop-2 1:2.22.0-0ubuntu2 Utility library for loading .desktop files -
jeff@jschroeder2:~/svn/systems/scripts/misc$ gnome-display-properties
Segmentation fault (core dumped)

For some reason apport isn't catching the core. Strace and gdb backtrace logs are attached.

Jeff Schroeder (sejeff) wrote :

Ubuntu has a similar bug with a patch that fixes it.

Maybe it would be worth looking into:
https://bugs.launchpad.net/ubuntu/+source/gnome-desktop/+bug/198951/comments/44

Jeff Schroeder (sejeff) wrote :

Looking at that strace and a bit of poking around on this box...

gnome-display-properties opens a socket and assigns it fd 3 for x.
It writes some data and RANDR to that socket. After another read on
that same socket, it drops core.

jeff@jschroeder2:~/svn/systems/scripts$ xrandr
Xlib: extension "RANDR" missing on display ":0.0".
RandR extension missing
jeff@jschroeder2:~/svn/systems/scripts$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro FX 1700 (rev a1)
02:00.0 VGA compatible controller: nVidia Corporation Quadro FX 1700 (rev a1)

These two cards are both used with Xinerama if that helps any.

Sebastien Bacher (seb128) wrote :

this crasher is a different one, see bug #199878

Hello, the gnome-settings-daemon is not crashing anymore after the latest updates.On Wed, 19 Mar 2008 13:13:34 -0000 Bug 198951 wrote Sorry Seb, but it doesn't seem like it was fixed on my box. jeff@jschroeder2:~/svn/systems/scripts/misc$ dpkg -l | grep gnome-desktop ii gnome-desktop-data 1:2.22.0-0ubuntu2 Common files for GNOME 2 desktop apps ii libgnome-desktop-2 1:2.22.0-0ubuntu2 Utility library for loading .desktop files - jeff@jschroeder2:~/svn/systems/scripts/misc$ gnome-display-properties Segmentation fault (core dumped) For some reason apport isn't catching the core. Strace and gdb backtrace logs are attached. ** Attachment added: "strace-gnome-display-properties.log" http://launchpadlibrarian.net/12738110/strace-gnome-display-properties.log -- gnome-display-properties crashed with SIGSEGV in screen_info_new() - i855, fglrx, radeonhd https://bugs.launchpad.net/bugs/198951 You received this bug notification because you are a direct subscriber of a duplicate bug. Status in Source Package "gnome-desktop" in Ubuntu: Fix Released Status in Source Package "gnome-settings-daemon" in Ubuntu: Invalid Status in Source Package "xserver-xorg-video-intel" in Ubuntu: Invalid Status in Source Package "gnome-desktop" in Fedora: Confirmed Bug description: Binary package hint: gnome-control-center Starting gnome-display-properties crash at startup. I got this from standart output : Resource Timestamp: 39771 Resource Configuration Timestamp: 39771 CRTC 49 Timestamp: 39771 CRTC 4a Timestamp: 39771 Output 4b Timestamp: 39771 I should add that xrandr 1.2 is running correctly from the terminal. I can change my resolution without problems : flo@flo-laptop:~$ xrandr Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 768 VGA disconnected (normal left inverted right x axis y axis) LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 228mm 1024x768 60.0*+ 800x600 60.3 640x480 59.9 TMDS disconnected (normal left inverted right x axis y axis) flo@flo-laptop:~$ xrandr --output LVDS --mode 800x600 flo@flo-laptop:~$ xrandr --output LVDS --auto flo@flo-laptop:~$ Laptop : Dell 510m Graphic card: intel 855GM ProblemType: Crash Architecture: i386 CrashCounter: 1 Date: Thu Mar 6 01:29:30 2008 DistroRelease: Ubuntu 8.04 ExecutablePath: /usr/bin/gnome-display-properties NonfreeKernelModules: cdrom Package: gnome-control-center 1:2.21.92-0ubuntu2 PackageArchitecture: i386 ProcCmdline: gnome-display-properties ProcEnviron: SHELL=/bin/bash PATH=/home/username/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games LANG=fr_FR.UTF-8 Signal: 11 SourcePackage: gnome-control-center StacktraceTop: screen_info_new (screen=) rw_screen_new (gdk_screen=0x80710b0, main () Title: gnome-display-properties crashed with SIGSEGV in screen_info_new() Uname: Linux 2.6.24-11-generic i686 UserGroups: adm admin audio cdrom dialout dip fax usernameppy fuse lpadmin mythtv plugdev sambashare scanner tape

I just applied the patch mentioned in #6 and recompiled gnome-desktop, not it
WFM. No idea how to make patches, this is my first miserable try ...

(/home/ds)$ diff -n rpmbuild/SOURCES/add-randr-12.patch
rpmbuild/SOURCES/add-randr-12.patch.new
--- rpmbuild/SOURCES/add-randr-12.patch 2008-03-02 22:18:50.000000000 +0000
+++ rpmbuild/SOURCES/add-randr-12.patch.new 2008-03-20 02:23:33.000000000 +0000
@@ -2535,10 +2535,10 @@
 + a = g_ptr_array_new ();
 + for (i = 0; i < info->nclone; ++i)
 + {
-+ RWOutput *output = rw_output_by_id (output->info, info->clones[i]);
++ RWOutput *rwoutput = rw_output_by_id (output->info, info->clones[i]);
 +
-+ if (output)
-+ g_ptr_array_add (a, output);
++ if (rwoutput)
++ g_ptr_array_add (a, rwoutput);
 + }
 + g_ptr_array_add (a, NULL);
 + output->clones = (RWOutput **)g_ptr_array_free (a, FALSE);

I hope this is fixed in gnome-desktop 2.22.0-2 which should appear in rawhide
soon. Feel free to reopen if it isn't.

Changed in gnome-desktop:
status: Confirmed → Fix Released
Changed in gnome-desktop (Fedora):
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.