bad performaces on intel x3100

Bug #193667 reported by farno on 2008-02-20
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

I have an hp pavillion dv6625el, with the intel x3100 video card:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

I have bad performances when I watch videos (by using different video player: vlc, totem, mplayer...). So I tried the glxgears test:

glxgears
5645 frames in 5.0 seconds = 1128.873 FPS
5805 frames in 5.0 seconds = 1160.964 FPS
5791 frames in 5.0 seconds = 1158.063 FPS
5799 frames in 5.0 seconds = 1159.799 FPS

The number of frames seems to be low. On another computer with a quite old ati video card the number of frames in 5 seconds is near to 25000.
I can't believe that the latest intel video card has this kind of behaviour. So I think that xserver-xorg-video-intel package could have problems (at least on my hardware).

The 3d acceleration is on:

glxinfo | grep rendering
direct rendering: Yes

For completness I report my xorg.conf:

cat /etc/X11/xorg.conf
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "it"
        Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ImPS/2"
        Option "ZAxisMapping" "4 5"
        Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
        Identifier "Synaptics Touchpad"
        Driver "synaptics"
        Option "SendCoreEvents" "true"
        Option "Device" "/dev/psaux"
        Option "Protocol" "auto-dev"
        Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "stylus"
        Option "Device" "/dev/input/wacom"
        Option "Type" "stylus"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "eraser"
        Option "Device" "/dev/input/wacom"
        Option "Type" "eraser"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "cursor"
        Option "Device" "/dev/input/wacom"
        Option "Type" "cursor"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
        Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
        Driver "intel"
        BusID "PCI:0:2:0"
EndSection

Section "Monitor"
        Identifier "Monitor Generico"
        Option "DPMS"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
        Monitor "Monitor Generico"
        DefaultDepth 24
        SubSection "Display"
                Modes "1280x800"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier "Default Layout"
        Screen "Default Screen"
        InputDevice "Generic Keyboard"
        InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
        InputDevice "Synaptics Touchpad"
EndSection

Ideas?

Thank's

p.s.: I am sorry for my english. I hope yau can undestand everything I wrote.

farno (d-farnocchia-gmail) wrote :

I tried to change the video output (with totem, mplayer and vlc), with no results.
Videos are not fluent at all

Bo90 (joakimcarli) wrote :

I have the same problem. I can't watch videos on my laptop because of this.
Video performance is really bad.

I'm currently running hardy with the latest updates, I thought that the update xserver-xorg-video-intel (2:2.2.0.90-2ubuntu7) would solve my problem, but it didn't.

I also tried adding
Option "MigrationHeuristic" "greedy"

That removed the window glitches when running compiz, but it didn't solve the video performance issue.

any ideas?

Bryce Harrington (bryce) wrote :

Yesterday's fix for 965 should take care of this. If not, feel free to reopen but please attach your /var/log/Xorg.0.log and output of lspci -vvnn

Also note that glxgears is not a benchmark, and further 3D performance probably has no bearing on video performance.

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Bo90 (joakimcarli) wrote :
Download full text (15.3 KiB)

That fix did not solve my problems.

lspci -vvnn
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
 Latency: 0
 Capabilities: <access denied>

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at f8000000 (64-bit, non-prefetchable) [size=1M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 1800 [size=8]
 Capabilities: <access denied>

00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 0c)
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Region 0: Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
 Capabilities: <access denied>

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03) (prog-if 00 [UHCI])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 17
 Region 4: I/O ports at 1820 [size=32]

00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03) (prog-if 00 [UHCI])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin B routed to IRQ 20
 Region 4: I/O ports at 1840 [size=32]

00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03) (prog-if 20 [EHCI])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin C routed to IRQ 18
 Region 0: Memory at f8604800 (32-bit, non-prefetchable) [size=1K]
 Capabilities: <access denied>

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)...

Bo90 (joakimcarli) on 2008-02-24
Changed in xserver-xorg-video-intel:
status: Fix Released → Incomplete
farno (d-farnocchia-gmail) wrote :

On ubuntu gutsy I haven't seen updates.
When I have the computer with the Intel graphic card I'll post the requested outputs.

farno (d-farnocchia-gmail) wrote :
Download full text (15.7 KiB)

These are the requested output:

lspci -vvnn
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
        Subsystem: Hewlett-Packard Company Unknown device [103c:30cc]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Capabilities: <access denied>

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company Unknown device [103c:30cc]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 17
        Region 0: Memory at f8000000 (64-bit, non-prefetchable) [size=1M]
        Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 1800 [size=8]
        Capabilities: <access denied>

00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 0c)
        Subsystem: Hewlett-Packard Company Unknown device [103c:30cc]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Region 0: Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03) (prog-if 00 [UHCI])
        Subsystem: Hewlett-Packard Company Unknown device [103c:30cc]
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 17
        Region 4: I/O ports at 1820 [size=32]

00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03) (prog-if 00 [UHCI])
        Subsystem: Hewlett-Packard Company Unknown device [103c:30cc]
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 18
        Region 4: I/O ports at 1840 [size=32]

00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03) (prog-if 20 [EHCI])
        Subsystem: Hewlett-Packard Company Unknown device [103c:30cc]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0...

Bryce Harrington (bryce) wrote :

farno, the update with the fix is available only for hardy.

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: Incomplete → Confirmed
unggnu (unggnu) wrote :

Hardy Heron Alpha5 was recently released. It contains an updated version of the Intel driver. You can download and try the new Hardy Heron Alpha5 Live CD from http://cdimage.ubuntu.com/releases/hardy/alpha-5/ . If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha5 .

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
unggnu (unggnu) wrote :

It seems that this issue has already been reported under Bug #152206 so it is marked es a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers