[i915] Configuration failed on MPC client pro all-in-one 414

Bug #186095 reported by swwxxwws on 2008-01-26
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

I have 4 computers: all 4 are: (MPC client pro all-in-one 414) with a P4 @ 3 Ghz 1GB ram and a Intel 82915G/GV/910GL Graphics chipset

on 1-25-08 7:50 PM

 I downloaded (Ubuntu 7.10) and I made a boot disk and rebooted; I selected to install. a few moments later my screen went crazy!

I then rebooted and tried to install with "graphics safe mode". a few moments later my screen went blank with no back light or anything, looked like no power.

I then removed the install disk and rebooted, my primary monitor (built in digital flat panel) was still off, with my secondary monitor booting up WIndows Xp.

windows no longer recognizes my primary display. and has very weird results if I try to change any setting related to graphics properties.

I have tried different operating systems (windows2000, windows xp) on different hard drives. - with the exact same results.

I tried this Ubuntu 7.10 install disk on one other of my machines with the same exact results. (same hardware configuration)

I am vary unhappy with this destroyed state my computers are in.

I thought I would report this horrible bug to you guys, hopefully to save anybody else from destroying there machines.

any thoughts?

thank you,

Chris X.
<email address hidden>

trollord (trollenlord) wrote :

Hi Chris, I am terribly sorry to hear that you had such problems!

My money says that the DPMS reported high refresh rate for the panel. It is the duty of the panels to report correct values, and sometimes some do not. All the X can do is to attempt to use those values and some panels have no sanity checks, leading into destruction. I have seen it happen on some HP's laptop myself, and it certainly is possible with some cheaper stand alone panels as well.

The only thing that the developers can do is to blacklist the monitor's bogus values somehow (in case you can produce what X.org.log includes when you started it up with that monitor...) and as for what comes to the rest you should use the warranty.

Bryce Harrington (bryce) wrote :

If you can attach /var/log/Xorg.0.log we can try implementing a quirk for this monitor to prevent the issue.

Changed in xserver-xorg-video-intel:
importance: Undecided → Critical

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
Nick (im-gettin-mine) wrote :

I have an MPC ClientPro 414 All-in-One II and I'm getting a similar situation as the OP. Luckily, I'm just getting the black screen when I try the LiveCD (I haven't tried installing yet) and when I reboot into XP, everything works just fine.

I'm using Ubuntu 8.10 instead of 7.10 however. I'll get the Xorg.0.log file uploaded shortly.

Changed in xserver-xorg-video-intel:
status: Invalid → New
Nick (im-gettin-mine) wrote :

Attached is the log file. IF there is anything else that I can do to help, please let me know. I really want to put Ubuntu on my PC.

Thanks!

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi swwxxwws1,

Please attach the output of `lspci -vvnn` too.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Nick (im-gettin-mine) wrote :

Hi Bryce, attached is the output of 'lspci -vvnn'.

Thanks!

Geir Ove Myhr (gomyhr) on 2009-01-18
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-02-17
Changed in xserver-xorg-video-intel:
importance: Critical → High
Andrew Ash (ash211) on 2009-05-08
tags: added: black-screen
Bryce Harrington (bryce) wrote :

Hi Chris,

I just had a chance to speak with an upstream developer about your issue. He said perhaps it was caused by your SDVO card was either not seated correctly or not connected right inside your machine. In any case we've not seen anyone else with this same issue so I am going to guess it is something peculiar to your hardware, not something we can solve directly in Ubuntu. Thanks for reporting the bug though, hopefully it's all resolved now for you.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers