[Gutsy backport] Cannot switch to console after installing "xserver-xorg-video-intel 2:2.1.1-0ubuntu9.1"

Bug #182865 reported by Norbert on 2008-01-14
34
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Gutsy
Medium
Unassigned

Bug Description

Hello there

The latest Ubuntu Gutsy xserver-xorg-video-intel 2:2.1.1-0ubuntu9.1 won't work well with my PC having a "VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)" graphical card. The X works well, but after having the driver loaded, I am unable to switch to console mode. I was going through every log, but I couldn't find any error messages which could help me further.
I had to downgrade to 2:2.1.1-0ubuntu9 so I can use console again.

May I ask you to take a look on this one?

Regards:
Norbert

Bryce Harrington (bryce) wrote :

Please provide additional information. See http://wiki.ubuntu.com/X/Debugging for help on what to include in bug reports.

Changed in xserver-xorg-video-intel:
status: New → Incomplete

Hello Bryce!

Thank you for your kind help, but the problem is, that I cannot give you
additional information. Thats all I have. When I performed the upgrade, I
was not able to switch to Console mode (Alt+Fx). No error message, nothing.
The monitor got into suspend mode. I had to downgrade to the earlier X
driver so I will be able to use the console mode again.
Can you please give me some hints how to include more information?

Regards:
Norbert

2008/1/17, Bryce Harrington <email address hidden>:
>
> Please provide additional information. See
> http://wiki.ubuntu.com/X/Debugging for help on what to include in bug
> reports.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: New => Incomplete
>
> --
> Cannot switch to console after installing "xserver-xorg-video-intel 2:
> 2.1.1-0ubuntu9.1"
> https://bugs.launchpad.net/bugs/182865
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Üdvözlettel/Gruß/Regards:
norbert79

I can confirm the bug:
- video driver used: xserver-xorg-video-intel 2:2.1.1-0ubuntu9.1
- video card (motherboard integrated):
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)

To reproduce: start any X server with this driver. After it has been started switching to console with ALT+CTRL+F1..F6 works but the monitor starts to search (analog/digital) video source and after a while goes to sleep => video card is deactivated. One can switch back to vt7 or any other vt where the X is started.
After shutting down X server user ends up without any display.
Console's are there: with blind type you can login and start an other X :-)

Bug is correctly reported and reported by more than one user.
Maybe a similar bug: 184018

Changed in xserver-xorg-video-intel:
status: Incomplete → New

Can you test and see if this issue also occurs with Hardy?

Changed in xserver-xorg-video-intel:
status: New → Incomplete

I can't install Hardy now, but if the DesktopCD used as a Live CD is ok for testing I can do it.
Is it ok? Should I test with the Live CD?

Daniel Stränger (schmaller) wrote :

I've specially installed Hardy to test the driver's behaviour.
I cannot reproduce the bug under Hardy, but confirm its existence under Gutsy.
The Hardy driver version is the following: 2:2.2.0+git20080107-1ubuntu2

Bryce Harrington (bryce) wrote :

Thanks for confirming the issue is solved on Hardy. Vadasz, yes a LiveCD of Hardy should make for an adequate test.

I'll leave the bug itself open - perhaps a backport of -intel to Gutsy could be done.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
importance: Undecided → Medium
status: Incomplete → In Progress
furicle (furicle) wrote :

Can we get that gutsy backport? I have same issue...

Bruno Beaufils (beaufils) wrote :

We get the same bug. It seems that the problem is not present with the xserver-xorg-video-intel (2:2.1.1-0ubuntu-9) available on Gutsy CD-ROM. The problem comes with updates done when using internet sources.list repositories.

So in order to bypass the problem on our machines we downgrad the package with the old version. We thus add the following lines to /etc/apt/preferences :

Package: xserver-xorg-video-intel
Pin: version 2:2.1.1-0ubuntu-9
Pin-Priority: 2000

Then we use the following command to install it :

apt-get --reinstall install xserver-xorg-video-intel=2:2.1.1-0ubuntu9

On Wed, Feb 27, 2008 at 10:45 PM, Bruno Beaufils <email address hidden> wrote:
> We get the same bug. It seems that the problem is not present with the
> xserver-xorg-video-intel (2:2.1.1-0ubuntu-9) available on Gutsy CD-ROM.
> The problem comes with updates done when using internet sources.list
> repositories.
>
> So in order to bypass the problem on our machines we downgrad the
> package with the old version. We thus add the following lines to
> /etc/apt/preferences :
>
> Package: xserver-xorg-video-intel
> Pin: version 2:2.1.1-0ubuntu-9
> Pin-Priority: 2000
>
> Then we use the following command to install it :
>
> apt-get --reinstall install xserver-xorg-video-intel=2:2.1.1-0ubuntu9

Thanks for the info - I've downgraded and pinned it.

As a reference, I think that this is the upstream bug (and fix):

http://bugs.freedesktop.org/show_bug.cgi?id=14481

...a backport, please? :-)

titi4u (titi4u) wrote :

Same bug for me! Downgrading to version 2:2.1.1-0ubuntu-9 solved the problem. Same request : backport ?

Same bug here, when installing kernel-386 bug is not there, but then I only have support for 1 processor.
This bug comes to me when using kernel-generic.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/197291

This also affects hardy alpha 6 after doing dist upgrade from gutsy

Bryce Harrington (bryce) wrote :

Unfortunately, the patch on upstream bug 14481 applies against code that has changed significantly since Gutsy's -intel, so cannot be backported directly. And indeed, the quantity of change compared with Gutsy makes it too risky to backport.

Presumably, this issue was introduced by one of the patches in the prior release. My guess would be 04_fix_hw_restore.diff. Here is a deb with this patch disabled, can someone confirm that thsi fixes the issue? If so, we can then investigate if 04_fix_hw_restore.diff can be improved to not cause this breakage.

http://people.ubuntu.com/~bryce/Testing/intel-Gutsy/xserver-xorg-video-intel_2.1.1-0ubuntu9.2~bwh1_i386.deb

Good work Bryce, thanks for biting in this bug so much. (It really bugged me)

I just installed the xserver-xorg-video-intel_2.1.1-0ubuntu9.2~bwh1_i386.deb on gutsy and
now I am able to switch consoles again. So this last version does NOT have the bug. The
question is, what have we disabled?

(as is this deb file cannot be installed in hardy)

Adios Barry

Bryce Harrington (bryce) wrote :

Right, this is a gutsy-only thing. Since we have the newer xserver code in hardy I would guess it probably doesn't suffer from this issue (can anyone confirm or deny?)

Well, 04_fix_hw_restore.diff solves bug 108056, so if we were to drop the patch, then we'd be trading one bug for another. hrm.

Well a few days ago I installed hardy on my laptop with dist-upgrade, that
did not solve the issue. (could still not switch consoles) Now this was not a fresh install, but it has the new xserver-xorg installed. So for me xserver-xorg-video-intel is not working in gutsy now.

On my desktop I am running gutsy with the
xserver-xorg-video-intel_2.1.1-0ubuntu9.2~bwh1_i386.deb
and that is working fine.

It is complicated tough...

Il giorno mer, 19/03/2008 alle 22.39 +0000, Bryce Harrington ha scritto:
> [...snip..]
> Presumably, this issue was introduced by one of the patches in the prior
> release. My guess would be 04_fix_hw_restore.diff. Here is a deb with
> this patch disabled, can someone confirm that thsi fixes the issue? If
> so, we can then investigate if 04_fix_hw_restore.diff can be improved to
> not cause this breakage.
>
> http://people.ubuntu.com/~bryce/Testing/intel-Gutsy/xserver-xorg-video-
> intel_2.1.1-0ubuntu9.2~bwh1_i386.deb
>
Hi Bryce,
 I installed the above package, the situation is somewhat better, in the
sense I'm now able to access consoles 1 to 6. It does not solve the
problem, however, because once switched to a command line console, I can
not switch back to graphic console by Ctrl-Alt-F7. If I try doing this,
I get a console with errors message and I must go back to a command line
interface, connect and do

~$ sudo /etc/init.d/gdm restart

--
Leo 'TheHobbit' Cacciari

Norbert (norbert79) wrote :

Bryce!

Thank you for your efforts, I just installed on my T60, and it seems to work right now. I am testing it with compiz and without compiz, no problems occured yet. (While I can see others have the problem still)
As I heard, Intel just released some technical specifications recently. Is this also beeing valid for graphical cards?

Regards:
Norbert

Bryce Harrington (bryce) wrote :

Thanks for confirming the issue is due to 04_fix_hw_restore.diff. Since that fixes a real issue, simply dropping the patch is probably not good form - the folks experiencing that bug would get hit with a regression. But perhaps the fix can be conditionalized such that it doesn't cause this bug. For now, I'll keep the debs available so people with this problem have this as an option (in addition to downgrading to 0ubuntu9, which is also a valid workaround).

@Norbert, not sure I understand your question, however the tech specs you mention have been available to many of the core -intel developers inside Intel. Making the docs public increases the number of people who can contribute to the code, but probably won't make a difference on bugs like this one (at least, not right away).

It seems that it's still here for me, with hardy and 2.2.2.1-ubuntu12.
Where can I find info on how downgrade this driver in a reversible way? I am testing kernel 2.6.26 and y'know, when testng kernels console is _quite_ useful...

Cannot find the right server to download... I have Hardy here.
Can someone help?

ping? :-)

Norbert (norbert79) wrote :

Pong!

Sorry Romano, I might be not really helpful at all, but did you try any of the packages on this site, as mentioned earlier?
http://people.ubuntu.com/~bryce/Testing/intel/

I have installed the packages, what has been listed earlier, since then I don't see any more problems, yet I didn't upgrade to Hardy yet, so I cannot speak for Hardy.

Regards:
Norbert

Tried it...

(0)rukbat:~/software/downloads% sudo dpkg -i xserver-xorg-video-intel_2.2.1-1ubuntu6~bwh1_i386.deb
dpkg - warning: downgrading xserver-xorg-video-intel from 2:2.2.1-1ubuntu13 to 2:2.2.1-1ubuntu6~bwh1.
dpkg: regarding xserver-xorg-video-intel_2.2.1-1ubuntu6~bwh1_i386.deb containing xserver-xorg-video-intel:
 xserver-xorg-video-intel conflicts with 915resolution
  915resolution (version 0.5.3-1ubuntu1) is present and installed.
dpkg: error processing xserver-xorg-video-intel_2.2.1-1ubuntu6~bwh1_i386.deb (--install):
 conflicting packages - not installing xserver-xorg-video-intel
Errors were encountered while processing:
 xserver-xorg-video-intel_2.2.1-1ubuntu6~bwh1_i386.deb

Hrmmm... not knowing what to do next, really. Without i915 resolution the screen is *really* ugly...

Bryce Harrington (bryce) wrote :

Romano, if you're using the "i810" driver, you should instead use the "intel" driver and uninstall 915resolution. That code is incorporated into the intel driver so you no longer need it.

Changed in xserver-xorg-video-intel:
assignee: bryceharrington → nobody
status: In Progress → Triaged
Bryce Harrington (bryce) wrote :

Moving to a Gutsy task. (However, since we don't know of an easy to apply fix, it's unlikely this will be addressed.)

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: New → Triaged
status: Triaged → Fix Released
Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Gutsy Gibbon 7.10 has reached its end of life -
http://www.ubuntu.com/news/ubuntu-7.10-eol . As a result, we are closing the
Gutsy task.

Changed in xserver-xorg-video-intel (Ubuntu Gutsy):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.