First instance of video playback is corrupted, subsequent playback ok

Bug #182682 reported by joss on 2008-01-13
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

When I launch a video in any application (totem, totem-xine, xfmedia, VLC, etc) it runs with corrupted picture colour (the colours are extremely luminous & bright, although everything else appears ok). However, when a subsequent video playback is made whilst the first is still playing (either using the same application as the first, or a differnt one), the playback is fine. So long as one video file is open, the others seem to work ok.

I have tried a miriad drivers, video playback applications, plugins, and config settings without success.

I have been unable to get any assistance from the Ubuntu forums. System info is as follows. If anymore information is required, please let me know.

Thanks.

System:
Acer Travelmate 3040, Intel Core2 @1.6GHz & 1GB RAM

Graphics are:
Intel Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

xorg.conf:
Section "Device"
        Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
        Driver "intel"
        BusID "PCI:0:2:0"
EndSection

Section "Monitor"
        Identifier "Generic Monitor"
        Option "DPMS"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
        Monitor "Generic Monitor"
        DefaultDepth 24
        SubSection "Display"
                Modes "1280x800"
        EndSubSection
EndSection

Mantas Kriaučiūnas (mantas) wrote :

> So long as one video file is open, the others seem to work ok.

AFAIK this is because first video player plays though accelerated (XV) video driver, but XV can't be used in 2 video players on the same time, so other video files are played though unaccelerated (X11) video driver and X11 video output doesn't have color corruption problem.

This bug could be related (but not duplicate, as this bug is about all video players) to bug #32963 (Totem overrides XV_CONTRAST/XV_SATURATION to wrong values - Xv movies on i810/i945 have horrible colour/gamma).

Changed in xserver-xorg-video-intel:
status: Unknown → New
Bryce Harrington (bryce) wrote :

Hi joss-markham,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Rami Al-Rfou' (rmyeid) wrote :

I have the same problem it appeared suddenly in hardy heron although the video was working correctly before, maybe an update broke the situation. I am not sure.

Rami Al-Rfou' (rmyeid) wrote :
Rami Al-Rfou' (rmyeid) on 2008-10-24
Changed in xserver-xorg-video-intel:
assignee: nobody → ubuntu-x
status: Incomplete → Confirmed
assignee: ubuntu-x → ubuntu-x-swat
Bryce Harrington (bryce) on 2008-10-24
Changed in xserver-xorg-video-intel:
assignee: ubuntu-x-swat → nobody
importance: Undecided → Low
Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
Arash Abghari (arash-abghari) wrote :

Hi,

I have exactly the same problem described here. I am running Debian Testing (Squeeze) and my video card is Intel 855GM. Please let me know what information you need me to provide with.

Thanks

Changed in xserver-xorg-video-intel (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.