no direct rendering after upgrade to hardy

Bug #182284 reported by Tijmen Ruizendaal (timing) on 2008-01-12
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

After an upgrade from gutsy to hardy, i didn't have any direct rendering anymore, scrolling in webpages was slow and such.
The weird thing is that glxinfo shows: direct rendering: No (LIBGL_ALWAYS_INDIRECT set)

but, sudo glxinfo shows: direct rendering: Yes

unsetting LIBGL_ALWAYS_INDIRECT didn't do anything.

furthermore, the output of id:
uid=1000(tijmen) gid=1000(tijmen) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),104(scanner),108(lpadmin),110(admin),115(netdev),117(powerdev),1000(tijmen)

so, my user is in the video group.

The device: crw-rw-rw- 1 root video 226, 0 2008-01-12 11:34 card0

Output of lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I use the intel driver.

If I have this line in my xorg.conf. compiz and scrolling is working better then:
 Option "AccelMethod" "xaa".
Still no DRI though.

I think it's just some sort of setting, somewhere. If so, it's still a bug in the updating meganism.

Timo Aaltonen (tjaalton) wrote :

Please attach your /var/log/Xorg.0.log and /etc/X11/xorg.conf.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
stereoit (smol-robert) wrote :

Hi, I believe I might have same bug (i.e. slow scrolling in webpages, it was very fast before upgrade from Gutsy). For example google mail is very slow for me, top shows Xorg ranging from 80-100%.

rsmol@rsmol-laptop:~/bugs/wifi$ glxinfo |grep direct
direct rendering: Yes

rsmol@rsmol-laptop:~/bugs/wifi$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

I also attached requested logs.

stereoit (smol-robert) wrote :
unggnu (unggnu) wrote :

@stereoit
The slow scrolling should be fixed again with the today xserver-xorg-video-intel update.
Btw. it could be help full to regenerate your xorg.conf with the command "sudo dpkg-reconfigure xserver-xorg".

stereoit (smol-robert) wrote :

Hi,
today I upgraded to xserver-xorg-video-intel 2:2.2.1-1ubuntu4 and I can confirm scrolling seems to be much faster. When looking at 'top' it is 30-40% for Firefox and around 30% Xorg. So it helped me.

Will also try that dpkg-reconfigure xserver-xorg command.

Alvaro Kuolas (kuolas) wrote :

I'm using Hardy Alpha6 and there's no DRI.
This is a HP 530 with intel GMA950.

unggnu (unggnu) wrote :

Does the same issue happen with the Hardy LiveCD?

Bryce Harrington (bryce) wrote :

I think this is just a dupe of the EXA performance issue - bug 177492 - which is now fixed.
Please test against gutsy-rc when it's out (or gutsy-beta with all updates applied), and if it still occurs feel free to reopen this bug.

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Released

HP 530 with intel GMA950 using latest Hardy stuff and there's no DRI.
Using xserver-xorg-video-intel 2:2.2.1-1ubunto6

I just updated to the latest kernel, modules and other packages. So I'm at 2.6.24-14-generic now. Still no DRI. Is the fix for EXA performance issue not added to the packages yet?

Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers