Xserver opengl problems on i5-8259U

Bug #1797604 reported by Dmitry Dudkin on 2018-10-12
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

I have installed 18.04.1 server on Intel NUC NUC8i5BEH with minimal xinit and xserver-xorg-video-intel. But it has 2 major issues:
1. Huge Xorg CPU usage with intel driver...more than 110% on glxgears without vsync (with modesetting driver Xorg has zero CPU usage and very good Opengl performance)
2. on DRI3 glxgears it skip most frames and display one frame every 60-70 frames but reported FPS is doubled than on DRI2

to reproduce a problem install fresh server image of 18.04 and then install minimal xinit+xserver-xorg-video-intel. Put 20-intel.conf to enable intel driver. Run X by startx and then run glxgears.

20-intel.conf:

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "TearFree" "true"
# Option "DRI" "3"
EndSection

P.S. Before 18.04 I tried 16.04 with HWE kernel...on stock Xserver and Intel driver it just crash. On latest HWE xserver and HWE Intel driver it works the same as 18.04 because it has the same versions. But with old 1.18 xserver and HWE intel driver it works in DRI2 mode...Xorg CPU usage just 10% instead of 110% on xserver 1.19...The only problem - poor OPENGL performance (glxgears 5400 fps vs 8000 fps on 1.19 xserver)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xserver-xorg-video-intel 2:2.99.917+git20171229-1
ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
Uname: Linux 4.15.0-36-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
Date: Fri Oct 12 17:27:34 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Device [8086:3ea5] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:2074]
MachineType: Intel(R) Client Systems NUC8i5BEH
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-36-generic root=UUID=b5cc483d-ce2c-11e8-9739-94c691a2ff22 ro
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/19/2018
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BECFL357.86A.0048.2018.0919.2013
dmi.board.name: NUC8BEB
dmi.board.vendor: Intel Corporation
dmi.board.version: J72692-303
dmi.chassis.type: 3
dmi.chassis.vendor: Intel Corporation
dmi.chassis.version: 2.0
dmi.modalias: dmi:bvnIntelCorp.:bvrBECFL357.86A.0048.2018.0919.2013:bd09/19/2018:svnIntel(R)ClientSystems:pnNUC8i5BEH:pvrJ72747-302:rvnIntelCorporation:rnNUC8BEB:rvrJ72692-303:cvnIntelCorporation:ct3:cvr2.0:
dmi.product.family: Intel NUC
dmi.product.name: NUC8i5BEH
dmi.product.version: J72747-302
dmi.sys.vendor: Intel(R) Client Systems
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Dmitry Dudkin (ddv) wrote :

Hello,

Open bug in launchpad.net
https://bugs.launchpad.net/bugs/1797604

"I have installed 18.04.1 server on Intel NUC NUC8i5BEH with minimal xinit and xserver-xorg-video-intel. But it has 2 major issues:
1. Huge Xorg CPU usage with intel driver...more than 110% on glxgears without vsync (with modesetting driver Xorg has zero CPU usage and very good Opengl performance)
2. on DRI3 glxgears it skip most frames and display one frame every 60-70 frames but reported FPS is doubled than on DRI2

to reproduce a problem install fresh server image of 18.04 and then install minimal xinit+xserver-xorg-video-intel. Put 20-intel.conf to enable intel driver. Run X by startx and then run glxgears.

20-intel.conf:

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "TearFree" "true"
# Option "DRI" "3"
EndSection

P.S. Before 18.04 I tried 16.04 with HWE kernel...on stock Xserver and Intel driver it just crash. On latest HWE xserver and HWE Intel driver it works the same as 18.04 because it has the same versions. But with old 1.18 xserver and HWE intel driver it works in DRI2 mode...Xorg CPU usage just 10% instead of 110% on xserver 1.19...The only problem - poor OPENGL performance (glxgears 5400 fps vs 8000 fps on 1.19 xserver)"

Best regards,
--
Cristian Aravena Romero (caravena)

Dmitry Dudkin (ddv) wrote :

Also I found than glxgears has some artifacts (see attached pic) if running without vsync with Awesome WM in DRI2 mode/ Intel driver. In full screen mode or with vsync no artifacts. Also no artifacts if running without awesome WM.

Dmitry Dudkin (ddv) wrote :

commit e7bfc9065345085f767235eea8b148c356e5bd2b
Author: Liwei Song <email address hidden>
Date: Thu Mar 15 23:14:18 2018 -0400

    Add Coffeelake PCI IDs for U Skus

    Add the Coffeelake PCI IDs based on the following kernel patch:

    commit d29fe702c9cb682df99146d24d06e5455f043101
    Author: Anusha Srivatsa <email address hidden>
    Date: Thu Jun 8 16:41:07 2017 -0700

        drm/i915/cfl: Add Coffee Lake PCI IDs for U Sku.

    Signed-off-by: Liwei Song <email address hidden>

Hello Dmitry,

https://bugs.freedesktop.org/show_bug.cgi?id=108349#c1

"commit e7bfc9065345085f767235eea8b148c356e5bd2b
Author: Liwei Song <email address hidden>
Date: Thu Mar 15 23:14:18 2018 -0400

    Add Coffeelake PCI IDs for U Skus

    Add the Coffeelake PCI IDs based on the following kernel patch:

    commit d29fe702c9cb682df99146d24d06e5455f043101
    Author: Anusha Srivatsa <email address hidden>
    Date: Thu Jun 8 16:41:07 2017 -0700

        drm/i915/cfl: Add Coffee Lake PCI IDs for U Sku.

    Signed-off-by: Liwei Song <email address hidden>"

Best regards

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
tags: added: patch

Before 18.04 I tried linux-image-4.18.13-041813 kernel on 16.04 with HWE Xserver but the same. If you want I can try any newest kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline that already have this patch.

tags: added: rls-cc-incoming
tags: added: rls-bb-incoming
removed: rls-cc-incoming

@Dimitry,

Apparently, the problem is not precisely in the kernel(linux). The problem is in the Xorg-> Driver-> Intel. Because your computer is relatively very modern.

If you are very impatient, try the live-cd of the next version of Ubuntu (18.10):
http://releases.ubuntu.com/18.10/

To see if in this version your problem is solved.

Best regards,
--
Cristian Aravena Romero (caravena)

Will Cooke (willcooke) wrote :

Marking as bb-notfixing. This means the bug is not considered a release blocker, but can still be worked on and fixed.

tags: added: rls-bb-notfixing
removed: rls-bb-incoming
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Fix Released

Hello

>If you are very impatient, try the live-cd of the next version of Ubuntu (18.10):
>http://releases.ubuntu.com/18.10/

I tried 18.10 but the same problem. I guess that live-cd use modesetting driver by default and it works. But modesetting does not have TearFree options and I can't use it.
Also intel driver has the same version (2.99.917+git20171229) for 18.04 & 18.10 and both have the same problems.

Finally I have fixed the problem by compiling and installed latest git xf86-video-intel driver. Now everything works fine. Thanks.

Dmitry Dudkin (ddv) wrote :

Finally I have fixed the problem by compiling and installing latest git xf86-video-intel driver. Now everything works fine. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.