TV-out missing from xrandr output on Thinkpad z61t with Intel

Bug #178505 reported by zdzichu
2
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

After upgrading from Gutsy to Hardy I've lost TV-output on xrandr.

Screen 0: minimum 320 x 200, current 1440 x 900, maximum 2048 x 2048
VGA disconnected (normal left inverted right x axis y axis)
 Identifier: 0x4c
 Timestamp: 35176
 Subpixel: unknown
 Clones:
 CRTCs: 0 1
LVDS connected 1440x900+0+0 (0x4f) normal (normal left inverted right x axis y axis) 303mm x 190mm
 Identifier: 0x4d
 Timestamp: 35176
 Subpixel: horizontal rgb
 Clones:
 CRTC: 1
 CRTCs: 1
 EDID_DATA:
  00ffffffffffff0030ae334000000000
  000f0103801e1378eaae109658538c28
  24505421080001010101010101010101
  0101010101013226a04051841a303020
  36002fbe10000019d51fa04051841a30
  302036002fbe100000190000000f0090
  0a32900a28140100320c4811000000fe
  004c503134315750312d544c423200c7
 BACKLIGHT_CONTROL: kernel
  supported: native legacy combination kernel
 BACKLIGHT: 70 (0x00000046) range: (0,100)
  1440x900 (0x4e) 97.8MHz -HSync -VSync
        h: width 1440 start 1488 end 1520 total 1760 skew 0 clock 55.6KHz
        v: height 900 start 903 end 909 total 926 clock 60.0Hz
  1440x900 (0x4f) 81.5MHz -HSync -VSync
        h: width 1440 start 1488 end 1520 total 1760 skew 0 clock 46.3KHz
        v: height 900 start 903 end 909 total 926 clock 50.0Hz
  1280x800 (0x50) 83.5MHz
        h: width 1280 start 1344 end 1480 total 1680 skew 0 clock 49.7KHz
        v: height 800 start 801 end 804 total 828 clock 60.0Hz
  1280x768 (0x51) 80.1MHz
        h: width 1280 start 1344 end 1480 total 1680 skew 0 clock 47.7KHz
        v: height 768 start 769 end 772 total 795 clock 60.0Hz
  1024x768 (0x52) 65.0MHz -HSync -VSync
        h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
        v: height 768 start 771 end 777 total 806 clock 60.0Hz
  800x600 (0x53) 40.0MHz +HSync +VSync
        h: width 800 start 840 end 968 total 1056 skew 0 clock 37.9KHz
        v: height 600 start 601 end 605 total 628 clock 60.3Hz
  640x480 (0x54) 25.2MHz -HSync -VSync
        h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz
        v: height 480 start 490 end 492 total 525 clock 60.0Hz
  640x480 (0x55) 25.2MHz -HSync -VSync
        h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz
        v: height 480 start 490 end 492 total 525 clock 59.9Hz

Revision history for this message
zdzichu (zdzichu-gmail) wrote :
Revision history for this message
zdzichu (zdzichu-gmail) wrote :
Revision history for this message
zdzichu (zdzichu-gmail) wrote :
Revision history for this message
zdzichu (zdzichu-gmail) wrote :
Revision history for this message
zdzichu (zdzichu-gmail) wrote :

xserver-xorg-video-intel 2:2.2.0-1ubuntu1

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
slazZ (slazz) wrote :

Confirmed (Thinkpad R60)
But for me not only running hardy, also since xserver-xorg-video-intel (2:2.1.1-0ubuntu9.1) on gutsy.
With xserver-xorg-video-intel (2:2.1.1-0ubuntu9) tv-out is working (gutsy).

slazZ (slazz)
Changed in xserver-xorg-video-intel:
status: Triaged → Confirmed
Revision history for this message
slazZ (slazz) wrote :

I think the problem is caused by:
----snip----
  [Kyle McMartin, Bryce Harrington]
  * 06_sync_quirks.diff:
    - Sync TV out quirks with upstream
      (Closes LP: #131646)
----snap----
On gutsy since 2:2.1.1-0ubuntu9.1
and on hardy since 2:2.1.1-4ubuntu1

This is only an assumption, I did not invest further

Revision history for this message
zdzichu (zdzichu-gmail) wrote :

slazZ, good shot! X60 have the same PCI ID but do not have tv-out psychically, so we were bitten by quirk for it.

I've reported it as https://bugs.freedesktop.org/show_bug.cgi?id=14432

Revision history for this message
zdzichu (zdzichu-gmail) wrote :

It got fixed upstream. Please backport 2 changesets or update driver.

Revision history for this message
slazZ (slazz) wrote :

As no developer is assigned to this one, is there a chance that somebody will reckognize this fix at all?

Changed in xserver-xorg-video-intel:
status: New → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Revision history for this message
slazZ (slazz) wrote :

Fixed upstream

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.