3D-Accelerated Games cause X to crash with Intel Driver

Bug #178292 reported by Elias K Gardner on 2007-12-23
48
Affects Status Importance Assigned to Milestone
Mesa
Fix Released
Critical
mesa (Ubuntu)
Medium
Timo Aaltonen
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wine

I am using ubuntu 7.10 64 bit and wine 0.9.51 (this bug has existed partially since the early 0.9.4* releases of wine).

When wine runs some applications it causes me to log out and sign back into ubuntu. It appears to only be for 3D applications. Originally started with Civ 4 BTS, but now happens for warcraft 3 and various valve games on steam.

There is a similar bug about this on launchpad that appears to have been caused by nvidia drivers. I do not have an nvidia card. I have an intel x3100 in a thinkpad x61.

Related branches

Elias K Gardner (zorkerz) wrote :

here is a link to the related bug https://bugs.launchpad.net/bugs/139388

It would appear to occur whenever opengl is used in wine.

Verrier (my-verrier) wrote :

I've also been having this issue since I got my laptop in November (Dell M1330, Intel Mobile X3100).

I've had this issue both with World of Warcraft and Starcraft. It seems all "normal" windows applications work fine such as the Blizzard patcher, the Starcraft map editor, notepad, UltraEdit32, and other various windows applications. This happens both when running with Compiz installed (enabled and disabled) or uninstalled.

I have run PlasmaPong in WINE and it appears to run without crashing gnome (however the FPS is awful, but I didn't even bother looking into fixing that).

Hope that helps and that we can get this fixed -- I'll post any logs needed.

does plasmapong use opengl? is it a 3d game? I have been thinking this is a
3d application problem (meaning opengl I believe) but i don't really know
how to find that out. Do you know what package provides the drivers for the
x3100?

Yeah PlasmaPong uses something called Glut32.dll (http://www.opengl.org/resources/libraries/glut/), but it's not exactly OpenGL from what I understand. I'm with you in thinking it's a 3D application problem.. however even running World of Warcraft in direct3D also causes the same issue. I do know in my past googling that everyone who has had this problem it's been a driver issue which I suspect is the same here, however I've yet to find any drivers that fix it for the X3100.

Perhaps someone can enlighten us if this is indeed not a WINE issue :)

Scott Ritchie (scottritchie) wrote :

This is not a Wine bug - Wine should never be able to crash the whole system. It's a bug in your video driver that Wine's OpenGL usage is exposing.

unggnu (unggnu) wrote :

Please provide a Backtrace ( https://wiki.ubuntu.com/DebuggingXorg ) against current Hardy Intel driver.

Changed in xserver-xorg-video-intel:
status: New → Incomplete

sorry I do not know how to install xserver-xorg-cor-dbgsym from above linked
DebuggingXorg to do a backtrace. I added the repos to my sources.list from
DebuggingProgramCrash,
<https://wiki.ubuntu.com/DebuggingProgramCrash>replacing gutsy with
hardy. The page has not been updated for hardy yet so I
must be doing something wrong.

I have this bug now using wine 0.9.53. It worked fine with 0.9.52. Ubuntu64, Intel video. Another machine with nvidia works perfect using the same software. Easy to reproduce, just use wine to run a 3d game. Will try to downgrade to .52 if i manage to find the package...

Artemis3 (artemis3) wrote :

Ok, just tried downgrading to 0.9.52 and it actually does the same. So the culprit must lie elsewhere, must likely some recent update...

David Tomaschik (matir) wrote :

0.9.54 has the same issue.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
unggnu (unggnu) wrote :

Hardy Heron Alpha4 was recently released. It contains an updated version of the Intel driver. You can download and try the new Hardy Heron Alpha4 release from http://cdimage.ubuntu.com/releases/hardy/alpha-4/ . You should be able to then test the new driver via the LiveCD. Install Wine with a LiveCD is no problem if you have enough mem and maybe you can start a 3D game which results to a crash. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha4 .
Btw. I had a similar problem and it is fixed in Hardy.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
David Tomaschik (matir) wrote :

I'm running the Hardy Alpha 4 Release and still see the same behavior. X Backtrace:
Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6a) [0x483fea]
1: /lib/libc.so.6 [0x7f4afd850100]
2: /usr/lib/dri/i965_dri.so [0x7f4aea900139]
3: /usr/lib/xorg/modules/extensions//libglx.so(DoRender+0xcc) [0x7f4afc6179fc]
4: /usr/lib/xorg/modules/extensions//libglx.so [0x7f4afc61b7fc]
5: /usr/bin/X(Dispatch+0x2ef) [0x44ea6f]
6: /usr/bin/X(main+0x47d) [0x436b6d]
7: /lib/libc.so.6(__libc_start_main+0xf4) [0x7f4afd83c1c4]
8: /usr/bin/X(FontFileCompleteXLFD+0x281) [0x435ea9]

I'm going to attempt to debug somewhat.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
David Tomaschik (matir) wrote :

Best backtrace from gdb that I could manage is attached.

Daniel (daniel-oberski) wrote :

3D figures; this happens to me with blender.

here is a related bug report for wine

https://bugs.launchpad.net/ubuntu/+source/wine/+bug/185423

Daniel (daniel-oberski) wrote :

Hi

Installing the newest version (169.07) of the NVIDIA drivers completely fixed the problem for me.

As suggested here:

https://bugs.launchpad.net/ubuntu/+source/wine/+bug/139388

David Tomaschik (matir) wrote :

Because, as best as I can tell, the crash is in i965_dri.so, part of libgl1-mesa-dri, I've added that package to the bug. I'm not really sure what the underlying cause is, and for some reason, gdb won't load the mesa debug symbols even after I install the libgl1-mesa-dri-dbg package. If someone can tell me what I'm missing to get gdb to load that, I'd love to produce a backtrace with more detail.

David Tomaschik (matir) wrote :

By recompiling the libgl1-mesa-dri package from source without having it strip the binaries (DEB_BUILD_OPTIONS=nostrip), I was able to produce a more useful (IMHO) backtrace. Yes, this is not an official package, but I hope it's still useful. It's definitely segfaulting in i965_dri.so, so I guess this is strictly a mesa bug. I'm going to try to take a look at it a bit, but since I don't really know much about the mesa architecture, I doubt I'll find much.

Changed in mesa:
status: Unknown → Confirmed
Jesper Larsen (knorr) wrote :

Seems like the same issue as in a bug report I made

https://bugs.launchpad.net/ubuntu/+source/wine/+bug/182584

Ryan Sinn (ryan-sinn) wrote :

This is still an issue with Hardy Alpha5 and Wine 0.9.56

Changed in mesa:
status: Confirmed → Invalid
Ryan Sinn (ryan-sinn) wrote :

It's already been addressed and it has been fixed - from the developer. The Ubuntu package maintainers need to recompile the code from the latest source available.

For those of us using Intel-based video cards this is still an issue.

This has been fixed for over a month and a half from the MESA library developers...

We're currently waiting for the Ubuntu package maintainers to recompile the source and upload the new "official" package.

https://bugs.freedesktop.org/show_bug.cgi?id=13492

Timo Aaltonen (tjaalton) wrote :

We are tracking the 7.0.x-branch, and that commit was not applied to it. Either let upstream know that it's wanted for the stable branch, or let us know the commit(s) that fix this so we can backport it to our package.

Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Changed in mesa:
importance: Undecided → Medium
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :
Changed in mesa:
status: Confirmed → Triaged
milestone: none → hardy-alpha-6
Changed in mesa:
status: Unknown → Fix Released
Steve Langasek (vorlon) on 2008-03-05
Changed in mesa:
milestone: hardy-alpha-6 → ubuntu-8.04-beta
Timo Aaltonen (tjaalton) on 2008-03-05
Changed in mesa:
assignee: nobody → tjaalton
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.0.3~rc2-1ubuntu2

---------------
mesa (7.0.3~rc2-1ubuntu2) hardy; urgency=low

  [ Laurent Bigonville ]
  * debian/patches/105_vblank_fix.patch: Fix "drmWaitVBlank returned -1" error
    (LP: #186764)

  [ Timo Aaltonen ]
  * Add 106_i965_wine_fix.diff from upstream, "Only call
    ProgramStringNotify if program parsing succeeded". (LP: #178292)

 -- Timo Aaltonen <email address hidden> Wed, 12 Mar 2008 12:33:41 +0200

Changed in mesa:
status: Triaged → Fix Released
Ryan Sinn (ryan-sinn) wrote :

I am running the latest xserver-xorg-video-intel ... updated this morning / last night and I am still having this issue when running 3d applications in WINE. It restarts X without any warning.

If there's anything I can do to debug or troubleshoot this issue to help you, I will.

I am running WINE 0.9.57 and xserver-xorg-video intel 2:2.2.1-1ubuntu4

My hardware is a ThinkPad X61t with an Intel X3100 video card (GM965.)

Ryan Sinn (ryan-sinn) wrote :

I do have to say that OSD has started working since the last driver package update ... I had it turned on in Konversation, but it hadn't started working until 1ubuntu4.

Timo Aaltonen (tjaalton) wrote :

Wait until the mesa libs are available and upgrade.

Ryan Sinn (ryan-sinn) wrote :

Ok :) I saw the new xlibs today and the new intel driver and then the email about the bug being fixed and I thought I'd better try it again :)

Sorry -- this has been a problem for me since Early December (about a week after I installed Ubuntu on my new laptop...) I'm just a bit excited to see it fixed.

Ryan Sinn (ryan-sinn) wrote :

3d applications are now working with wine for me since the updated MESA drivers released today... 7.0.3~rc2-1ubuntu2.

This seems to be working :) Yay!

Ryan Sinn (ryan-sinn) wrote :

Do you have 7.0.3~rc2?

If not, check the box in "Sources" for Pre-Release packages in synaptic package manager and see if the updated intel packages fix it for you...

They've fixed the issue (for the most part) for me ... I'm still doing some testing.

Brian Rogers (brian-rogers) wrote :

My mesa packages are 7.0.3~rc2-1ubuntu3, and I'm still experiencing the X crash with 3D wine apps. This is on an i965.

Brian Rogers (brian-rogers) wrote :

Never mind, I can confirm that the issue is fixed for most programs.

The programs that still crash (Portal, Half-Life 2) are experiencing the bug reported at https://bugs.freedesktop.org/show_bug.cgi?id=14448 which currently has no upstream resolution.

Gohalien (gohalien) wrote :

I am experimenting this problem, I am runing wine-1.1.2 and xserver-xorg-video-intel 2:2.2.1-1ubuntu13.6, mesa 7.0.3~rc2-1ubuntu3, my hardware is Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03).
X is crashing when I try to run World of Warcraft in Wine, I tried with compiz enabled and disabled.

larsemil (emil-larsemil) wrote :

Also my X crashes when i try to run World of Warcraft in wine. My setup is working fine with the same version of wine and world of warcraft on a computer with nvidia-card.

Kubuntu 9.10

larsemil@mamin:~$ uname -r
2.6.31-12-generic

larsemil@mamin:~$ wine --version
wine-1.1.30-502-gd62d442

larsemil@mamin:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Package-versions:
xserver-xorg-video-intel 2:2.9.0-1ubuntu1

Brian Rogers (brian-rogers) wrote :

larsemil, you might be experiencing bug 444039. Take a look at the instructions I posted there to bypass the problem. If that solves it for both you and the original reporter, then we have confirmation that it's a bug with mode switching and you'll want to subscribe to that bug.

Changed in mesa:
importance: Unknown → Critical
Changed in mesa:
importance: Critical → Unknown
Changed in mesa:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.