Xorg crashed with SIGSEGV

Bug #173265 reported by Emilio Pozuelo Monfort on 2007-12-01
44
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
High
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

I was playing a video in Totem. There seemed to be a problem with Totem or most likely some gstreamer plugins as the video was in black&white but it shouldn't.

When I was forwarding then Xorg crashed and sent me to the login window.

ProblemType: Crash
Architecture: i386
Date: Sat Dec 1 16:24:02 2007
Disassembly: 0xb7af410e:
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/Xorg
NonfreeKernelModules: cdrom
Package: xserver-xorg-core 2:1.4.1~git20071119-1ubuntu1
PackageArchitecture: i386
ProcCmdline: /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7
ProcCwd: /etc/X11
ProcEnviron:
 LANGUAGE=
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: xorg-server
Stacktrace: #0 0xb7af410e in ?? ()
StacktraceTop: ?? ()
ThreadStacktrace:

Title: Xorg crashed with SIGSEGV
Uname: Linux pochu 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
UserGroups:

Created an attachment (id=12365)
bt full of crash, created based on core dump (still available if needed)

Created an attachment (id=12389)
xv crash #2

This is another crash related to XV. I'm adding it here since it is in some relation with closing XV "sessions".

My hardware is described here;
http://lists.freedesktop.org/archives/xorg/2007-October/029604.html

Created an attachment (id=12390)
xv crash #3

Both #2 and #3 happened when I used gmplayer and opened a second session to play a second video after the first finished (but the application still open). Maybe the mplayer code does not properly handle cases where XV is already used (the error message claimed that in both cases).

Just to note: The core dumps of all crashes are still available.

Way to reproduce:
execute
mplayer -vo xv some_video.avi
in window 1
mplayer -vo xv another_video.avi
in window 2

You can take the same avis, of course. Note that the backtraces differ, but the reason seems to be the same.

Created an attachment (id=12551)
xv crash #4

This with the two mplayer sessions approach of last comment, but I haven't tested twice, so the next attempt might cause a different backtrace.

Upping the severity since this causes a server crash.

I'm not able to reproduce this on my 855GM with 2.1.99 driver, also not reproducible on 915gm/945gm with git tip driver.

Ok, let's try it more detailed:
1) mplayer -vo xv -ao alsa some_viod.avi
2) Switch to konsole/xterm etc. (I'm on konsole), so mplayer window is completely hidden by konsole window. (I use Alt + Tab)
3) Ctrl + Z
4) bg
5) 2 x cursor up (so you get the command again.
6) Enter
7) Now make mplayer visible by a mouse click on task bar.

I'm sure I got it with simpler ways too, but I guess the problem is the xv window in the background while trying to open the second xv.

Note that reproduceablity is still sometimes (30 %), not always, I'm trying to work out if it has to do with the mouse pointer position.

It hope I'm now at 100 % reproduceability:

1) mplayer -vo xv -ao alsa somevid.avi
2) Alt + Tab to go back to console
3) Ctrl + Z
4) Wait 15 seconds
5) fg
6) Now bring mplayer window in foreground
7) Crash

What we need is a new title for the bug.

As an additional note: If the konsole window does not completely hide the mplayer window, I get screen corruption instead.

It's even simpler: You just need to completely hide the mplayer window for more than 10 (even less might be enough) seconds you don't need to stop mplayer.

(In reply to comment #11)
> It hope I'm now at 100 % reproduceability:

After this (but using Totem instead) I am able to reproduce this on DELL Latitude D820 with Intel 945GM. Started happening when Ubuntu Hardy (current dev release) switched to version 2.1.99 of the "intel" X.org driver.

It's pretty annoying, so if I can do anything (non-dev :)) to help fix this, just let me know.

(In reply to comment #14)

Backtraces might be useful. http://wiki.debian.org/XStrikeForce/XserverDebugging

Just a non-dev opinion.

BTW: Do you also see the screen corruption when the XV window is half-hidden?

(In reply to comment #15)
> Backtraces might be useful.
> http://wiki.debian.org/XStrikeForce/XserverDebugging

I'll try to provide some later.

> BTW: Do you also see the screen corruption when the XV window is half-hidden?

No screen corruption until the crash. When it crashes, it sometimes restarts back to the GDM screen, sometimes I see some full-screen screen corruption... wierd lines, dots and such. At that point the system does not react to any key presses, so it needs a cold start.

In reply to comment #11)
> It hope I'm now at 100 % reproduceability:
Using Willi's method,I can reporduce this bug 0n my 855gm machine with intel-2.2.0 driver.but I can not reproduce this bug on 945gm with latest git code.Interestingly,only when full-cover the mplayer window with console window,then can reproduce this bug and it's just xserver crash,not the whole system(although apparently the keyboard has no response,in fact it has, only you do VT switch this time that can crash the whole system)

back trace on my 855gm
Backtrace:
0: X(xf86SigHandler+0x80) [0x80d0850]
1: [0xffffe420]
2: X [0x80df45b]
3: /opt/X11R7/lib/xorg/modules/extensions//libextmod.so(XvdiPutImage+0x17d) [0xb7ea588d]
4: /opt/X11R7/lib/xorg/modules/extensions//libextmod.so [0xb7ea83fc]
5: X [0x81483ed]
6: X(Dispatch+0x357) [0x8087597]
7: X(main+0x490) [0x806e2d0]
8: /lib/libc.so.6(__libc_start_main+0xdc) [0x6657e4]
9: X(FontFileCompleteXLFD+0xa1) [0x806d821]

Fatal server error:
Caught signal 11. Server aborting

> you do VT switch this time that can crash the whole system)

I'm in no way experiencing full system crashes, but I have NoTrapSignals On, as I always ended up with a frozen system when I experienced the recently fixed VT-switch bug and had NoTrapSignals off. Also, it's much simpler to get backtraces.

What surprises me is that your backtrace ends in xf86sighandler, mine always end in some memory related function, in libc, or in the kernel.

moreover,on 915gm using the same environment just as my 855gm,it seems there is no this bug problem.

(In reply to comment #20)
> moreover,on 915gm using the same environment just as my 855gm,it seems there is
> no this bug problem.

Don't the 9xx chips allow for more than one XV playing method? If so, did you try with other than the default port? On 855GM, I only have port 73, Adaptor #0: "Intel(R) Video Overlay", according to xvinfo.

In reply to comment #21)

Yes, On the 9xx(<965) chips there are two XV playing method:"Intel(R) Textured Video" and "Intel(R) Video Overlay". On my 915gm, the default XV playing method is "Intel(R) Textured Video" and using this default option can not reproduce this bug.When switch to "Intel(R) Video Overlay",the bug can reproduce everytime.Moreover,under "Intel(R) Video Overlay",using intel-2.2.0 driver can reproduce this bug,if using latest git code can not reproduce. So,my conclusion is:using intel-2.2.0 with "Intel(R) Video Overlay" XV playing method can reproduce this bug.

(In reply to comment #22)
> using intel-2.2.0 driver can
> reproduce this bug,if using latest git code can not reproduce. So,my conclusion

Do you mean latest git of everything or just latest git of intel driver? I ask because the difference on the intel driver is just TV out related, so it seems unlikely to be really fixed. (And I can reproduce it with latest intel driver git on 855GM)

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=summary

(In reply to comment #23)
yeah,my old conclusion is wrong.I do more detailed testing again:
I used the xserver 1.4 with latest git source code or relese version driver(intel-2.2.0) both can reproduce this bug.When I used xserver git source with latest intel git source code or release version driver(intel-2.2.0) can not reproduce this bug. So this bug is not intel dirver’s problem.Willi,You can try using the latest xserver git source code and see if this problem gone or not.

Using what's currently in debian unstable (2:1.4.1~git20071119-1), I can still reproduce this bug. I could test latest git, but that would take some time.

Created an attachment (id=12725)
latest version of crash backtrace

(In reply to comment #24)
Just to ensure we do the same when we try to reproduce the bug, could you describe how you do it exactly? (I'm especially interested in the timing and the video you use)
What I do is:
1) mplayer -vo xv some_vid.avi
   (the video I use is 720x544, I can't share because of the size and possible copyright issues)
2) put konsole window in foreground - best is probably to ensure before 1) that it covers the whole screen (except taskbar in my case).
3) Wait 20 seconds (10 seems to be enough but I usually wait 20 seconds to be on the "safe" side)
4) bring mplayer window into foreground and let the crash happen.

I can reproduce this on FJS Amilo Pi1505 with Intel GMA950 - hiding Mplayer with XV video overlay for more than ~10 seconds and then bringing it to foreground or quitting mplayer crashes xserver. Textured video doesn't crash (but tears instead :) ). I'm running Debian unstable with latest repo xorg and driver.
Backtrace:
0: /usr/bin/X(xf86SigHandler+0x7e) [0x80c660e]
1: [0xffffe420]
2: /lib/i686/cmov/libc.so.6(vsnprintf+0xb4) [0xb7d9f874]
3: /usr/bin/X(LogVWrite+0xb7) [0x81bac47]
4: /usr/bin/X(LogVMessageVerb+0x99) [0x81bb189]
5: /usr/bin/X(xf86VDrvMsgVerb+0xda) [0x80d01ca]
6: /usr/bin/X(xf86DrvMsg+0x3d) [0x80d11ad]
7: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b72207]
8: /usr/lib/xorg/modules/drivers//intel_drv.so(i830_free_memory+0x24) [0xb7b72fa
4]
9: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b77d87]
10: /usr/bin/X [0x80d94f5]
11: /usr/lib/xorg/modules/extensions//libextmod.so(XvdiPutImage+0x178) [0xb7c226
d8]
12: /usr/lib/xorg/modules/extensions//libextmod.so [0xb7c25546]
13: /usr/bin/X [0x814d58e]
14: /usr/bin/X(Dispatch+0x2bf) [0x808d1ff]
15: /usr/bin/X(main+0x48b) [0x807474b]
16: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d53450]
17: /usr/bin/X(FontFileCompleteXLFD+0x20d) [0x8073ac1]

Emilio Pozuelo Monfort (pochu) wrote :

I was playing a video in Totem. There seemed to be a problem with Totem or most likely some gstreamer plugins as the video was in black&white but it shouldn't.

When I was forwarding then Xorg crashed and sent me to the login window.

ProblemType: Crash
Architecture: i386
Date: Sat Dec 1 16:24:02 2007
Disassembly: 0xb7af410e:
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/Xorg
NonfreeKernelModules: cdrom
Package: xserver-xorg-core 2:1.4.1~git20071119-1ubuntu1
PackageArchitecture: i386
ProcCmdline: /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7
ProcCwd: /etc/X11
ProcEnviron:
 LANGUAGE=
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: xorg-server
Stacktrace: #0 0xb7af410e in ?? ()
StacktraceTop: ?? ()
ThreadStacktrace:

Title: Xorg crashed with SIGSEGV
Uname: Linux pochu 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
UserGroups:

Emilio Pozuelo Monfort (pochu) wrote :

StacktraceTop:?? ()

Changed in xorg-server:
importance: Undecided → Medium

Created an attachment (id=13087)
latest backtrace

As I said ealier, backtraces vary a little bit, but the I830PutImage is always involved. Note that yesterday I found bug in the debian BTS that describes a similar issue with the ati driver. http://bugs.debian.org/455837

What I wanted to post before but didn't is:
I can still reproduce this bug with the latest debian packages 2:1.4.1~git20071212-1 of xserver and latest git of intel driver.

I've had a (similar?) crash several times running Ubuntu Hardy, with xserver 2:1.4.1~git20071119-1ubuntu1 and the -intel driver 2:2.2.0-1ubuntu1.

I've put a couple of backtraces in https://launchpad.net/bugs/173265 - the way to get the crash was similar - opening a video in totem, hiding it, and bringing it to the top a few seconds later.

I have an Intel gma 915 mobile:
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

Emilio Pozuelo Monfort (pochu) wrote :
Download full text (6.1 KiB)

I've reproduced this running X under gdb through ssh. This is the backtrace:

(gdb) cont
Continuing.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7c846b0 (LWP 5643)]
0xb7d9df8b in strlen () from /lib/tls/i686/cmov/libc.so.6
(gdb) backtrace full
#0 0xb7d9df8b in strlen () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#1 0xb7d6d6c2 in vfprintf () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0xb7d8e8f4 in vsnprintf () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3 0x081bee37 in LogVWrite (verb=136350816, f=0x83f21f0 "(EE) intel(0): Failed to mprotect %s: %s\n", args=0xbfc1958c "\001") at ../../os/log.c:264
        len = <value optimized out>
        tmpBuffer = "(EE) intel(0): Failed to mprotect ne a\n\000ane a, not enabling on plane a\n\000 801 804 816 -hsync -vsync (49.0 kHz)\n\000/75dpi/:unscaled,\n\t/usr/share/fonts/X11/Type1,\n\t/usr/share/fonts/X11/100dpi,\n\t/usr/share/"...
#4 0x081bf3b9 in LogVMessageVerb (type=X_ERROR, verb=0, format=0x8425d08 "intel(0): Failed to mprotect %s: %s\n", args=0xbfc1958c "\001")
    at ../../os/log.c:368
        s = 0x81d8aab "(EE)"
#5 0x080d110a in xf86VDrvMsgVerb (scrnIndex=0, type=X_ERROR, verb=1, format=0xb7b76e06 "Failed to mprotect %s: %s\n", args=0xbfc1958c "\001")
    at ../../../../hw/xfree86/common/xf86Helper.c:1322
No locals.
#6 0x080d20ed in xf86DrvMsg (scrnIndex=0, type=X_ERROR, format=0xb7b76e06 "Failed to mprotect %s: %s\n") at ../../../../hw/xfree86/common/xf86Helper.c:1348
        ap = 0xbfc1958c "\001"
#7 0xb7b58347 in i830_unbind_memory (pScrn=0x821be58, mem=0x8442720) at ../../src/i830_memory.c:226
No locals.
#8 0xb7b59104 in i830_free_memory (pScrn=0x821be58, mem=0x8442720) at ../../src/i830_memory.c:269
No locals.
#9 0xb7b5dee7 in I830PutImage (pScrn=0x821be58, src_x=<value optimized out>, src_y=<value optimized out>, drw_x=236, drw_y=74, src_w=320, src_h=240,
    drw_w=808, drw_h=606, id=808596553,
    buf=0xa1cbf000 "\214\214\214\214\214\213\212\210\210\207\206\205\205\205\206\206\203\202\201\200~{xwwwwwwxxyz{||||||\177\177\177~~\177\177nacdca_]\\]_abba_[`YSMJJMRK6W\200\210\213\214\204S!\f\n\f\r\r\n\n\n\n\n\n\n\n\n", '\t' <repeats 53 times>, "\n\v\v\v\v\v\v\v\f\f\f\r\016\016\017\020\021\022\023\024\024\026\031\037&-13455558=CGIHFD@Ac\177^?UTQX"..., width=320, height=240, sync=0, clipBoxes=0xbfc198a4, data=0x822e2f4, pDraw=0x840f4b8) at ../../src/i830_video.c:2325
        pI830 = (I830Ptr) 0x821d848
        pScreen = (ScreenPtr) 0x8228df8
        pPixmap = <value optimized out>
        x1 = 0
        x2 = 20971520
        y1 = 0
        y2 = 15728640
        srcPitch = 320
        srcPitch2 = 160
        dstPitch = 192
        destId = 808596553
        top = <value optimized out>
        left = <value optimized out>
        npixels = <value optimized out>
        nlines = <value optimized out>
        size = 138240
        dstBox = {x1 = 236, y1 = 74, x2 = 1044, y2 = 680}
        pitchAlignMask = <value optimized out>
        alloc_size = 276480
        extraLinear = <value optimized out>
        crtc = <value optimized out>
#10 0x080da445 in xf86XVPutImage (client=0x8422108,...

Read more...

Download full text (5.2 KiB)

Second try:

(gdb) bt full
#0 0xb7b7810e in i830_free_memory (pScrn=0x821be58, mem=0x86d87d8) at ../../src/i830_memory.c:289
No locals.
#1 0xb7b7cee7 in I830PutImage (pScrn=0x821be58, src_x=<value optimized out>, src_y=<value optimized out>, drw_x=106, drw_y=0, src_w=320, src_h=240,
    drw_w=1066, drw_h=800, id=808596553,
    buf=0xa252c000 "\027\027\027\026\026\026\026\026\026\016\t\n\020\030\036 \032\033\033\032\031\030\027\027\025\027\030\031\026\022\021\024 %*//+#\034\025\024\034#\037\030\030\032\031\027\026\024\021\017\r\f\023!.8967:<:7553.) #5>:3/,)(('%!\034\031\032\034\035\037!\"$%\"\037\037\037\037\037\037\037!\"\"###$$*7GSSPTUQ<\036\025\027\026\027\032\036\035\037#\037\022\033Mbfghijkkkjjjjjjjfdfge^TLF@@PabWOSXXXXXXXWVVVVVVVV", 'U' <repeats 15 times>..., width=320, height=240,
    sync=0, clipBoxes=0xbfd47034, data=0x822e2f4, pDraw=0x846f850) at ../../src/i830_video.c:2325
        pI830 = (I830Ptr) 0x821d848
        pScreen = (ScreenPtr) 0x8228df8
        pPixmap = <value optimized out>
        x1 = 0
        x2 = 20971520
        y1 = 0
        y2 = 15728640
        srcPitch = 320
        srcPitch2 = 160
        dstPitch = 192
        destId = 808596553
        top = <value optimized out>
        left = <value optimized out>
        npixels = <value optimized out>
        nlines = <value optimized out>
        size = 138240
        dstBox = {x1 = 106, y1 = 0, x2 = 1172, y2 = 800}
        pitchAlignMask = <value optimized out>
        alloc_size = 276480
        extraLinear = <value optimized out>
        crtc = <value optimized out>
#2 0x080da445 in xf86XVPutImage (client=0x886aa30, pDraw=0x846f850, pPort=0x822d680, pGC=0x839ba40, src_x=<value optimized out>,
    src_y=<value optimized out>, src_w=<value optimized out>, src_h=<value optimized out>, drw_x=0, drw_y=0, drw_w=<value optimized out>,
    drw_h=<value optimized out>, format=0x8259230,
    data=0xa252c000 "\027\027\027\026\026\026\026\026\026\016\t\n\020\030\036 \032\033\033\032\031\030\027\027\025\027\030\031\026\022\021\024 %*//+#\034\025\024\034#\037\030\030\032\031\027\026\024\021\017\r\f\023!.8967:<:7553.) #5>:3/,)(('%!\034\031\032\034\035\037!\"$%\"\037\037\037\037\037\037\037!\"\"###$$*7GSSPTUQ<\036\025\027\026\027\032\036\035\037#\037\022\033Mbfghijkkkjjjjjjjfdfge^TLF@@PabWOSXXXXXXXWVVVVVVVV", 'U' <repeats 15 times>..., sync=0,
    width=<value optimized out>, height=<value optimized out>) at ../../../../hw/xfree86/common/xf86xv.c:1777
        portPriv = <value optimized out>
        WinRegion = {extents = {x1 = 106, y1 = 0, x2 = 1172, y2 = 800}, data = 0x0}
        ClipRegion = {extents = {x1 = 106, y1 = 0, x2 = 1172, y2 = 800}, data = 0x83e16d8}
        ret = 0
#3 0xb7c2f7f8 in XvdiPutImage (client=0x886aa30, pDraw=0x846f850, pPort=0x822d680, pGC=0x839ba40, src_x=<value optimized out>, src_y=<value optimized out>,
    src_w=<value optimized out>, src_h=<value optimized out>, drw_x=<value optimized out>, drw_y=<value optimized out>, drw_w=<value optimized out>,
    drw_h=<value optimized out>, image=0x8259230,
    data=0xa252c000 "\027\027\027\026\026\026\026\026\026\016\t\n\020\030\036 \032\033\033\032\031\030\027\027\025\027\030\031\026\022\021\02...

Read more...

Emilio Pozuelo Monfort (pochu) wrote :

As Julien Cristau has pointed to me on irc, this looks like fdo #13108. There are some specific details to reproduce this crash, and I've got it with a similar approach: playing a video in totem, hiding it, and bring it back.

I have an intel gma 915 mobile
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

Changed in xorg-server:
status: Unknown → Confirmed
ogc (hackrez) wrote :

Someone should raise severity of this bug. This makes my Ubuntu Alpha1 completely unusable. Steps to reproduce for me: Start tvtime, minimize it for few minutes and then restore. Screen fills with some noise and Xorg restarts (sometimes it's hard crash and nothing helps). Another way to reproduce. Start tvtime, put some other window on to on it. Wait few minutes, minimize the other window.
My card is VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03). Happens with -intel or -810 drivers

Created an attachment (id=13192)
Possible fix

This seems to fix the problem here, can you confirm?

(In reply to comment #32)

> This seems to fix the problem here, can you confirm?

Yes, it does. Thanks for the patch.

At line 2688, there is another free on pPriv->buf that's not set to NULL. Just noting that as I remember there were similar fixes for 2.2.

(In reply to comment #33)
> At line 2688, there is another free on pPriv->buf that's not set to NULL.

Thanks. Fixes pushed to master branch, but leaving open for the 2.2.1 tracker.

Bryce Harrington (bryce) wrote :

Please test the following package, which incorporates the aforementioned Debian patch:

http://people.ubuntu.com/~bryce/Uploads/xserver-xorg-video-intel_2.2.0-1ubuntu2_i386.deb

Changed in xorg-server:
assignee: nobody → bryceharrington
status: New → Fix Committed
Emilio Pozuelo Monfort (pochu) wrote :

It haven't fixed it.

Opening a video in totem, going to a different workspace, and ~15 seconds after that going back to the video crashed X.
And yes, I restarted xorg after installing the driver (in fact I rebooted)

Bryce Harrington (bryce) wrote :

Okay, let me know if/when someone finds a better patch to propose. Maybe what was committed upstream differs from what was mentioned in the debian bug report.

Changed in xorg-server:
assignee: bryceharrington → nobody
status: Fix Committed → Confirmed
Bryce Harrington (bryce) wrote :

Moving to -intel package and upping priority.

Changed in xorg-server:
importance: Medium → High
ogc (hackrez) wrote :

It haven't fixed it for me either. Still crashes with above steps. Also image is weird on shutdown. Ubuntu logo is rendered in stripes and repeated across the screen several times

Seems to work fine on my i855GM, I'll push this patch to Gentoo to see if it helps more users.

Thanks to all for the patch.

Changed in xserver-xorg-video-intel:
milestone: none → ubuntu-8.04-beta
Nikopol (markboydell) wrote :

the new Deb doesn't fix it here either - and it's present in alpha 2. A bit of a shame - I guess Vesa is the only option to keep it functional at the mo' :(

I've also found that the gnome-panel becomes unclickable (and becomes blank) - not sure if it's related but it seems to be linked with maximising the video windows while trying to figure out the crash. Strangely even restarting X does not resolve the issue so I've put myself a link to gnome-terminal on the Desktop

Nikopol (markboydell) wrote :

Seems to have found a workaround by using the i810 driver with 915resolution - can no longer replicate the bug when doing that.

ogc (hackrez) wrote :

Thanks Nikopol, i810 works for me also. And my post above is somewhat incorrect -- i810 is not affected by this bug. It's just Ubuntu graphical tool can't change the driver for some reason. Had manually edit xorg.conf.

Nikopol (markboydell) wrote :

Just to clarify the workaround - it's actually stopped working properly. For some reason gdm login is in the correct screen format but as soon as I log on it goes to something non widescreen and warped. Still workable (typing on it now) but not a perfect workaround yet.

*** Bug 12960 has been marked as a duplicate of this bug. ***

Pulled fix into 2.2 branch.

Changed in xorg-server:
status: Confirmed → Fix Released
Emilio Pozuelo Monfort (pochu) wrote :

Can't reproduce anymore with 2:2.2.0+git20080107-1ubuntu1:

xserver-xorg-video-intel (2:2.2.0+git20080107-1) experimental; urgency=low

[...]
    + Xv window hidden for a little while no longer causes segfaults.
      Closes: #457587

 -- David Nusinow <email address hidden> Mon, 07 Jan 2008 22:41:51 -0500

Dunno why the other deb didn't worked, but looks fixed now.

Cheers

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Changed in xorg-server:
importance: Unknown → High
Changed in xorg-server:
importance: High → Unknown
Changed in xorg-server:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.