hardware acceleration fails after numerous suspends

Bug #1682364 reported by Igor Grabin on 2017-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

the system is a thinkpad x220t. I don't shut it down, just suspend/resume. past 3 days uptime and 21 suspends I got slow graphics and X at 80% cpu, with those lines in /var/log/Xorg.0.log:
[115619.748] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[115619.796] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[115755.059] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[115755.059] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[119211.856] (EE) intel(0): Failed to submit rendering commands (Input/output error), disabling acceleration.
[119211.857] (EE) intel(0): When reporting this, please include /sys/class/drm/card0/error and the full dmesg.

around the same time in dmesg:
[119206.581790] [drm] stuck on render ring
[119206.582299] [drm] GPU HANG: ecode 6:0:0xf288fffc, in Xorg [793], reason: Ring hung, action: reset
[119206.584402] drm/i915: Resetting chip after gpu hang
[119212.581861] [drm] stuck on render ring
[119212.582383] [drm] GPU HANG: ecode 6:0:0xf288fff8, in Xorg [793], reason: Ring hung, action: reset
[119212.582478] [drm:i915_set_reset_status [i915]] *ERROR* gpu hanging too fast, banning!
[119212.584508] drm/i915: Resetting chip after gpu hang

# lsb_release -rd
Description: Ubuntu 16.04.2 LTS
Release: 16.04
# apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.99.917+git20160325-1ubuntu1.2
  Candidate: 2:2.99.917+git20160325-1ubuntu1.2
  Version table:
 *** 2:2.99.917+git20160325-1ubuntu1.2 500
        500 http://ua.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:2.99.917+git20160325-1ubuntu1 500
        500 http://ua.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
ProcVersionSignature: Ubuntu 4.4.0-71.92-generic 4.4.49
Uname: Linux 4.4.0-71-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
Date: Thu Apr 13 10:39:33 2017
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)

Igor Grabin (cacodem0n) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers