rendercheck claims that 'blend' 'add' operation renders incorrectly

Bug #1670945 reported by Mikko Rantalainen on 2017-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

$ rendercheck -o add -t blend
...
Beginning Add blend test on b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
           R G B A
got: 0.00 0.00 0.00 1.00
expected: 1.00 1.00 1.00 1.00
src color: 0.00 0.00 0.00 1.00 (a8)
dst color: 1.00 1.00 1.00 1.00
src: 1x1R a8, dst: b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
           R G B A
got: 0.00 0.00 0.00 1.00
expected: 1.00 1.00 1.00 1.00
src color: 0.00 0.00 0.00 1.00 (a8)
dst color: 1.00 1.00 1.00 1.00
src: 1x1R a8, dst: b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
           R G B A
got: 0.00 0.00 0.00 1.00
expected: 1.00 1.00 1.00 1.00
src color: 0.00 0.00 0.00 1.00 (a8)
dst color: 1.00 1.00 1.00 1.00
src: 1x1R a8, dst: b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
           R G B A
got: 0.00 0.00 0.00 1.00
expected: 1.00 1.00 1.00 1.00
src color: 0.00 0.00 0.00 1.00 (a8)
dst color: 1.00 1.00 1.00 1.00
src: 1x1R a8, dst: b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
           R G B A
got: 0.00 0.00 0.00 1.00
expected: 1.00 1.00 1.00 1.00
src color: 0.00 0.00 0.00 1.00 (a8)
dst color: 1.00 1.00 1.00 1.00
src: 1x1R a8, dst: b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
           R G B A
got: 0.00 0.00 0.00 1.00
expected: 1.00 1.00 1.00 1.00
src color: 0.00 0.00 0.00 1.00 (a8)
dst color: 1.00 1.00 1.00 1.00
src: 1x1R a8, dst: b8g8r8a8
Add blend test error of 64.0000 at (0, 0) --
...

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
 Identifier "Intel Graphics"
 Driver "intel"
 Option "XvPreferOverlay" "false"
 Option "VSync" "false"
 Option "TripleBuffer" "false"
 Option "TearFree" "true"
EndSection

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
ProcVersionSignature: Ubuntu 4.8.0-39.42~16.04.1-lowlatency 4.8.17
Uname: Linux 4.8.0-39-lowlatency x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
BootLog: system: clean, 442787/1933312 files, 3477778/7721472 blocks
CompizPlugins: [core,composite,opengl,decor,compiztoolbox,mousepoll,move,resize,gnomecompat,wall,imgpng,vpswitch,place,snap,grid,dbus,regex,resizeinfo,session,unitymtgrabhandles,animation,expo,ezoom,fade,scale,workarounds,unityshell]
CompositorRunning: None
CurrentDesktop: MATE
Date: Wed Mar 8 08:08:24 2017
DistUpgraded: 2016-11-14 12:59:58,597 ERROR SystemError from cache.commit(): installArchives() failed
DistroCodename: xenial
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0162] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. P8 series motherboard [1043:84ca]
InstallationDate: Installed on 2009-10-08 (2707 days ago)
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091008)
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-39-lowlatency root=UUID=23b87e6c-20b4-4242-9489-1599d62abcce ro resume=UUID=fb90e965-920d-4276-85b4-e0b72c4b0a6b delayacct quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to xenial on 2016-11-14 (113 days ago)
dmi.bios.date: 08/20/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1401
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8H77-M PRO
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1401:bd08/20/2013:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8H77-MPRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.6-0ubuntu0.16.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Tue Mar 7 22:07:09 2017
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.4-0ubuntu0.2

Mikko Rantalainen (mira) wrote :
Mikko Rantalainen (mira) wrote :

Also broken: rendercheck -t composite -o add -f a8r8g8b8,a8

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers