Ubuntu

[Hardy] [XPS M1330] Resume from suspend/hibernate doesn't always work (i965)

Reported by Christophe Dumez on 2007-11-25
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

I have a XPS M1330 with an intel video card (using xorg-driver-intel). Under Ubuntu Gutsy, when I try to put the computer into sleep mode, it usually works fine but sometimes it won't work:
- Screen is switched off but blue LED on the front of the laptop is still on (although it should be blinking slowly) and the CPU fan is still working. Once it is in this state, I couldn't find a way to resume my session : I had to switch the computer off manually (keep pressing power button during 5 secs).

What could be causing it?

Suspend and Hibernate are known issues with Linux in general, and certainly Ubuntu is no exception. For now, I would suggest the workaround in http://linux.dell.com/wiki/index.php/Ubuntu_7.10/Issues/8400M_Suspend_Hibernate-Failure (this is for nVidia, but should also works for Intel video cards). Unfortunately, expecting suspend and hibernate to work 100% of the time is not a reality at this time, but are diligently working to get there at some point.

Changed in dell:
status: New → Confirmed
Albert (albert-mahonis) wrote :

Following that workaround it seems to work better, but what I've found is that the netwok gets disabled after suspend, and you can't enable it anyway (/etc/init.d/networking restart does not work, nor ifconfig eth0 or wlan0 up...).

I noticed the same problem here. After resuming, I must sometimes reboot the
computer because the network does not work anymore.

network-manager just keeps displayed old access points (that aren't
reachable anymore). I tried "/etc/init.d/networking restart" and it doesn't
work here either. I tried to log off/ relog in but then it displays that I
have no network interfaces.

On Nov 27, 2007 10:41 PM, Albert <email address hidden> wrote:

> Following that workaround it seems to work better, but what I've found
> is that the netwok gets disabled after suspend, and you can't enable it
> anyway (/etc/init.d/networking restart does not work, nor ifconfig eth0
> or wlan0 up...).
>
> --
> [XPS M1330] sleep mode doesn't always work
> https://bugs.launchpad.net/bugs/164974
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Albert, I filled another report concerning the network failure on resume: https://bugs.launchpad.net/dell/+bug/172522

Albert (albert-mahonis) wrote :

Ok, I will follow that report. Thanks.

Albert

Christophe Dumez (hydr0g3n) wrote :

I'm joining my kern.log after a failed suspend on Dec 3 13:52:56

I hope this can help.

Christophe Dumez (hydr0g3n) wrote :

$ uname -a
Linux chris-laptop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Christophe Dumez (hydr0g3n) wrote :
robe (r-evert) wrote :

Yeah, thanks for the hint about Suspend/Resume with the M1330.

As I mentioned earlier, on Kubuntu when I stop KDM all my Consoles are black and Monitor switches off when I change to one. When I start an X-Session then (blindly) I get a save Hibernate/Resume. Otherwise same thing happens with The Screen switching off but the Machine still runs.

Bryce Harrington (bryce) on 2008-01-09
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: New → Triaged

Marking invalid against dell project (still open against xserver-xorg-video-intel). We have seen acceptable S3/S4 support on the Intel X3100 video card, and we are always working with our partners to improve Linux driver support. Expect better performance on Ubuntu 8.04.

Changed in dell:
status: Confirmed → Invalid
Andrew Oakley (andrew-aoakley) wrote :

Remarking confirmed against Dell. Hibernate fails more than three quarters of the time on my Inspiron 1520.

In Hardy Alpha with all updates to date (2008-03-06) and Intel X3100 video card, still cannot reliably resume from hibernate. Machine will either stall during the graphical slider boot progress meter, or freeze after the progress meter with a totally black screen (backlight still on, of course).

If there is something specific that the developers would like me to do, to provide more details, I'd be glad to do so.

Changed in dell:
status: Invalid → Confirmed
Andrew Oakley (andrew-aoakley) wrote :

Confirming this bug still present in Hardy Alpha 6 with all updates to date (2008-03-10) on Dell Inspiron 1520 laptop with Intel X3100 (i965) video card.

Andrew Oakley (andrew-aoakley) wrote :

I emailed Ubuntu developer Steve Langasek about this bug, as it didn't appear on the Hardy milestone, and I was concerned that it severely impacts the stability of Hardy. He replied:

> I've spoken with our X developers, and the answer I've been given is that
> this is not a bug that's practical for us, with the resources available
> within Ubuntu, to resolve in time for the Hardy release. As mentioned in
> the bug log, it really needs to be fixed upstream, and that fix is not yet
> forthcoming.
>
> So while I regret the lack of reliable suspend support for i965 (my wife
> also has a laptop with one of these chipsets - I guess this bug explains a
> few things now that I've found it), we can't commit to fixing this bug for
> the hardy release in spite of its significant impact.

I'll try the workarounds again before I have to resort to reinstalling Microsoft Windows Vista, which I really, really don't want to do, but frankly there's no point in having a laptop without reliable hibernate IMHO.

I'm keen to donate towards fixing this problem (I'd rather PAY for Ubuntu than use MS-Windows shipped free with my laptop!), but as per bug #174040, the Ubuntu bounty system has been withdrawn.

What a shame.

Has anyone tried this to see if it will fix the issue? I was looking up info for my Thinkpad, which also uses the X3100:
http://www.thinkwiki.org/wiki/Installing_Ubuntu_7.10_%28Gutsy_Gibbon%29_on_a_ThinkPad_T61#Blank_screen_fix_for_intel_graphics_cards

I cannot tell if this is the same problem you all are experiencing or not. Might be worth a shot

Mario Limonciello (superm1) wrote :

Andrew, what symptoms are you encountering in Hardy? Were these recent developments with recent updates? Probably about two weeks ago Jose & I were testing the 1330, 1420, and 1520.

Andrew Oakley (andrew-aoakley) wrote :

Steps to reproduce & symptoms:

1. Boot into Hardy with EITHER Metacity or Compiz (doesn't matter which)

2. Click Quit... button, Hibernate

3. Machine appears to hibernate successfully. Power turns off entirely, automatically.

4. Switch back on, boot into Hardy

5. Machine shows progress bar moving left and right

6. Screen goes entirely blank (am colour-blind so not sure of exact colour), backlight remains on. There is no mouse pointer and no text cursor.

7. Machine is entirely unresponsive. Keyboard and trackpad have no effect. CTRL-ALT-F1/F2/F3/F4/F5/F6/F7/F8/F9 have no effect. Pinging the machine over the network does not work.

8. Force a power-off by holding down the Power button for 4+ seconds.

9. Switch back on, boot into Hardy, succeeds with a brand new session and the Hibernate session is lost.

Laptop is a Dell Inspiron 1520 with Intel X3100 graphics. Machine is dual booted with MS Windows Vista using EasyBCD. Vista boot loader loads first, then transfers (defaults after 5 seconds) to GRUB on 5th partition. Symptoms were the same both before and after I applied the workaround from Jose above.

If booted into Vista, the machine hibernates and resumes without trouble.

I'm exceptionally keen to help resolve this, and have got some holiday coming up over the next few days, so I can provide any further info you need, just tell me how to obtain it! I'm happy working from terminal/console. I'll even take a video of the whole thing happening if it helps, and host it on my site. I'm very grateful for your interest, thanks.

Andrew Oakley (andrew-aoakley) wrote :

I don't know how or why, but this appears to have been fixed in the Hardy updates over the last few days.

xserver-xorg-video-intel is now 2:2.2.1-1ubuntu6

Fixed for Dell Inspiron 1520 with Intel X3100 i965 graphics.

Machine now reliably resumes from hibernate.

Suspend feature does work a lot better for me too since I upgraded to Hardy
(It has not failed once since I'm upgraded).
The new driver is not perfect though, opengl games are broken now (
https://bugs.launchpad.net/bugs/206287)

On Sun, Mar 30, 2008 at 3:27 PM, Andrew Oakley <email address hidden> wrote:

> I don't know how or why, but this appears to have been fixed in the
> Hardy updates over the last few days.
>
> xserver-xorg-video-intel is now 2:2.2.1-1ubuntu6
>
> Fixed for Dell Inspiron 1520 with Intel X3100 i965 graphics.
>
> Machine now reliably resumes from hibernate.
>
> --
> [Hardy] [XPS M1330] Resume from suspend/hibernate doesn't always work
> (i965)
> https://bugs.launchpad.net/bugs/164974
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Mario Limonciello (superm1) wrote :

Since both Andrew and Chris indicated this is fixed for them, i'm going to mark this as Fix Released. Thanks.

Changed in dell:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Changed in somerville:
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305512

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers