backport SNA render backend for gen9

Bug #1640755 reported by Timo Aaltonen on 2016-11-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
Hybrid setups with KBL/BXT + AMD need gen9 sna backend backported to fix bugs that prevent using the discrete GPU via DRI_PRIME=1 envvar.

[Test case]

Run 'DRI_PRIME=1 glxgears'

[Regression potential]

Minimal, as the commits mostly touch the new backend, apart from two commits that are fixes for other generations too.

[Other info]

backported commits are:

15c5ff12459a034 sna: Clear damage tracking when marking as all-clear
205146b0fdc8db0 sna/gen9: Fix Kabylake typo
ebc066c1ece2db2 sna: Add missing GT info for bxt,kbl
c28e62f94f15c9f sna/gen2+: Do not force migration to GPU for very large objects
81029be07380090 sna/gen8+: Flush pipecontrols when forcing a pipeline stall
0d38419cbeaae5f sna/gen9: Update mocs selection
e783ffa4977ae63 sna/gen9: Bias GT for pipeline selection
4e172a38e170746 sna/gen9: Quick and dirty implementation

Timo Aaltonen (tjaalton) on 2016-11-10
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: New → In Progress
description: updated
description: updated

Hello Timo, or anyone else affected,

Accepted xserver-xorg-video-intel into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.917+git20160325-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Shih-Yuan Lee (fourdollars) wrote :

xserver-xorg-video-intel/2:2.99.917+git20160325-1ubuntu1.2 works but I need to set DRI "3" in xorg.conf.d manually because it is not enabled for intel by default.

tags: added: verification-done
removed: verification-needed
Timo Aaltonen (tjaalton) wrote :

this works great on my Skylake machine

Timo Aaltonen (tjaalton) wrote :

yes, that's for the (private) hybrid bug, but not generally needed for everyone

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.917+git20160325-1ubuntu1.2

---------------
xserver-xorg-video-intel (2:2.99.917+git20160325-1ubuntu1.2) xenial; urgency=medium

  * Backport sna render backend for gen9. (LP: #1640755)

 -- Timo Aaltonen <email address hidden> Thu, 10 Nov 2016 12:31:32 +0200

Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers