Virtual Terminal (VT, e.g. Ctrl-Alt-F3) is completely black [Hardy, i945GZ]

Bug #162400 reported by Paul Dufresne on 2007-11-13
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

When going to a Virtual Terminal (with by example Ctrl-Alt-F3), screen is totally black.
Moreover, after about 7 seconds, my monitor seems to go to sleep mode (green light goes yellow).
But I can always return with Alt-F7 to graphical screen.

Seems to be independant of EXA acceleration (I say it because it was first mention in an other
bug where it was discovered that EXA acceleration was needed to have windows update their content).

This happens with intel driver, and not with i810 driver.

This is on Hardy, with 2:2.1.1-4ubuntu2 of xserver-xorg-video-intel.

Paul Dufresne (paulduf) wrote :

Problem still exist with 2:2.1.99-1ubuntu1.

Paul Dufresne (paulduf) wrote :

Was a duplicate of bug #129910, but I removed the duplicate because in my case I have not vga=xxx on kernel line of /boot/grub/menu.lst

Paul Dufresne (paulduf) wrote :

The symptom change a bit recently, rather than screen stay black, and monitor going in energy saving mode, now the X window come back. Not sure which /var/log/ would help... Let's try Xorg.0.log first.

Paul Dufresne (paulduf) wrote :
Bryce Harrington (bryce) wrote :

I assume it occurs as well on -intel 2.2?

Do you use multiple keyboard layouts? If so, does this look like your bug? https://bugs.freedesktop.org/show_bug.cgi?id=12775

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Paul Dufresne (paulduf) wrote :

ii xserver-xorg-video-intel 2:2.2.0-1ubuntu1
yes, it still happens.

I don't use multiple layouts, but I am indeed using an unusual layout: ca-multi.
This is supposed to be the standard here in Quebec, but only the government use it in reality.

That said, I tried to run:
 setxkbmap -model pc105 -layout us
and then try again to 'Ctrl-Atl-F3' with no success.
It always go black a little while, but sometimes continue with monitor going economy mode, sometimes returns in
'Ctrl-F7' mode by itself.

Attaching my old xorg.conf file. I see that I have none since november 24.
Don't recall exactly what I was testing by removing it.
Will redo dpkg-reconfigure xserver, and retry again.

Paul Dufresne (paulduf) wrote :

Well, I have made many tests, but nothing made it work.
I have found that booting in recovery mode, going to # prompt, and doing startx, make the system go to graphical mode, ask if I want to continue as superuser and when click continue, screen disappears just like when switching virtual terminal.
Tried it with 'i810' driver, and it does return with some interesting errors.
I did startx 1>startx1.txt 2>startx2.txt but only startx2.txt returned with some info.
This is with i810, attaching startx2.txt.

Paul Dufresne (paulduf) wrote :

Also, i810 driver show me that my BIOS does not support some call:
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(II) I810(0): xf86BindGARTMemory: bind key 4 at 0x007bf000 (pgoffset 1983)
(II) I810(0): xf86BindGARTMemory: bind key 0 at 0x0ffff000 (pgoffset 65535)
(II) I810(0): xf86BindGARTMemory: bind key 1 at 0x0fffb000 (pgoffset 65531)
(II) I810(0): xf86BindGARTMemory: bind key 3 at 0x0ffea000 (pgoffset 65514)
(II) I810(0): xf86BindGARTMemory: bind key 2 at 0x0fffa000 (pgoffset 65530)
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(II) I810(0): BIOS call 0x5f05 not supported, setting refresh with VBE 3 method.
(II) I810(0): Setting refresh with VBE 3 method.
(II) I810(0): Display plane A is enabled and connected to Pipe A.
(II) I810(0): Display plane B is disabled and connected to Pipe B.
(II) I810(0): Enabling plane A.
(II) I810(0): Display plane A is now enabled and connected to Pipe A.
(II) I810(0): Display plane B is now disabled and connected to Pipe B.
(II) I810(0): PIPEACONF is 0x80000000
(II) I810(0): PIPEBCONF is 0x80000000
(II) I810(0): Mode bandwidth is 47 Mpixel/s
(WW) I810(0): Extended BIOS function 0x5f28 not supported.

Paul Dufresne (paulduf) wrote :

I have tried to update from latest stable BIOS to latest beta BIOS (601 to 801) for Asus-P5GZ-MX.
But still i810 report BIOS call 0x5f05 to not be supported.
And Ctrl-Alt-F3 still not working.

Paul Dufresne (paulduf) wrote :

According to:
http://lists.opensuse.org/opensuse-xorg/2004-02/msg00000.html
0x5f05 function call is used to set refresh rate.
Well, maybe I am going the wrong way here. I probably should try to get the Xorg.log file given by intel driver rather than playing with i810 one.

Paul Dufresne (paulduf) wrote :

Well, by doing "startx; cp /var/log/Xorg.0.log > ./Xorg.Intel.log" at recovery console, I was able to get a full debug Xorg.0.log for intel driver. (After doing Continue, it return back (I guess) to console, but I saw nothing. I recuperated the Xorg.Intel.log after rebooting. I have a xorg.conf with some test values, even changed acpid file. Will attach in next comments.

Paul Dufresne (paulduf) wrote :

My present xorg.conf.

Paul Dufresne (paulduf) wrote :

I don't know much about this PipeA and PipeB, but I note that with intel driver, at the end, they are both disabled.

mcsekar (mcsekhar) wrote :

I too am experiencing the same problem with Hardy(Gobuntu CD) with 2.6.24-2-386 kernel.
The virtual terminals are blank and the monitor LED changes from green to yellow, indicating it is sleeping, I think.
I will also attach the relevant files one after another.

I am using
xserver-video-intel 2:2.2.0-1ubuntu1
xserver-xorg 1:7.3+7ubuntu3
xserver-xorg-core 2:1.4.1~git20071212-1ubuntu2

This is what "uname -a" says:
Linux abyss 2.6.24-2-386 #1 Thu Dec 13 23:22:02 GMT 2007 i686 GNU/Linux

I did these steps from a thread in the forums.
1. sudo vi /etc/initramfs-tools/modules and add fbcon and vesafb
so my /etc/initramfs-tools/modules looks like:

fbcon
vesafb

2. sudo update-initramfs -u
3. sudo vi /etc/modprobe.d/blacklist-framebuffer
change the line "blacklist vesafb" to "# blacklist vesafb"

But, it still did not solve the problem

I will attach the relevant files in the following posts.

mcsekar (mcsekhar) wrote :
mcsekar (mcsekhar) wrote :
mcsekar (mcsekhar) wrote :

I forgot to mention that I am using a Intel 865G Integrated Graphics Controller.

Paul Dufresne (paulduf) wrote :

Well, hum, sorry, but finally in my case, it does seems that:
modprobe vesafb
modprobe fbcon
followed by Ctrl-Backspace (the step I was not doing before) to reset the X server does indeed fix the problem.
So I now consider this a duplicate of #129910 for me.

mcsekar, sorry if this seems like a stupid question but: Did you reboot after your changes?

I have the same problem as mcsekar with Intel 865G videochip.
My setup:
Ubuntu 7.10 32bit (alternative desktop)
kernel: Linux izba 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
xorg driver: xserver-xorg-video-intel 2:2.1.1-0ubuntu9.1
Hardware: IBM/Lenovo ThinkCentre S50 with Intel 865G video controller.

Problem:
When trying to switch from X to text console using Ctrl-Alt-F3, the monitor goes into DPMS mode.
I do not have vga=791 or anything like that set as a boot option. When the system boots the sceen looks like 80x25 normal vga=0 mode.

When I tried to boot from Ubuntu 7.04 live CD and switched from X to text console, all works fine.
This 7.04 live CD uses different xorg server:
xserver-xorg-video-i810 1.7.4-0ubuntu1
Linux ubuntu 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Solution / workaround:
Going back to Ubuntu 7.10 "Ctrl-Alt-F3" problem now - Edit /etc/modprobe.d/blacklist-framebuffer
and comment out all intel related fb modules, like this:
#blacklist intelfb
#blacklist vesafb

Edit /etc/modules and add the lines:
fbcon
vesafb

After the reboot, lsmod |grep fb shows that intelfb (!!!) and vesafb get loaded:
fbcon 41760 71
tileblit 3584 1 fbcon
font 9344 1 fbcon
bitblit 6912 1 fbcon
vesafb 9092 0
intelfb 39460 1
i2c_algo_bit 7428 1 intelfb
i2c_core 26112 2 intelfb,i2c_algo_bit
agpgart 35016 4 drm,intelfb,intel_agp

Interestingly, now the system boots into vga=791 so this must be set somewhere in initramfs or kernel.compilation:
Anyway, now I can switch from X to console with Ctrl-Alt-F3 and the console is graphical vga(791).

Also it is interesting that if I remove vesafb module ( rmmod vesafb) and try to start X (startx), then X server wouldn't start. Looks like intel video driver depends on vesafb presence. Strange.

Please note - intelfb module above is essential for this to work on Intel865G chip with xorg intel 2:2.1.1 driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.