Comment 88 for bug 1573959

It's been 50 days since I upgraded from 16.04 kernel 4.4 to LTS Enablement Stack kernel 4.8 and I haven't had this issue again.

https://wiki.ubuntu.com/Kernel/LTSEnablementStack#Ubuntu_16.04_LTS_-_Xenial_Xerus

$ lspci -nn | egrep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)

$ uname -a
Linux USER-PC 4.8.0-46-generic #49~16.04.1-Ubuntu SMP Fri Mar 31 14:51:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux