Screen issue with Java applications

Bug #1533675 reported by Gian Luca on 2016-01-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Hi,
I've an issue with ssh X11 forwarding while launching Java applications, it's a critical issue because I'm working with my laptop(with Ubuntu 15.10) for a customer and is impossible to dispatch all the requests.
This is what I do step by step:
1- ssh -X user@customerserver
2- xclok <- it works well
3- /export/appl-data/oracle/jdk1.7.0_45/bin/java -d64 -jar weblogic.jar
4- The X Java application starts but the fonts are "invisible" s you can see in the screenshot in attach.

I don't think is a server issue but an Ubuntu issue because it works fine from fedora and windows 7 with Xming

The server Java version is this:
/export/appl-data/oracle/jdk1.7.0_45/bin/java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

The server os is this:
[user@customerserver bin]$ uname -a
Linux customerserver 2.6.39-400.214.5.1.el6uek.x86_64 #1 SMP Fri May 30 16:43:43 PDT 2014 x86_64 x86_64 x86_64 GNU/Linux

The server env is this:
[user@customerserver bin]$ env
HOSTNAME=customerserver
TERM=xterm-256color
SHELL=/bin/bash
HISTSIZE=1000
SSH_CLIENT=10.173.150.18 34230 22
QTDIR=/usr/lib64/qt-3.3
OLDPWD=/export/appl-data/oracle/web/wls10.3.6
QTINC=/usr/lib64/qt-3.3/include
SSH_TTY=/dev/pts/0
USER=user
LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=05;48;5;232;38;5;15:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:st=48;5;21;38;5;15:ex=38;5;34:*.tar=38;5;9:*.tgz=38;5;9:*.arj=38;5;9:*.taz=38;5;9:*.lzh=38;5;9:*.lzma=38;5;9:*.tlz=38;5;9:*.txz=38;5;9:*.zip=38;5;9:*.z=38;5;9:*.Z=38;5;9:*.dz=38;5;9:*.gz=38;5;9:*.lz=38;5;9:*.xz=38;5;9:*.bz2=38;5;9:*.tbz=38;5;9:*.tbz2=38;5;9:*.bz=38;5;9:*.tz=38;5;9:*.deb=38;5;9:*.rpm=38;5;9:*.jar=38;5;9:*.rar=38;5;9:*.ace=38;5;9:*.zoo=38;5;9:*.cpio=38;5;9:*.7z=38;5;9:*.rz=38;5;9:*.jpg=38;5;13:*.jpeg=38;5;13:*.gif=38;5;13:*.bmp=38;5;13:*.pbm=38;5;13:*.pgm=38;5;13:*.ppm=38;5;13:*.tga=38;5;13:*.xbm=38;5;13:*.xpm=38;5;13:*.tif=38;5;13:*.tiff=38;5;13:*.png=38;5;13:*.svg=38;5;13:*.svgz=38;5;13:*.mng=38;5;13:*.pcx=38;5;13:*.mov=38;5;13:*.mpg=38;5;13:*.mpeg=38;5;13:*.m2v=38;5;13:*.mkv=38;5;13:*.ogm=38;5;13:*.mp4=38;5;13:*.m4v=38;5;13:*.mp4v=38;5;13:*.vob=38;5;13:*.qt=38;5;13:*.nuv=38;5;13:*.wmv=38;5;13:*.asf=38;5;13:*.rm=38;5;13:*.rmvb=38;5;13:*.flc=38;5;13:*.avi=38;5;13:*.fli=38;5;13:*.flv=38;5;13:*.gl=38;5;13:*.dl=38;5;13:*.xcf=38;5;13:*.xwd=38;5;13:*.yuv=38;5;13:*.cgm=38;5;13:*.emf=38;5;13:*.axv=38;5;13:*.anx=38;5;13:*.ogv=38;5;13:*.ogx=38;5;13:*.aac=38;5;45:*.au=38;5;45:*.flac=38;5;45:*.mid=38;5;45:*.midi=38;5;45:*.mka=38;5;45:*.mp3=38;5;45:*.mpc=38;5;45:*.ogg=38;5;45:*.ra=38;5;45:*.wav=38;5;45:*.axa=38;5;45:*.oga=38;5;45:*.spx=38;5;45:*.xspf=38;5;45:
MAIL=/var/spool/mail/user
PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/user/bin
PWD=/export/appl-data/oracle/web/wls10.3.6/wlserver_10.3/common/bin
JAVA_HOME=/export/appl-data/oracle/jdk1.7.0_45/
LANG=it_IT.UTF-8
HISTCONTROL=ignoredups
SHLVL=1
HOME=/home/user
LOGNAME=user
QTLIB=/usr/lib64/qt-3.3/lib
CVS_RSH=ssh
SSH_CONNECTION=10.173.150.18 34230 10.25.63.82 22
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=localhost:10.0
G_BROKEN_FILENAMES=1
_=/bin/env

May I give you some other infos?

Best regards,
Gian Luca

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: ssh (not installed)
ProcVersionSignature: Ubuntu 4.2.0-23.28-generic 4.2.6
Uname: Linux 4.2.0-23-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jan 13 14:08:23 2016
InstallationDate: Installed on 2015-12-29 (14 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: openssh
UpgradeStatus: No upgrade log present (probably fresh install)

Gian Luca (gianluca-ricci) wrote :
Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

It might be worth checking to see if plain remote X (without ssh) is affected. If it is (I think this is likely), then the bug isn't with ssh but with either your X client, X server or X configuration, and we should reassign it so it has a chance of getting attention from a developer closer to this area.

Gian Luca (gianluca-ricci) wrote :

Hi Robie,
thanks for you answer, I've asked to the sysadmin to make a test and let me know if X server works fine and he told me that he hasn't verified any kind of issue, so I think that is something wrong with my Ubuntu installation. I've made also a test with a virtual installation(Oracle VirtualBox) of Ubuntu 15.04 and I have the same issue. If this bug/issue will be assigned to an X server developer I'd like to collect any other info about this strange behavior.

Regards,
Gian Luca

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openssh (Ubuntu):
status: New → Confirmed
Andre T (wind-kitesurfer) wrote :

Hi

I have exactly the same issue. While connecting through ssh on a remote Linux server, most Java related screens come up with scrambled fonts. I have tested the same on a Vbox running Ubuntu mate and it works fine.

I have gone through some display driver settings and I have found a workaround:

Enabled uxa for my display driver:
Option "AccelMethod" "uxa"
Then rebooted and all java fonts displayed correctly.

The above workaround though decreases graphics performance so I reverted back to the original graphics settings.

My setup is:

Lenovo T450
Intel® HD Graphics 5500 (Broadwell GT2)
Running Ubuntu LTS 14.04 (Unity)

I have also tested 15.05 and 15.10 but no change. I am waiting for 16.04 to come out and try it again.

I'm not uploading screens since I have exactly the same issue as gianluca (I tried weblogic installation too )
Strange thing is that, when I start for example the weblogic installer locally (not through SSH), graphics and fonts are fine....
So it seems the SSH connections (-X or -Y tried both even with different ciphers) have an issue.

Thanks

Andreas

Robie Basak (racb) wrote :

X forwarding is a pretty straightforward channel. If there's bug here, then given that X forwarding generally works for you it seems more likely to me that the bug is in the X server or X client or some incompatibility between them, rather than in ssh.

For example, I suggest that you check that your X client works properly on your X server using a direct TCP channel instead of with ssh forwarding. This would help eliminate or implicate ssh.

Andre T (wind-kitesurfer) wrote :

Hi

I believe you are right. SSH does not seem to be the issue. If I change display driver from SNA to UXA it works fine. So it must be an X client issue.

I'm not aware of any other method for remote X than SSH. And I mean direct. For example VNC runs on the server so is not what we are looking for.

Maybe we should change this from openssh to X Clinet issue.

Thanks

Robie Basak (racb) on 2016-04-18
affects: openssh (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
summary: - ssh X11 forwarding has screen issue with Java applications
+ Screen issue with Java applications
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Andre T (wind-kitesurfer) wrote :

Hello

After upgrading to 16.04 issue still exists.

Thanks

thrillseeka (mail-to-depa) wrote :

I had the same on issue on my Lenovo T450 running Oracle Linux 7.2

xorg-x11-server-utils-7.7-14.el7.x86_64
xorg-x11-server-common-1.17.2-10.el7.x86_64
xorg-x11-server-Xorg-1.17.2-10.el7.x86_64
xorg-x11-drv-intel-2.99.917-8.20150615.el7.x86_64
kernel-uek-4.1.12-32.2.3.el7uek.x86_64

After reading this post

https://www.reddit.com/r/archlinux/comments/4cojj9/it_is_probably_time_to_ditch_xf86videointel/

I've tried using modesetting instead of Intel x11 driver

Section "Device"
   Identifier "Intel Graphics"
   Driver "modesetting"
EndSection

and the issue is gone.

I'm running GNOME-3.14: I don't know if Unity is able to run on modesetting.

I hope it helps

Andre T (wind-kitesurfer) wrote :

Hello

Thanks for the tip. I changed the driver config to what you have suggested and it seems to be working fine.
Graphics performance seems to be at least as fast as SNA (default setting) and java graphics from remote SSH load up correctly.
I will keep these settings and I will test thoroughly.
I will update soon.

Thanks

:)

Qianqian Fang (fangq) wrote :

I have similar issues with Xubuntu 14.04 LTS with HWE (kernel 4.4.0-66) and Intel Graphics (Skylake i7-6700k with HD 530 GPU).

In my below screen capture, I show a matlab window started on a remote machine via "ssh -Y" (left), and the same matlab started on the local machine (right).

You can see the left window show blank text in various places. The file icons for the two files (initval.txt and wazu2...) on the file explorer panel also show white stripes (I've seen this on various context).

This seems to happen only with Intel graphics, although I am not sure.

Qianqian Fang (fangq) wrote :

the pixelated/garbled text in Java applications (particularly severe on remote java applications) appears to be caused by bugs in the xorg intel driver for the default SNA acceleration method, see

https://www.mathworks.com/matlabcentral/answers/271637-matlab-starts-but-looks-weird-arch-linux
https://wiki.archlinux.org/index.php/intel_graphics#SNA_issues

the workaround is to create a file /usr/share/X11/xorg.conf.d/20-intel.conf with the content of

Section "Device"
Identifier "card0"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

and restart the X window, this will completely solve the pixlated graphics issue.

However, the UXA rendering method is somehow extremely unstable for my 14.04 LTS with the 4.4.0-78 kernel, only in a few minutes after X window starts, the xorg process starts to use 80-90% of the CPU load, and window response becomes sluggish, despite similar glxgears FPS readings compared to SNA. I switched several times back and forth, the observation is consistent on my computer. I had to revert back to SNA to use the computer normally. too bad this is not a real fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers