GNOME panels are smaller than detected and set resolution

Bug #152416 reported by Pēteris Krišjānis
18
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Invalid
Low
Ubuntu Desktop Bugs
xserver-xorg-video-intel (Ubuntu)
Fix Released
Low
Bryce Harrington

Bug Description

1. Install Gutsy RC with Alternative CD
2. Install GNOME
3. Login as new user
4. Problems:
a) GNOME panels are set to width in 1024 pixels
b) System => Preferences => Screen Resolution also shows width 1024 pixels
c) Actual screen resolution is 1280x768 (which is also monitor's resolution)

So panels are smaller that actual screen resolution and Screen Resolution app also lies about it.

this is snippet from lspci concerning graphics chipset:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)

Tags: likely-dup
Revision history for this message
Peter Clifton (pcjc2) wrote :

Please attach an Xorg.log

I see this on my Intel 945GM hardware, but only when I've got an external monitor plugged in with a smaller resolution than the inbuilt display. It means when projecting on a display, you can use the panels. The Screen resolution applet shows the resolutions for the projector / monitor rather than the inbuilt panel.

Revision history for this message
Pēteris Krišjānis (pecisk-gmail) wrote :
Revision history for this message
Pēteris Krišjānis (pecisk-gmail) wrote :
Revision history for this message
Pēteris Krišjānis (pecisk-gmail) wrote :

There is no external monitor attached.

Revision history for this message
Peter Clifton (pcjc2) wrote :

Can you send /var/log/Xorg.0.log

Revision history for this message
Pēteris Krišjānis (pecisk-gmail) wrote :
Revision history for this message
Peter Clifton (pcjc2) wrote :

I'm not sure why, but its detecting that you've got a TV connected, probing 1024x768 as the biggest mode its capable of, and that is whats causing your problem:

(II) intel(0): Printing probed modes for output TV
(II) intel(0): Modeline "1024x768"x30.0 26.89 1024 1025 1088 1120 768 769 800 801 (24.0 kHz)
(II) intel(0): Modeline "800x600"x30.0 17.00 800 801 864 896 600 601 632 633 (19.0 kHz)
(II) intel(0): Modeline "848x480"x30.0 14.51 848 849 912 944 480 481 512 513 (15.4 kHz)
(II) intel(0): Modeline "640x480"x30.0 11.31 640 641 704 736 480 481 512 513 (15.4 kHz)

What sort of TV out connector does the laptop have? (Do you have anything plugged into it? Nothing broken off in the socket?)

As far as I know, the hardware detects the TV connection by its electrical loading, so I don't know why its being confused here.

Revision history for this message
Pēteris Krišjānis (pecisk-gmail) wrote :

I will let bug's original "owner" talk about it futher :)

Revision history for this message
baltais_suns (birojs) wrote :

What sort of TV out connector does the laptop have?
- S-video
Do you have anything plugged into it?
- No

On feisty works all fine, but on gutsy no.

In attach my curent xorg.conf and /var/log/Xorg.0.log on feisty now

Revision history for this message
baltais_suns (birojs) wrote :
Revision history for this message
baltais_suns (birojs) wrote :
Peter Clifton (pcjc2)
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Revision history for this message
Bryce Harrington (bryce) wrote :

seb128, is this another example of a known gnome or gnome-panel bug?

Changed in xserver-xorg-video-intel:
importance: Undecided → Low
description: updated
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

Could be, there is some bugs upstream about multi screen configuration, not sure what would be the right behaviour when different screen with different format are used though

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Revision history for this message
unggnu (unggnu) wrote :

I am pretty sure that this bug has something to do with Bug #131646 and of course Bug #130933.
You can test it through disabling compiz System - Preferences - Appearance - Desktop Effects - None and then restart X. After that the panel should be fine.
Btw. please post the output of xrandr.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

unggnu's right - this is another tv out quirk bug. Closing the gnome-panel component.

Changed in gnome-panel:
status: New → Invalid
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: Incomplete → In Progress
Revision history for this message
Bryce Harrington (bryce) wrote :

Here is a patch to add a tv out quirk for this (it's a common issue). Could you tell me the vendor and model number of your laptop, to include in the patch description?

Revision history for this message
baltais_suns (birojs) wrote :

Ordi SIA
MT-L00558808 LK
ORDI ENDURO UW31 PDD
INTEL PRO 39345 ABG
54 Mb WIREL.
NBO M30EI DWD-RW
NBO M30EI kb RUS
NBO M31EI 13,3 WXGA 1945G
INTEL PM T2300 DUAL CORE 1,66G
DDR2 1GB 4300-533 SO-DIMM
HDD 80GB 2.5" HITACHI SATA
SN: 153459 / 29.05.06
MODEL: 9120-103824

Revision history for this message
Pēteris Krišjānis (pecisk-gmail) wrote :

Vendor is ORDI (Estonian laptop vendor)
Model is ENDURO UW31 I think.

Rest of hardware spec follows:
 MT-L00558808 LK
 ORDI ENDURO UW31 PDD
 INTEL PRO 39345 ABG
 54 Mb WIREL.
 NBO M30EI DWD-RW
 NBO M30EI kb RUS
 NBO M31EI 13,3 WXGA 1945G
 INTEL PM T2300 DUAL CORE 1,66G
 DDR2 1GB 4300-533 SO-DIMM
 HDD 80GB 2.5" HITACHI SATA
 SN: 153459 / 29.05.06
 MODEL: 9120-103824

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.2.1-1ubuntu3

---------------
xserver-xorg-video-intel (2:2.2.1-1ubuntu3) hardy; urgency=low

  * Add 07_intel_exa_force_all_greedy.patch, to expand the fix from
    05_intel_exa_force_greedy.patch to cover all Intel chipsets, not just
    965. (LP: #177492)
  * Drop 05_intel_exa_force_greedy.patch, since 07 is a superset of it.
  * Add 08_945gm_quirk.diff, to add quirk for another laptop model with a
    tv out detection bug. (LP: #152416)

 -- Bryce Harrington <email address hidden> Fri, 29 Feb 2008 15:52:16 -0800

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers