Intel 965G (GMA X3000) - Video Tearing Effect & Poor Performance

Bug #152206 reported by cbsim on 2007-10-13
60
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-i810 (Baltix)
Undecided
Unassigned
xserver-xorg-video-intel (Baltix)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Video tearing effect on gaming & video playback (not deinterlace), the graphic & gaming performance is poor compare to Windows on both Ubuntu Feisty & Gusty:

Packages:
xserver-xorg-video-intel
xserver-xorg-video-i810

xorg.conf:
Section "Module"
Load "i2c"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "Intel Corporation 82G965 Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "L196WTQ"
Option "DPMS"
HorizSync 30-83
VertRefresh 56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82G965 Integrated Graphics Controller"
Monitor "L196WTQ"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1440x900"
ViewPort 0 0
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

glxinfo:
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
client glx vendor string: SGI
client glx version string: 1.4
GLX version: 1.2
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 965G 4.1.3002
OpenGL version string: 1.4 Mesa 6.5.2

cbsim (cbsim) on 2007-10-14
Changed in xserver-xorg-video-i810:
status: New → Invalid
description: updated
description: updated
cbsim (cbsim) wrote :

xserver-xorg-video-intel (Ubuntu)

cbsim (cbsim) wrote :

xserver-xorg-video-i810 (Ubuntu)

fondle-em (mcribbb) wrote :

Definitely experiencing the same profoundly irritating problem on a Dell Inspiron 1420n that shipped with this bug and 32-bit 7.04 on it. It exhibited the same symptoms under the 64-bit version of Feisty, and both the 32 and 64-bit versions of Gutsy. Currently I am running 64-bit Gutsy. There's a screenshot of the bug in the forums:

http://ubuntuforums.org/showpost.php?p=3770323&postcount=11

Thanks in advance.

from xorg.conf:
Section "Device"
 Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
 Driver "intel"
 BusID "PCI:0:2:0"
 Option "XvMCSurfaces" "7"
 Option "LinearAlloc" "16384"
 Option "Cachelines" "2048"
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
 HorizSync 28-64
 VertRefresh 43-60
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
 Monitor "Generic Monitor"
 DefaultDepth 24
 SubSection "Display"
  Modes "1280x800"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"

Section "DRI"
    Mode 0666
EndSection

from glxinfo:
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
client glx vendor string: SGI
client glx version string: 1.4
GLX version: 1.2
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 965GM 4.1.3002
OpenGL version string: 1.4 Mesa 7.0.1

Mathias Nedrebø (nedrebo) wrote :

The tearing is happening on my computers as well, both my laptop with Intel GMA X3000 and my desktop with nVidia GeForce 7600 GS. I suspect this to be a bug in X.

Kasimir Gabert (kasimir-g) wrote :

This is occurring for me as well, on my Dell Inspiron 1420N, regardless of which video out driver I use and which program I use. There needs to be a solution to this...

Bryce Harrington (bryce) wrote :

Can someone verify this is still happening with the 2.2 driver on hardy?

Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: New → Incomplete
assignee: nobody → bryceharrington
oh (oystein-homelien) wrote :

Running hardy here, with what seems to be 2.2:

(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
    compiled for 1.4.0.90, module version = 2.2.0

I see tearing when moving windows with alt-left-mouse in X (not using compiz). I am not sure if X is supposed to be synced to vsync though.

I also see tearing with OGRE 3d applications (www.ogre3d.org), even if I explicitly enable vsync.

Not sure if this report is relevant, but I'd love to find a way to do vsync properly in my applications on this laptop.

Bryce Harrington (bryce) wrote :

Thanks for confirming. Please attach /var/log/Xorg.0.log and the output of lspci -vvnn. A screenshot, photo, or video that demonstrates the issue would also be handy.

Bryce Harrington (bryce) wrote :

Sounds like we're going to change things around to not use this configuration of EXA on 965 for hardy, which should resolve this issue. Leaving open for now until that's done.

Changed in xserver-xorg-video-intel:
assignee: bryceharrington → nobody
Bryce Harrington (bryce) on 2008-02-20
Changed in xserver-xorg-video-intel:
status: Incomplete → In Progress
Bryce Harrington (bryce) wrote :

I've got a fix for this by switching to the greedy pixmap migration heuristic, which resolves this and several other problems. It's packaged and tested, and is in the process of being uploaded.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: In Progress → Fix Committed
Bryce Harrington (bryce) wrote :

xserver-xorg-video-intel (2:2.2.0.90-2ubuntu6) hardy; urgency=low

  * Add 06_xaa_as_default_except_i965.patch to switch us back to XAA by
    default for intel chipsets for performance reasons, except for i965
    which does not work as well with XAA (Xv video doesn't display
    properly.) This patch essentially just reverts upstream's 'Default to
    EXA' patch, and adds a special case i965 to allow it to use EXA.

 -- Bryce Harrington <email address hidden> Tue, 19 Feb 2008 14:27:18 -0800

xserver-xorg-video-intel (2:2.2.0.90-2ubuntu5) hardy; urgency=low

  * Add 05_intel_exa_force_greedy.patch to force use of greedy mode on
    i965 hardware. (closes LP: #177492, #148247, #152206)

 -- Bryce Harrington <email address hidden> Tue, 19 Feb 2008 13:48:02 -0800

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Fix Committed => Fix Released

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Adam K (trogdor282) wrote :

I'm still seeing tearing in xv video on Hardy alpha 4 livecd.

- Upgraded to xserver-xorg-video-intel (2:2.2.0.90-2ubuntu7)
- Added Options "AccelMethod" "EXA" and Options "MigrationHeuristic" "greedy"
- Hit CTRL+ALT+BACKSPACE

Video still tears.

Bo90 (joakimcarli) wrote :
Download full text (25.7 KiB)

Me too.

Running hardy, xserver-xorg-video-intel (2:2.2.1-1ubuntu2)

lspci -vvnn
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
 Latency: 0
 Capabilities: [e0] Vendor Specific Information

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at f8000000 (64-bit, non-prefetchable) [size=1M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 1800 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+

00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 0c)
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Region 0: Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
 Capabilities: [d0] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03) (prog-if 00 [UHCI])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 17
 Region 4: I/O ports at 1820 [size=32]

00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03) (prog-if 00 [UHCI])
 Subsystem: COMPAL Electronics Inc Unknown device [14c0:0026]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin B routed to IRQ 20
 Region 4: I/O ports at 1840 [size=32]

00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03) (prog-if 20 [EHCI])
 Subsystem: COMPAL Electronics ...

Changed in xserver-xorg-video-intel:
status: Fix Released → Incomplete
Adam K (trogdor282) wrote :

This is probably the wrong place to ask, but is the problem that xv can't 'find' the vblank? Or does it find the vblank and then can't complete the whole frame fast enough?

PS thanks for all the hard work Bryce, you're my hero even if I'm still having trouble. I blame Intel :)

zombiepig (nyall-zombiepigs) wrote :

A possible fix to the tearing video problem is to switch from textured video to overlay video. It was previously believed that the x3100 chipsets didn't have hardware support for overlay video, but it's now discovered that they do have overlay adapters. Apparently, the video tearing only occurs with textured video, not overlay.

A recent post on the xorg mailing list includes patches to allow overlay video with intel chipsets, and also adds the xorg.conf option for
Option "TexturedVideo" "false"
that will disable the textured video adapter, so that the overlay adapter becomes default for video playback.

The patches are available here:

http://lists.freedesktop.org/archives/xorg/2008-February/033331.html
http://lists.freedesktop.org/archives/xorg/2008-February/033332.html

Adam K (trogdor282) wrote :

> A possible fix to the tearing video problem

Confirmed!! My X3100 now displays 720p AVC properly with no tearing, using zombie's overlay patch. I recompiled for Gutsy and it works there too. Thanks everybody =)

Nick (spereneka) wrote :

Hi there, i tried to apply these patches as well but i'm not sure if it worked after all. Applying the patch using the patch command wouldn't work so i altered the original files manually. I compiled the driver again but i don't know if it is actually using overlay video instead of textured video. Could someone have a look at my Xorg.0.log and let me know if the patch worked?

I'm still getting tearing anyway..

Adam K (trogdor282) wrote :

Nick, your log says:
(WW) intel(0): Option "TexturedVideo" is not used

If you do it right it will say:
(**) intel(0): Option "TexturedVideo" "false"

Note that 'make install' puts the drivers in /usr/local/lib/xorg/modules/drivers/, I had to copy them to /usr/lib/xorg/modules/drivers/

Nick (spereneka) wrote :

Hey Adam, thanks for you response. This seems to have done the trick. I didn't know i had to copy the files to that directory.

Thanks again!

Using hardy updated today, 11 march. The performance has gotten worse since Gutsy. Lots of tearing, computer running terribly slow with compiz. 3D artifacts when running opengl.

oh (oystein-homelien) wrote :

Just a question wrt textured vs overlaid video- isn't textured video "the way to go" for the future - tighter integration with compositing window managers, several videos at once etc? I'm asking since the discussion here seems to focus on switching (back?) to overlays, which seems to me as just masking the real problem.

I'm most interested in great 3d/opengl performance (with vsync control/no tearing), just my few cents.

zombiepig (nyall-zombiepigs) wrote :

The problem is that the move to textured video & exa is still missing some pieces, like ttm, dri2 and batch buffer. So, using textured video at the moment results in poor performance and video tearing. Switching to overlay video and back to xaa could possibly fix the performance problems temporarily, until things are more ready for textured video (8.10?)

unggnu (unggnu) wrote :

@Nikolai Ugelvik
The problem could be the fix of Bug #177492 which possible doesn't activate Greedy migration heuristic for i965 anymore. If scrolling in Firefox lags very much it is very likely the mentioned issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.2.1-1ubuntu4

---------------
xserver-xorg-video-intel (2:2.2.1-1ubuntu4) hardy; urgency=low

  * Revert the greedy change, use the old patch again since the new one
    doesn't work right. (LP: #177492)
  * Add patches to enable hardware overlay for i965, and disable textured
    video by default. It can be enabled again by setting
    'Option "TexturedVideo" "true"'. (LP: #152206)

 -- Timo Aaltonen <email address hidden> Tue, 11 Mar 2008 21:42:43 +0200

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Released
Teemu Sivonen (teemu-sivonen) wrote :

Playing opengl games is unstable and there's still 3d artifacts.

xserver-xorg-video-intel (2:2.2.1-1ubuntu6) hardy.

sibidiba (sibidiba) wrote :

I can confirm the poor 3D performance using the current xserver-xorg-video-intel (2:2.2.1-1ubuntu10) on Hardy.

I have INTEL_BATCH set to 1. This is not bug #177492 (poor scolling performance, resolved by the greedy patch). Also thanks to hardware overlay for xv, video playback works fine with compiz enabled.

Although 3D performance is still crappy, glxgears is around 1000 FPS.
Even basic compiz effects are laggy, running around 5-10 FPS.

VGA controller:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Changed in xserver-xorg-video-intel:
status: Fix Released → New
Bryce Harrington (bryce) wrote :

The corruption issue reported in #25 was due to a mesa bug completely unrelated to the greedy patch. I uploaded a fix for this issue on Friday.

@Gabor, using INTEL_BATCH=1 is not recommended by upstream, and so we do not support it. If you can reproduce your issues with that disabled, please report issues in new bug reports.

Changed in xserver-xorg-video-intel:
assignee: bryceharrington → nobody
status: New → Fix Released
mhakali (ubuntu-nexticom) wrote :

Although the non textured video playback works great with XV overlay, applications which use OpenGL as renderer (more specific; XBMC for linux which uses OpenGL via SDL) still shows tearing during video playback. I am looking to use a machine with intel gfx and XBMC linux as a HTPC, but those plans will probably not work out it seems :-)

Resolution to get rid of tearing effects all in all?

Andy Botting (andybotting) wrote :

I'm using a Mac Mini with the Intel 945GM chipset, and using XBMC on Hardy, I see some pretty nasty video tearing. I found that XBMC has a Vsync to Black option, which fixes the tearing, but after about 5-10 minutes, the whole screen goes one colour, and to get X working again, I need to reboot.

I'm using xserver-xorg-video-intel version 2:2.2.1-1ubuntu12.

wfrancis (wfrancis) wrote :

@Andy Botting

What's the vsync to Black option? is that in the guisettings.xml file?

@everyone else

Running hardy on a 2Ghz core duo asus mini mobo with a intel 945G video chip and I'm getting some tearing at 720p. Not the end of the world, but enough to be annoying compared to when I drive my projector with my mac. So far I've turned off compiz and set part of my xorg.conf to look like this:

Section "Device"
        Identifier "Configured Video Device"
        Option "AccelMethod" "exa"
        Option "MigrationHeuristic" "greedy"
        Option "ExaNoComposite" "false"
        Option "TexturedVideo" "false"
EndSection

xserver-xorg-video-intel 2:2.2.1-1ubuntu13
xbmc 2.1a2-hardy2
(--) PCI:*(0:2:0) Intel Corporation 82945G/GZ Integrated Graphics Controller rev 2, Mem @ 0xdfc80000/19, 0xc0000000/28, 0xdfd80000/18, I/O @ 0xac00/3

Is there anything else that I can tweak to get about 10-20% more performance?

I can get about 1100 fps with glxgears but I have no idea how any other opengl stuff runs as I just got this box and it's going to be 100% for xbmc.

thanks for all the work on this. I can't tell you how happy I am to have xbmc on ubuntu and able to play 720p content!

Andy Botting (andybotting) wrote :

wfrancis, I must have been asleep when I wrote that.

I meant to say Vertical Blank Sync. You can find it from the Configuration -> Appearance -> Screen menu.

It seemed to fix my tearing issue, but I was getting other problems. I was seeing the screen flicker and jump, and this often ended with the screen going all one colour and requiring a reboot to fix it.

I've switched to the i810 driver which seems to work better.

wfrancis (wfrancis) wrote :

Andy - wow, what a fantastic difference that made, it works beautifully. I used the mode where it syncs on black only when the video is playing and I have no other issues at all. Thanks for the tip!

Azarashi (tul-tut) wrote :

I have a similar video tearing effect with Intel 945GM in 8.10. Actually I think it always (since 7.04) was like this with x11, but xv was fine. Now x11 and xv seem like the same thing. Also I can't change Contrast and Saturation, only Brightness. I tried to put the following lines to Xorg.conf:
Section "Device"
        Identifier "Configured Video Device"
        Option "AccelMethod" "exa"
        Option "MigrationHeuristic" "greedy"
        Option "ExaNoComposite" "false"
        Option "TexturedVideo" "false"
EndSection

But I have "(WW) intel(0): Option "TexturedVideo" is not used" in log file.
I don't need compiz, just how can I get xv to work like it was in 8.04?

Mircea Deaconu (mirceade) wrote :

Azarashi, I think you need the patches suggested here but unfortunately the links don't work any more.

e.lamskoy (e-lamskoy) on 2010-03-22
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Fix Committed
Bryce Harrington (bryce) on 2010-03-29
tags: added: tearing
tags: added: performance
unggnu (unggnu) wrote :

Shouldn't this bug report be closed? Tearing should be gone since Karmic and also the performance is fine - at least for the possibilities of the Intel gpus I think.

On Mon, Mar 29, 2010 at 08:50:44PM -0000, unggnu wrote:
> Shouldn't this bug report be closed? Tearing should be gone since Karmic
> and also the performance is fine - at least for the possibilities of the
> Intel gpus I think.
>

@Unggnu: The bug has already been closed :)

--
Regards,
Vikram Dhillon

There is poetry and there is beauty in real sympathy; but there is more — there is action. The noblest and most powerful form of sympathy is not merely the responsive tear, the echoed sigh, the answering look; it is the embodiment of the sentiment in actual help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers