/usr/bin/Xorg:6:sna_dri2_event_free:sna_dri2_schedule_flip:sna_dri2_schedule_swap:DRI2SwapBuffers:ProcDRI2SwapBuffers

Bug #1518021 reported by errors.ubuntu.com bug bridge
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Unknown
Medium
xserver-xorg-video-intel (Ubuntu)
Critical
Unassigned

Bug Description

This occurs on my shiny new Lenovo Thinkpad T540p.

I have my laptop docked in a Lenovo UltraDock running two external 1080p displays.

When I'm logged in, if I un-dock the laptop I get booted back out to the login screen (i.e.- X crashes). This seems to happen about 90% of the time, so it's reasonably easy to reproduce.

In order to try and reproduce this, I installed the X server -dbg packages. However, with the -dbg packages installed I can't seem to reproduce this any more (possibly a race condition?).

---

The Ubuntu Error Tracker has been receiving reports about a problem regarding xorg-server. This problem was most recently seen with version 2:1.17.2-1ubuntu9, the problem page at https://errors.ubuntu.com/problem/e58accb723690ba7801e7f3fbc9bc637f08e8641 contains more details.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton)
affects: xorg-server (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : apport information

.tmp.unity.support.test.0:

ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
DistUpgraded: 2015-10-28 13:20:11,275 DEBUG enabling apt cron job
DistroCodename: wily
DistroRelease: Ubuntu 15.10
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:2210]
InstallationDate: Installed on 2015-10-12 (41 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 20BECTO1WW
Package: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-18-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Tags: wily ubuntu compiz-0.9
Uname: Linux 4.2.0-18-generic x86_64
UpgradeStatus: Upgraded to wily on 2015-10-28 (25 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/01/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: GMET72WW (2.20 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20BECTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGMET72WW(2.20):bd09/01/2015:svnLENOVO:pn20BECTO1WW:pvrThinkPadT540p:rvnLENOVO:rn20BECTO1WW:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20BECTO1WW
dmi.product.version: ThinkPad T540p
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+15.10.20151015-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Thu Nov 19 11:36:55 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.17.2-1ubuntu9
xserver.video_driver: intel

tags: added: apport-collected compiz-0.9 ubuntu
Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : BootLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : Dependencies.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : DpkgLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : GconfCompiz.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : JournalErrors.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : LightdmDisplayLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : LightdmGreeterLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : LightdmGreeterLogOld.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : LightdmLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : Lspci.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : Lsusb.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : MonitorsUser.xml.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : ProcEnviron.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : ProcModules.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : UdevDb.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : UdevLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : UnitySupportTest.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : XorgLog.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : XorgLogOld.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : Xrandr.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : xdpyinfo.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : xserver.devices.txt

apport information

Revision history for this message
Thomi Richards (thomir-deactivatedaccount) wrote : xserver.outputs.txt

apport information

description: updated
Revision history for this message
Robert Ancell (robert-ancell) wrote :

I suggested trying xserver-xorg-video-intel from https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa/+index?field.series_filter=wily to see if the issue has been fixed.

Revision history for this message
In , Robert Ancell (robert-ancell) wrote :

We're getting reports of the Intel driver crashing in Ubuntu 15.10. One user can easily reproduce this by undocking their Lenovo Thinkpad T540p.

Tracked in Ubuntu:
https://bugs.launchpad.net/bugs/1518021

Stacktrace on errors.ubuntu.com:
https://errors.ubuntu.com/problem/e58accb723690ba7801e7f3fbc9bc637f08e8641

description: updated
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Chris Wilson (ickle) wrote :

What stacktrace?

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Revision history for this message
In , Robert Ancell (robert-ancell) wrote :

Created attachment 120199
Stacktrace.

Sorry, I guess you need an account to view it on errors.ubuntu.com.

Revision history for this message
In , Chris Wilson (ickle) wrote :

Hmm, that doesn't even closely match upstream. What is the corresponding source? Or probably better just to check with upstream first.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

test with the new driver snapshot uploaded to xenial today

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Ryan C. Underwood (nemesis-icequake) wrote :

This bug should not have been marked incomplete.
The bug was fixed upstream and a fix needs to be backported to wily.
https://bugs.freedesktop.org/show_bug.cgi?id=92911

Revision history for this message
Ryan C. Underwood (nemesis-icequake) wrote :

Sorry, that was posted on the wrong bug thread. Disregard.

Revision history for this message
In , Martin-peres-n (martin-peres-n) wrote :

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel/issues/77.

Changed in xserver-xorg-video-intel:
status: Incomplete → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.