Ubuntu

Corrupted screen on G33 with -14 kernel; regression from -13

Reported by Loïc Minier on 2007-10-10
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Kyle McMartin

Bug Description

Hi,

Since upgrading to linux-image-2.6.22-14-generic, I get screen corruption in the middle of the screen on my dual screen setup (one builtin VGA adapter, one DVI adapter on an ADD2 adapter).

My motherboard is G33 based (Asus P5K-V) and I have xserver-xorg-video-intel 2:2.1.1-0ubuntu6.

The -13 kernel works fine.

Bye,

Loïc Minier (lool) wrote :

I tried rebuilding a kernel with a14a5742c371dc55ca55bfc23bec892dfea26b9b reverted, but that didn't help.

Either I did something wrong, or I have no idea which change could have broken this.

Loïc Minier (lool) wrote :

For the record in this bug, this was my revert:
commit e1b2d424de27643a2ff2ccdca4a187b083c1b389
Author: Loic Minier <email address hidden>
Date: Wed Oct 10 20:57:55 2007 +0200

    Revert "Revert "Revert "UBUNTU: remove broken changes from intel-agp.c"""

    This reverts commit a14a5742c371dc55ca55bfc23bec892dfea26b9b.

    Causes major corruption with the xserver-xorg-video-intel fix in place.

(so a revert of revert of revert of removal :-)

In the end, what I wanted is to flip the seemingly only change related to G33 between -13 and -14, which resulted in using the current upstream code and in this diff:
diff --git a/drivers/char/agp/intel-agp.c b/drivers/char/agp/intel-agp.c
index aeaa4fa..4b7002e 100644
--- a/drivers/char/agp/intel-agp.c
+++ b/drivers/char/agp/intel-agp.c
@@ -508,6 +508,11 @@ static void intel_i830_init_gtt_entries(void)
                        break;
                }
        } else {
+ /* G33's GTT stolen memory is separate from gfx data
+ * stolen memory.
+ */
+ if (IS_G33)
+ size = 0;
                switch (gmch_ctrl & I855_GMCH_GMS_MASK) {
                case I855_GMCH_GMS_STOLEN_1M:
                        gtt_entries = MB(1) - KB(size);

Loïc Minier (lool) wrote :

I also tried with a single screen connected and the VirtualSize setup commented out.

Loïc Minier (lool) wrote :
Loïc Minier (lool) wrote :

After discussion with BenC, assigning to Kyle and setting Importance/Milestone.

Changed in linux-source-2.6.22:
assignee: nobody → kyle
importance: Undecided → High
milestone: none → ubuntu-7.10
Loïc Minier (lool) wrote :

After clarification with Kyle, turns out the kernel should only have been accepted with the xserver-xorg-video-intel driver at the same time, with the patch for G33 reverted too; reassigning. Confirming because Kyle told me it's expected to be broken in this combination.

Changed in linux-source-2.6.22:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

The package version that fixes this bug has been accepted:

 xserver-xorg-video-intel (2:2.1.1-0ubuntu7) gutsy; urgency=low

   * 04-fix-g33-gtt-stolen-mem-range.diff:
     - Nuke, caused graphics corruption on G33, reverted kernel code.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
To post a comment you must log in.