Bad webcam video rendering when using XV acceleration on Skylake gpus.

Bug #1506107 reported by Robert Hooker on 2015-10-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Vivid
Medium
Robert Hooker
xserver-xorg-video-intel-lts-vivid (Ubuntu)
Trusty
Medium
Unassigned

Bug Description

CPU: Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz
GPU: Intel Corporation Device [8086:1916] (rev 07)
Webcam: 0bda:57e3 Realtek Semiconductor Corp.

[Impact]
We noticed that webcam output on a wide range of skylake systems contained corruption during certification testing of OEM machines which uses a certain gstreamer pipeline. An example of the corruption is attached.

[Test Case]
1. Boot ubuntu 14.04.3 or 15.04 on a machine with a skylake intel GPU and a webcam
2. Login system and open a terminal.
4. Execute '$ gst-launch-0.10 v4l2src ! xvimagesink'

Expect result:
There should be no visual artifacts during video playing. The artifacts will look like the attached video and be very obvious in the unfixed package.

[Regression Potential]
Low, the fix is very minimal was included immediately after the 2.99.917 release was made. It consists of 2 parts, a small patch (http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=cc9d7f6777703037d0d7eff346dd350f4d8b3f31) and a configure option change. The configure option change was in lieu of http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=986cb2335c30792e24a7e2b930ecaa3fa051809a which flipped it on unconditionally and only affects i915_bpo in both of these releases as it requires a 4.0 or newer kernel (i915_bpo is a backport of i915 from 4.2 that is only used on skylake). Both of these changes are already in wily's xserver-xorg-video-intel.

It has been tested on a large number of machines during certification, and also by me on sandybridge, ivybridge, broadwell and skylake machines.

Robert Hooker (sarvatt) wrote :
Robert Hooker (sarvatt) on 2015-10-14
Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: New → Invalid
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu Vivid):
status: New → In Progress
assignee: nobody → Robert Hooker (sarvatt)
Changed in xserver-xorg-video-intel-lts-vivid (Ubuntu Trusty):
assignee: nobody → Robert Hooker (sarvatt)
status: New → In Progress
Changed in xserver-xorg-video-intel-lts-vivid (Ubuntu Vivid):
status: New → Invalid

The attachment "xserver-xorg-video-intel_2.99.917-1~exp1ubuntu2.3.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Robert Hooker (sarvatt) wrote :

updated the changelog comment to add more info

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel (Ubuntu Trusty):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel-lts-vivid (Ubuntu):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel (Ubuntu Vivid):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel-lts-vivid (Ubuntu Trusty):
importance: Undecided → Medium
Changed in xserver-xorg-video-intel-lts-vivid (Ubuntu Vivid):
importance: Undecided → Medium
Keng-Yu Lin (lexical) on 2015-11-10
Changed in hwe-next:
status: New → Fix Released
no longer affects: xserver-xorg-video-intel-lts-vivid (Ubuntu)
Sebastien Bacher (seb128) wrote :

It's being handled, getting out of the sponsoring queue

Hello Robert, or anyone else affected,

Accepted xserver-xorg-video-intel into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.917-1~exp1ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Vivid):
status: In Progress → Fix Committed
tags: added: verification-needed
no longer affects: xserver-xorg-video-intel-lts-vivid (Ubuntu Vivid)
no longer affects: xserver-xorg-video-intel (Ubuntu Trusty)
Sebastien Bacher (seb128) wrote :

could somebody having the hardware to trigger the issue verify the fix?

Robert Hooker (sarvatt) wrote :

Working fine here on skylake-y.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.917-1~exp1ubuntu2.3

---------------
xserver-xorg-video-intel (2:2.99.917-1~exp1ubuntu2.3) vivid-proposed; urgency=medium

  * Add sna-reject-cpu-blits-that-require-format-conversions.patch and build with
    --enable-wc-mmap: Fix webcam problems on Skylake (LP: #1506107)

 -- Robert Hooker <email address hidden> Tue, 13 Oct 2015 12:25:21 -0400

Changed in xserver-xorg-video-intel (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Robert Hooker (sarvatt) on 2017-04-10
Changed in xserver-xorg-video-intel-lts-vivid (Ubuntu Trusty):
assignee: Robert Hooker (sarvatt) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers