external monitor doesnt wake up after suspend

Bug #1492639 reported by Kai Mast on 2015-09-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

Happens when connecting the screen via a docking station. I have a thinkpad t440s.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu2
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.18-0ubuntu9
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sat Sep 5 17:27:48 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:220c]
InstallationDate: Installed on 2014-11-20 (289 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
MachineType: LENOVO 20AQS00500
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.1.0-3-generic root=/dev/mapper/ubuntu--vg-root ro console=tty1 console=ttyS0 panic=-1
SourcePackage: xserver-xorg-video-intel
SystemImageInfo:
 current build number: 0
 device name:
 channel: daily
 last update: 2015-07-01 14:58:02
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/20/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: GJET80WW (2.30 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20AQS00500
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGJET80WW(2.30):bd10/20/2014:svnLENOVO:pn20AQS00500:pvrThinkPadT440s:rvnLENOVO:rn20AQS00500:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20AQS00500
dmi.product.version: ThinkPad T440s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.1+15.10.20150805-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.6.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.6.3-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Sat Sep 5 16:42:10 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12350
 vendor AUO
xserver.version: 2:1.17.2-1ubuntu5

Kai Mast (kai-mast) wrote :

Kai Mast, thank you for reporting this and helping make Ubuntu better. As per http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t440s an update to your computer's buggy and outdated BIOS is available (2.34). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful. As well, you don't have to create a new bug report.

Once the BIOS is updated, if the problem is still reproducible, and the information above is provided, then please mark this report Status New. Otherwise, please mark this as Invalid.

Thank you for your understanding.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
tags: added: bios-outdated-2.34
Kai Mast (kai-mast) wrote :

I will try this asap. But I don't see that any of the recent bios changes are related to the video card.

https://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/gjuj21uc.txt

Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
Kai Mast (kai-mast) wrote :

I'm on 18.10 with Wayland and newest BIOS and still have this issue :/

Changed in xserver-xorg-video-intel (Ubuntu):
status: Expired → Confirmed
tags: added: bios-outdated-2.50 cosmic
removed: bios-outdated-2.34
To post a comment you must log in.