Ubuntu

Compiz not supported for G965

Reported by lukisi on 2007-10-02
70
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

3d effects won't show up in gutsy beta with a Intel graphics chipset.

To reproduce:
 - launch a pc with a G965 motherboard with the gutsy-beta-32bit live cd.
 - 3d effects won't work

What I expect:
 - 3d effects working
    -or-
 - some information displayed when the user enables the effects,
   regarding why the effects won't work

Note: if this is due to black-listing the driver for the video playback
issue, IMHO it's a shame because the intel driver was the first little
step towards some good stuff for FLOSS in video cards drivers.

Bryce Harrington (bryce) wrote :

Correct, the driver is blacklisted on 965gm due to issues playing video with Xv. You can direct compiz to ignore the blacklist if you want to run it anyway (such as if you don't care about Xv). See http://wiki.compiz-fusion.org/Hardware/Blacklist for details.

Changed in xserver-xorg-video-intel:
importance: Undecided → Critical
status: New → Triaged
Sander Smid (s-smid) wrote :

If you use (for instance) gnome-mplayer with x11 as rendering backend movies will play fine..

Bryce Harrington (bryce) wrote :

Subscribed Intel Hardware Certification.

EXA is considered to be a fix for this issue. The question is, can we expect this to be fixed with XAA? If so, we can continue debugging it; otherwise we will need to wait until EXA is set as the default.

Brian Pitts (bpitts) wrote :

As an aside, it is easy to switch video playback to "No XV" using the gstreamer-properties tool.

Christophe Dumez (hydr0g3n) wrote :

In hardy, xserver-xorg-video-intel (2:2.2.0-1ubuntu1) package has the following patch:
 * 01_fix_compiz_video.diff: use xf86XVFillKeyHelperDrawable() to fix video playback with compositing enabled

Could it be possible to backport xserver-xorg-video-intel from hardy to gutsy? Or at least apply the patch to Gutsy's intel driver (if possible).

This way, we could enable compositing on Ubuntu Gutsy when using G965 cards, right?

Bryce Harrington (bryce) wrote :

Sure... but can someone confirm on Hardy that the issue is absent?

Bryce Harrington (bryce) wrote :

Another thought - on Gutsy we're limited to XAA rather than EXA, which may be the source of this issue. In which case, backporting the driver probably won't make a difference since we'd need the newer xserver. Still, it would be worthwhile to test this on Hardy. Alpha 1 comes out later this week.

Marcus Granado (mrc-gran) wrote :

A dell inspiron 1720 laptop with an GMA965/X3100 intel chip and compiz/'desktop effects' enabled plays videos using totem in Hardy alpha 1 even after setting xv / xvimagesink in gstreamer-properties, while the same laptop does not play videos in totem if xv+compiz is used in Gutsy. As a side note, I noticed that playing videos in totem using xv+compiz in hardy alpha 1 uses lots of cpu (about 35%), but it is much faster without xv selected.

Rolla Selbak (rolla-n-selbak) wrote :

A helpful reference to the freedesktop bug on Composite + XAA:

https://bugs.freedesktop.org/show_bug.cgi?id=10912

Right now, we suggest to move to EXA. EXA has been the default setting starting from the 2.2 release, and XAA may even be removed in next release.

Bryce Harrington (bryce) wrote :

Marcus, can you attach your /var/log/Xorg.0.log files from Gutsy and from Hardy? My guess is that the former is using XAA and the latter EXA, resulting in the differences you report, but the logs will tell us for certain. Thanks!

Marcus Granado (mrc-gran) wrote :

Yes, Gutsy is using XAA and Hardy-alpha1 EXA.

I tried to force Gutsy to use EXA by adding an 'option "AccelMethod" "exa"' line in my xorg.conf intel device section, but the X server crashes just after login. The three xorg.0.log follow.

Marcus Granado (mrc-gran) wrote :
Michael Doube (michael-doube) wrote :

Installed from Hardy daily iso and Compiz is now enabled by default on the GMA X3100 (GM 965) in my Sony Vaio SZ650N.

Nic (ntetreau) wrote :

Installed from Hardy alpha2 and I could enable Compiz. However, the shadow drawing is horrible around the windows and performance is appaling, especially when scrolling in Firefox. Should I open another bug report for this?

Rolla Selbak (rolla-n-selbak) wrote :

Yeah, it doesn't look good at all - at least Compiz can be enabled, that's one step closer :\

We already filed 2 bugs related to Enabling 'Normal' and 'Extra' effects, which covers the problem you're talking about:

launch#178832 and launch#178842

So any info you have on the problems you're seeing would be very helpful if posted on one of those related bugs I think...

Rolla Selbak (rolla-n-selbak) wrote :

Also, perhaps we can close this specific bug since Compiz can now be enabled (though ugly) on G965...

Timo Aaltonen (tjaalton) wrote :

Indeed, closing. The driver uses EXA by default now.

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Timo Aaltonen (tjaalton) wrote :

Reopening, lowering priority.

It was confirmed that to make EXA performance similar to XAA it'll need the new memory-manager (TTM), and that's not ready for Hardy. So we might need to force the driver to use XAA again.

Changed in xserver-xorg-video-intel:
importance: Critical → High
status: Fix Released → Confirmed
Marcus Granado (mrc-gran) wrote :

hi, Timo, is this the upstream bug?
https://bugs.freedesktop.org/show_bug.cgi?id=13389

From that discussion, I'm curious why it is not possible to update hardy's current libdrm version with one that supports ttm and then try Dave Airlie's ttm-based intel-batchbuffer branch (http://cgit.freedesktop.org/~airlied/xf86-video-intel/?h=intel-batchbuffer), or Carl Worth's recent work in exa compositing performance (http://cgit.freedesktop.org/~cworth/xf86-video-intel/) or xorg's upstream intel-batchbuffer (http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/log/?h=intel-batchbuffer), since there are people who could make it work (?) (https://bugs.freedesktop.org/show_bug.cgi?id=13389#c10).

btw, these two urls seem to be relevant to understanding this slowdown in exa performance with g965:
http://cworth.org/exa/i965/emulating_speedups/
http://cworth.org/exa/i965/synchronous_composite/

Timo Aaltonen (tjaalton) wrote :

The latest libdrm release was over a year ago, it has changed dramatically.. not to mention that all this needs kernel support, which is not necessarily going to be merged until 2.6.26 or so. So no, it's not doable for hardy.

mind you, that the guy who's running the code works for Intel :)

Bryce Harrington (bryce) wrote :

I've got a fix for this by switching to the greedy pixmap migration heuristic, which resolves this and several other problems. It's packaged and tested, and is in the process of being uploaded.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: Confirmed → Fix Committed
Bryce Harrington (bryce) wrote :

xserver-xorg-video-intel (2:2.2.0.90-2ubuntu6) hardy; urgency=low

  * Add 06_xaa_as_default_except_i965.patch to switch us back to XAA by
    default for intel chipsets for performance reasons, except for i965
    which does not work as well with XAA (Xv video doesn't display
    properly.) This patch essentially just reverts upstream's 'Default to
    EXA' patch, and adds a special case i965 to allow it to use EXA.

 -- Bryce Harrington <email address hidden> Tue, 19 Feb 2008 14:27:18 -0800

xserver-xorg-video-intel (2:2.2.0.90-2ubuntu5) hardy; urgency=low

  * Add 05_intel_exa_force_greedy.patch to force use of greedy mode on
    i965 hardware. (closes LP: #177492, #148247, #152206)

 -- Bryce Harrington <email address hidden> Tue, 19 Feb 2008 13:48:02 -0800

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Fix Committed => Fix Released

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.