[BDW GT3] Backport fixes to unbreak X

Bug #1444436 reported by Timo Aaltonen on 2015-04-15
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Timo Aaltonen
Utopic
Undecided
Unassigned
xserver-xorg-video-intel-lts-utopic (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

BDW GT3 need these to properly render menus, windows:

commit de54a93217cc550c44ee138f0511ede6925d84e0
Author: Chris Wilson <email address hidden>
Date: Wed Oct 22 19:30:21 2014 +0100

    sna/gen8: Annotate more 64bit pointer locations

commit 7a9bdadd71730adc5266bc6758982abec5917b93
Author: Chris Wilson <email address hidden>
Date: Wed Oct 22 19:31:10 2014 +0100

    sna/gen8: Clamp URB allocations for GT3

[Test case]

Log in unity, see how window borders and menus are rendered incorrectly

[Regression potential]

Slim, this has been upstream for half a year.

Timo Aaltonen (tjaalton) on 2015-04-15
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu Trusty):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress

Hello Timo, or anyone else affected,

Accepted xserver-xorg-video-intel into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.910-0ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: New → Confirmed
John doe (r9-launchpad-fq) wrote :

Dear raof,

Is it possible to force install this new package from trusty-proposed without updating other X.org stuff related packages?

Thanks

girisha (girishad) wrote :

Dear All as #3 said is there anyway to get this fix to trusty tahr? that would be really great. thank you

John doe (r9-launchpad-fq) wrote :

@girisha: if you're OK to have last packages from proposed-updates you may follow instructions on https://wiki.ubuntu.com/Testing/EnableProposed to easily test the new package.

In my case I just realize that I had previously upgraded to Utopic graphics stack so my curent package is xserver-xorg-video-intel-lts-utopic (2:2.99.914-1~exp1ubuntu4.2~trusty1) and no more xserver-xorg-video-intel (2:2.99.910-0ubuntu1.4).

If anybody with trusty original's graphic stack can test the new package (ubuntu1.5) (maybe trying to force ut with dpkg, if you don't want to enable all proposed-updates, but at your own risks).

Also if a new xserver-xorg-video-intel-lts-utopic proposed package is release I will try it on my system as descrive above.

Timo Aaltonen (tjaalton) wrote :

installing just this package doesn't pull any extra ones

John doe (r9-launchpad-fq) wrote :

At least I does on my config:
apt-get install xserver-xorg-video-intel/trusty-proposed -s
[snip]
l'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 xserver-xorg-video-intel : Dépend: xorg-video-abi-15
                            Dépend: xserver-xorg-core (>= 2:1.14.99.902)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Timo Aaltonen (tjaalton) wrote :

well the package is meant for the stock trusty install, not 14.04.2 with utopic stack (*-lts-utopic)

John doe (r9-launchpad-fq) wrote :

That' right : should it be possible to produce the package for utopic stack under Trusty ? I would be happy to test it.

Robert Erdin (robert-erdin) wrote :

sudo apt-get install xserver-xorg-video-intel/trusty-proposed -s
on xorg-video-abi-15 leads to:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '2:2.99.910-0ubuntu1.5' (Ubuntu:14.04/trusty-proposed [amd64]) for 'xserver-xorg-video-intel'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-intel : Depends: xorg-video-abi-15
                            Depends: xserver-xorg-core (>= 2:1.14.99.902)

Timo Aaltonen (tjaalton) on 2015-04-16
no longer affects: xserver-xorg-video-intel-lts-utopic (Ubuntu Utopic)
Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu):
status: New → Invalid
Chris Halse Rogers (raof) wrote :

Hello Timo, or anyone else affected,

Accepted xserver-xorg-video-intel into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.910-0ubuntu1.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

milegrin (milegrin) wrote :

Confirmed bug on Lenovo E550.
Prominently appears when plugging in an external Samsung S23C350 screen before boot/power on however plugging it in once logged it. Thus far the bug has only once occurred when the external screen is not plugged in.

https://bugs.launchpad.net/linux/+bug/1432194 :: bug #1432194 refers to the same/similar issue.

The fix mentioned has not fixed my installation using xserver-xorg-video-intel-lts-utopic ver 2.99.914-1 (Comment #8 mentions that fix is not for utopic - possibly why the fix did not work)

<code>
root@u1404:~/# uname -a
Linux u1404 3.16.0-34-generic #47~14.04.1-Ubuntu SMP Fri Apr 10 17:49:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
root@u1404:~/# lshw -c video
  *-display
       description: VGA compatible controller
       product: Broadwell-U Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:63 memory:d0000000-d0ffffff memory:a0000000-bfffffff ioport:5000(size=64)
root@u1404:~/# modinfo i915 | head
filename: /lib/modules/3.16.0-34-generic/kernel/drivers/gpu/drm/i915/i915.ko
license: GPL and additional rights
description: Intel Graphics
author: Tungsten Graphics, Inc.
srcversion: 4623F6696D48BF78FB054D5
alias: pci:v00008086d000022B3sv*sd*bc03sc*i*
alias: pci:v00008086d000022B2sv*sd*bc03sc*i*
alias: pci:v00008086d000022B1sv*sd*bc03sc*i*
alias: pci:v00008086d000022B0sv*sd*bc03sc*i*
alias: pci:v00008086d0000162Dsv*sd*bc03sc*i*
root@u1404:~/# lspci -nnk | grep '\[03' -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)
 Subsystem: Lenovo Device [17aa:5021]
 Kernel driver in use: i915
--
05:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] [1002:6604] (rev ff)
 Kernel driver in use: radeon
06:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader [10ec:5227] (rev 01)
root@u1404:~/# dpkg -l | grep -i video-intel
ii xserver-xorg-video-intel-lts-utopic 2:2.99.914-1~exp1ubuntu4.2~trusty1 amd64 X.Org X server -- Intel i8xx, i9xx display driver
root@u1404:~/#
</code>

girisha (girishad) wrote :

@ #12 at the time of commenting the proposed fixed is yet to be pushed on trusty proposed.. I guess we will have to wait a few hours :)

Timo Aaltonen (tjaalton) wrote :

lihow731 tested the trusty package

tags: added: verification-done-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu Trusty):
status: New → Confirmed
girisha (girishad) wrote :

as mentioned above I enabled trusty proposed updates and then created the proposed-updates file in /etc/apt/preferences.d

Package: *
Pin: release a=trusty-proposed
Pin-Priority: 400

so far I have not seen the update on trusty 14.04 (3.16.0-34-generic #47~14.04.1-Ubuntu)

Timo Aaltonen (tjaalton) wrote :

Because there is no fix uploaded for utopic yet. After that's in utopic-proposed and tested, the backport for trusty can be created..

you can't test the stock trusty package version on lts backport stack, as has been pointed out many times by now

girisha (girishad) wrote :

@ #17

Dear Timo, Thank you for the response. I was unaware of the terminology and how the bug fix is pushed. Sorry!!

John doe (r9-launchpad-fq) wrote :

As a workaround for utopic graphic stack users in trusty, I'm looking for a good way to revert back to the stock trusty package to use the proposed package, so if anybody try it, please share :)

John doe (r9-launchpad-fq) wrote :

*** dirty temp workaround for hurry people ***
If you want to use SNA on Ubuntu 14.04 with lts enablement stack while waiting for the patched xserver-xorg-video-intel-lts-utopic package, you may just replace the following files with the same files coming from the xserver-xorg-video-intel ([1] or [2]) package in trusty-proposed version (do it in tty1 for example as you will replace in use driver! ):
/usr/lib/libI810XvMC.so.1.0.0
/usr/lib/libIntelXvMC.so.1.0.0
/usr/lib/xorg/modules/drivers/intel_drv.so

Don't forget to remove any conf file you may have added to use XNA in /etc/X11/xorg.conf.d/.

This is really dirty, I don't know what will happen when the official package will come (don't forget to backup original files), but at least it seems to work for me !

[1] amd64 : http://fr.archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-intel/xserver-xorg-video-intel-dbg_2.99.910-0ubuntu1.6_amd64.deb
[2] i386 : http://fr.archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-intel/xserver-xorg-video-intel-dbg_2.99.910-0ubuntu1.6_i386.deb

Timo Aaltonen (tjaalton) wrote :

no, it really shouldn't work, since it's not built against the lts stack xserver..

Timo Aaltonen (tjaalton) on 2015-04-22
description: updated
girisha (girishad) wrote :

Is updating to 15.04 a solution?

John doe (r9-launchpad-fq) wrote :

You right, it doesn't work, and X load "Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)" as intel driver is of course not OK.

Timo Aaltonen (tjaalton) wrote :

the utopic & lts-utopic packages have been uploaded but not accepted yet

Timo Aaltonen (tjaalton) wrote :

the fix got acked and is building now, should be in utopic-proposed soon (and the backport for trusty too)

xserver-xorg-video-intel (2:2.99.914-1~exp1ubuntu4.3) utopic; urgency=medium

  * bdw-annotate-more-64bit-pointer-locations.diff
    bdw-clamp-urb-allocations-for-gt3.diff:
    Fix BDW GT3. (#1444436)

 -- Timo Aaltonen <email address hidden> Wed, 22 Apr 2015 19:57:12 +0300

tags: added: verification-needed-utopic
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: Confirmed → Fix Committed
Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu Trusty):
status: Confirmed → Fix Committed
John doe (r9-launchpad-fq) wrote :

Unfortunately, the proposed package don't fix my problem.

I install the proposed package :

dpkg -l | grep video-intel | grep ii$
ii xserver-xorg-video-intel-lts-utopic 2:2.99.914-1~exp1ubuntu4.3~trusty1 amd64 X.Org X server -- Intel i8xx, i9xx display driver

You can see the prb is still here in attachment. Important note: I have Intel® HD Graphics 5500 announced as Broadwell GT2 by Ubuntu System Information, not GT3.

Timo Aaltonen (tjaalton) wrote :

then the bugfix was never meant for you

John doe (r9-launchpad-fq) wrote :

It seems. I mark Bug #1432194 as duplicate as Chris told me it was the same bug as the current one. As some people may have the same different issue, what should I do? Create a new bug? De-depulicate #1432194 ? Thanks.

Bernd Schlapsi (bernd-sch) wrote :

So what is the solution for all users with an Intel HD Graphics 5500 (GT2)? I'm also still having the problem on my Lenovo Thinkpad T450s

Is it possible to reopen the Bug #1432194 again? Is there a known upstream solution for this problem?

Timo Aaltonen (tjaalton) wrote :

Unduped, that bug is probably a dupe of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1374389 instead

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.910-0ubuntu1.6

---------------
xserver-xorg-video-intel (2:2.99.910-0ubuntu1.6) trusty-proposed; urgency=medium

  * sna-mark-the-chv-vsync-method-as-unknown.diff: Fix video playback
    on CHV. (LP: #1445221)

xserver-xorg-video-intel (2:2.99.910-0ubuntu1.5) trusty-proposed; urgency=medium

  * bdw-annotate-more-64bit-pointer-locations.diff
    bdw-clamp-urb-allocations-for-gt3.diff:
    Fix BDW GT3. (LP: #1444436)
 -- Timo Aaltonen <email address hidden> Fri, 17 Apr 2015 08:00:47 +0300

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Timo Aaltonen (tjaalton) wrote :

tested the lts-utopic package on trusty, but since it's identical to the native utopic one marked this verified

tags: added: verification-done-utopic
removed: verification-needed-utopic
Brian Murray (brian-murray) wrote :

It's unfortunate the utopic changelog didn't have the LP bug reference properly formatted.

Timo Aaltonen (tjaalton) wrote :

utopic has 2:2.99.914-1~exp1ubuntu4.4 already

Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) wrote :

xserver-xorg-video-intel-lts-utopic (2:2.99.914-1~exp1ubuntu4.3~trusty1) trusty; urgency=medium

  * Backport utopic package for lts-utopic stack.

xserver-xorg-video-intel (2:2.99.914-1~exp1ubuntu4.3) utopic; urgency=medium

  * bdw-annotate-more-64bit-pointer-locations.diff
    bdw-clamp-urb-allocations-for-gt3.diff:
    Fix BDW GT3. (#1444436)

xserver-xorg-video-intel (2:2.99.914-1~exp1ubuntu4.2) utopic-proposed; urgency=medium

  [ Timo Aaltonen ]
  * Added patches:
    - disable-dri3.diff: Disable DRI3. (LP: #1401784)
    - sna-fix-gen8-blt.diff,
      sna-add-more-checks-and-asserts-for-blt.diff,
      sna-tweak-alignment-constraints-on-gen8.diff:
      Fix GEN8 BLT with 4bit address. (LP: #1401788)
  [ Maarten Lankhorst ]
  * Fix rotating external display with optimus results in corruption.
    - fix-sna-external-slave-rotation.patch (LP: #1410238)

Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers