Rotating external display with optimus results in corruption

Bug #1410238 reported by Maarten Lankhorst on 2015-01-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Maarten Lankhorst
Trusty
High
Maarten Lankhorst
Utopic
High
Maarten Lankhorst

Bug Description

[Impact]
 * Black screen when attempting to rotating external display in affected configurations.

[Test Case]
 * Run a system with a internal nvidia card, and 2 displays on the intel card. (Usually LCD screen + external VGA/DVI screen.)
 * Run xrandr --output <external> --rotate left
 * Expect a normal, rotated screen.
 * Bad behavior is a black screen.

[Regression Potential]
 * Low, only affects the transformed case in optimus mode, but it will be tested against !optimus config too.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
tags: added: trusty utopic vivid
Changed in xserver-xorg-video-intel (Ubuntu Trusty):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
Changed in xserver-xorg-video-intel (Ubuntu Trusty):
importance: Undecided → High
status: New → In Progress
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.917-1~exp1ubuntu2

---------------
xserver-xorg-video-intel (2:2.99.917-1~exp1ubuntu2) vivid; urgency=medium

  * Fix rotating external display with optimus results in corruption.
    - fix-sna-external-slave-rotation.patch (LP: #1410238)
 -- Maarten Lankhorst <email address hidden> Tue, 13 Jan 2015 15:16:03 +0100

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released

Hello Maarten, or anyone else affected,

Accepted xserver-xorg-video-intel into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.910-0ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Maarten, or anyone else affected,

Accepted xserver-xorg-video-intel into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.914-1~exp1ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Maarten Lankhorst (mlankhorst) wrote :

Tested against trusty and utopic, both rotate correctly!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.914-1~exp1ubuntu4.2

---------------
xserver-xorg-video-intel (2:2.99.914-1~exp1ubuntu4.2) utopic-proposed; urgency=medium

  [ Timo Aaltonen ]
  * Added patches:
    - disable-dri3.diff: Disable DRI3. (LP: #1401784)
    - sna-fix-gen8-blt.diff,
      sna-add-more-checks-and-asserts-for-blt.diff,
      sna-tweak-alignment-constraints-on-gen8.diff:
      Fix GEN8 BLT with 4bit address. (LP: #1401788)
  [ Maarten Lankhorst ]
  * Fix rotating external display with optimus results in corruption.
    - fix-sna-external-slave-rotation.patch (LP: #1410238)
 -- Maarten Lankhorst <email address hidden> Tue, 13 Jan 2015 17:16:49 +0100

Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.910-0ubuntu1.4

---------------
xserver-xorg-video-intel (2:2.99.910-0ubuntu1.4) trusty-proposed; urgency=medium

  [ Timo Aaltonen ]
  * sna-fix-gen8-blt.diff
    sna-tweak-alignment-constraints-on-gen8.diff
    sna-add-more-checks-and-asserts-for-blt.diff:
    - Fix GEN8 BLT with 4bit address. (LP: #1401788)

  [ Maarten Lankhorst ]
  * Fix regression with external displays on sna. (LP: #1405325)
  * Fix rotating external display with optimus results in corruption.
    - fix-sna-external-slave-rotation.patch (LP: #1410238)
 -- Maarten Lankhorst <email address hidden> Tue, 13 Jan 2015 17:14:19 +0100

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers