no 3d acceleration with error [drm:intel_dp_start_link_train] *ERROR* too many full retries, give up

Bug #1354046 reported by Jonas G. Drange on 2014-08-07
110
This bug affects 18 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Description:
3D games, video (especially flash) makes computer unresponsive. The problem has been present since upgrade to Utopic, but have recently become worse, maybe because of error message

[drm:intel_dp_start_link_train] *ERROR* too many full retries, give up

which appears in all terminals.

How to reproduce:
Start a 1080p video. e.g. Note that the video is not run from an encrypted folder.
Or watch a video on youtube.
Reproducable for new users as well, so not related to /home/$USER

What happens:
Usage on all four CPUs on my DELL XPS 13 DEVELOPER EDITION will be between 30% and 100%.

What I expected:
Expected same 3D performance as on Thrusty.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.16.0-6.11-generic 3.16.0-rc7
Uname: Linux 3.16.0-6-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.5-0ubuntu3
Architecture: amd64
BootLog:
 Scanning for Btrfs filesystems
  * Setting up X socket directories... 
[ OK ]
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Aug 7 17:03:51 2014
DistUpgraded: Fresh install
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20120703-2
DistroCodename: utopic
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.3.12, 3.13.0-24-generic, x86_64: installed
 vboxhost, 4.3.12, 3.13.0-27-generic, x86_64: installed
 vboxhost, 4.3.12, 3.13.0-29-generic, x86_64: installed
 vboxhost, 4.3.12, 3.16.0-5-generic, x86_64: installed
 vboxhost, 4.3.12, 3.16.0-6-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:058b]
InstallationDate: Installed on 2013-08-27 (345 days ago)
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
MachineType: Dell Inc. Dell System XPS L322X
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-6-generic root=UUID=221de9c1-f10a-4be4-9273-5c12864c8680 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/15/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0PJHXN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/15/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.11+14.10.20140707-0ubuntu1b1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.54-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 10.0.0-1ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Aug 7 16:54:59 2014
xserver.configfile: default
xserver.errors:
 intel: Failed to load module "dri3" (module does not exist, 0)
 intel: Failed to load module "present" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4933
 vendor CMN
xserver.version: 2:1.15.1-0ubuntu9

Jonas G. Drange (jonas-drange) wrote :
description: updated
description: updated
Jonas G. Drange (jonas-drange) wrote :

So far triaging has led me to these conclusions:
3.13.29: not affected
3.14.17: not affected
3.15.0: symptoms, compiz/unity dying

Will test 3.15.0 some more, then move to 3.16.rc1

Jonas G. Drange (jonas-drange) wrote :

3.15.0: cleared, not affected
3.16.rc1: affected

Meaning this was introduced some time between those two version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: trusty

This also happens in "utopic".

I also tried using the Kernel 3.17.1 from the kernel-ppa and the latest xserver from xorg-edgers ppa and I can see the same problem.

I using an Dell XPS 12 (Ultrabook)

Calin (calinuswork) wrote :

Same issue, with a Dell XPS 12 (Ultrabook)

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Undecided → High
_the_mars_ (themars) wrote :

Same issue on a Dell Latitude D6510. In Utopic and Trusty. I have seen this from more than a half year ago.

If I lock my screen, sometimes there is no password field to unlock it. If I go back to the terminal (Ctrl-Alt-F1), then that message is showing up.
My solution is to login on the terminal and then killing compiz with:
    pkill -9 compiz
When I switch back to my locked screen (Ctrl-Alt-F7) I have a password field and I can unlock my screen.

I have done a reinstall (on 2014-11-15) to Trusty, because Utopic does not work very well on this laptop. Issues with video playing and editing and slow keyboard performance (autotype in Keepassx is too fast and characters are not typed in the right order; in Google Chome typing is sometimes impossible; mssh is not working).

Same issue, with a ASUS UX32A (Ultrabook)

Ryan Karolak (rkarolak) wrote :

Getting the same error with Chromebook Pixel on all terminals occasionally.

Not sure if there are any other related symptoms. 3D and video works fine, although with 3D the system will start getting warm and kicking up the fans. I haven't done enough testing to know if this is typical with this laptop and that level of 3D processing though.

Runing 14.10 and MATE 1.8.1.

Ryan Karolak (rkarolak) wrote :

I was just able to reproduce it by previewing a 3D screensaver (Molecule). After clicking Leave Fullscreen X crashes with this as the error message on screen. Killing the session (ctrl-alt-backspace) will recover responsiveness and allows me to log back in.

K (kaeseblatt) wrote :

Since using kernel 3.19 (http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.19-vivid/), the problem is gone. Battery consumption down, general responsiveness up. Finally!

DELL E6510, Xubuntu 14.10

Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz
Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (i915)
OpenGL version string: 2.1 Mesa 10.3.2

eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm

linux-image-3.19.0-031900-generic

Jonas G. Drange (jonas-drange) wrote :

I've near searched to the end of Google to find a solution. One of my observations is that the symptoms of other bugs never matches the symptoms of this bug. On my laptop, everything seems to be OK—that is, until I run some thing requiring 3D. Then my machine grinds to a halt. No logs, no nothing. 100% on all four cores.

So, I'm thinking, what is _something_ is misbehaving, but the system believes everything to be OK? The answer to that, it seems, is cpu frequency scaling.

My CPU cores are scaled using the 'powersave' governance. Using Half Life 2 as a benchmark (this game ran well on trusty, but currently is not playable after 1.5 minutes), I looked at what happened to cpu frequencies while playing the game. At first, all four cores jumped to 3GHz [1]. Then, surprisingly, they were lowered to ~130 MHz [2].

Uh.

So, setting my cpu frequency scaling governance to 'performance' partly fixes this issue.

[1] http://pastebin.ubuntu.com/10276246/
[2] http://pastebin.ubuntu.com/10276257/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu (Ubuntu):
status: New → Confirmed
Bib (bybeu) wrote :

Same machine, same error
XPS L322X/0PJHXN, BIOS A10 08/28/2013
3.13.0-63-generic #103-Ubuntu SMP Fri Aug 14 21:42:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Teemu Torma (teemu-torma) wrote :

I had the same issue on Dell Latitude E6510 and utopic. Upgrading to vivid solved the issue (3.19 kernel).

Jonas G. Drange, thank you for reporting this bug to Ubuntu. Utopic reached EOL on July 23, 2015.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

If this is reproducible in a supported release, please file a new report.

tags: removed: trusty
no longer affects: ubuntu (Ubuntu)
no longer affects: linux (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
Norbert (nrbrtx) wrote :

I have the message "[drm:intel_dp_start_link_train] *ERROR* too many full retries, give up" on my Ubuntu 12.04.5 LTS with Intel i7-3537U CPU and 3.13 kernel from Trusty HWE.

tags: added: precise
Changed in xserver-xorg-video-intel (Ubuntu):
status: Invalid → Confirmed
Norbert (nrbrtx) wrote :

Forgot to mention - I have these results on Asustek UX32A laptop.

Norbert, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: High → Undecided
status: Confirmed → Invalid
tags: removed: precise
To post a comment you must log in.