very corrupt X after suspend/resume

Bug #133118 reported by Chris Jones on 2007-08-17
46
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
Gutsy
Undecided
Unassigned
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Gutsy
Undecided
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

I am running an updated gutsy install on a Thinkpad X40 (so i855GM graphics) with the -intel driver. I enabled Desktop Effects last night and the two times I have done a suspend/resume cycle since then, on resuming, is rendered entirely corruptly.
X appears to still function, in that i can just about make out where windows are and I can switch desktops and see the corrupt workspaces scroll.
Giving X the three finger salute makes it come back fine.

Impact: Affects laptop users with older intel 855 graphics when they suspend/resume, leading to 3D textured surface corruption (corrupt X graphics) on resume forcing the user to reboot (and lose any saved work). Because of this, the bug is considered serious and deserving of a backported fix for Gutsy.

Solution: The proposed patch adds a one-line fix to emit an invariant state at the appropriate point, to make X not become corrupted. This fix was uploaded to hardy about a week ago and testers report it correctly eliminates the corruption.

This patch has also been merged into the upstream intel driver.

Patch: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/133118/comments/64

Steps to reproduce:
1. On an intel 855gm graphics system, enable desktop effects
2. Suspend
3. Resume
4. Screen graphics become garbled/corrupted (but system is still responsive, just unusable)

Regression Potential: Low. It's a one-line change that merely modifies what is allowed to be cached between state changes for older i830-class hardware. The patch has been tested on various -intel chipsets by at least half a dozen people without any regression seen. Some have reported occasional crashes after resume, however this is believed to be a separate bug not particular to i855, that this bug was simply hiding.

Chris Jones (cmsj) wrote :

relevant output of lspci -vvnn:

00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA])
        Subsystem: IBM Unknown device [1014:0557]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at e0000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at d0000000 (32-bit, non-prefetchable) [size=512K]
        Region 2: I/O ports at 1800 [size=8]
        Capabilities: [d0] Power Management version 1
                Flags: PMEClk- DSI+ D1+ D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Justin M. Wray (wray-justin) wrote :

What version of Compiz are you running, and from what repository?

Thanks,
Justin M. Wray

Chris Jones (cmsj) wrote :

I have zero third repositories enabled and the gutsy install is up to date.

-(cmsj@waishou)-(~)- dpkg -l | grep compiz
ii compiz 1:0.5.2-0ubuntu3
ii compiz-core 1:0.5.2-0ubuntu3
ii compiz-fusion-plugins-extra 0.5.2+git20070813-0ubuntu2
ii compiz-fusion-plugins-main 0.5.2-0ubuntu2
ii compiz-gnome 1:0.5.2-0ubuntu3
ii compiz-plugins 1:0.5.2-0ubuntu3
ii compizconfig-settings-manager 0.5.2+git20070814-0ubuntu1
ii libcompizconfig-backend-gconf 0.5.2+git20070813-0ubuntu1
ii libcompizconfig0 0.5.2-0ubuntu1
ii python-compizconfig 0.0.0+git20070810-0ubuntu2

Changed in compiz:
status: New → Confirmed
Chris Jones (cmsj) wrote :

I see this, as does Soren Hansen at least.
It is not a compiz bug because it affects all 3D textures. Running xscreensaver hacks with textures shows similar problems.

To re-state - after resuming from suspend, every 3D texture is replaced with the wrong memory. I can see patterns in it, but it's still mostly random noise. Intel 855GM.

Soren Hansen (soren) wrote :

I just want to note I *do* in fact also see this :)

Chris Jones (cmsj) on 2007-09-10
description: updated
Greg T. (gjtbiz) wrote :

I saw this as well using Compize Fusion, but when I disabled "Sync to VBlank" in CompizConfig Settings Manager -> Display Settings, the visual noise went away after about five seconds after coming out of suspend, but usually taking down Compiz in the process. Running Metacity, I've had no problems.

Chris Jones (cmsj) wrote :

the corruption certainly will go away if compiz dies and metacity is resumed, because at that point the windows are rendered onscreen and aren't using 3D textures.
It's purely 3D textures that are corrupted (to confirm this, switch back to metacity, suspend, resume and run some 3d application, such as google earth or some of the xscreensaver hacks)

Bryce Harrington (bryce) wrote :

Has this been always happening with all tribes, or can you narrow it to one tribe where it worked, and another where it stopped?

Fwiw, there are a lot of suspend/resume laptop issues, although I think this is the first I've read where it comes back with corrupted X. Usually it doesn't come back at all. These are probably hardware-specific issues perhaps tied to ACPI implementation variations.

Chris Jones (cmsj) wrote :

Bryce: the description I set originally is probably quite misleading. It's not X that's corrupted, it's just 3D textures (ie every window in compiz, or any textured surface in a GL application with/without compiz running).

I will grab all of the tribes tomorrow and start going backwards to find one that works.

Michael Vogt (mvo) on 2007-09-19
Changed in xserver-xorg-video-intel:
importance: Undecided → High
Bryce Harrington (bryce) wrote :

Can you attach your /var/log/Xorg.0.log from after the corruption has occurred, and your /etc/X11/xorg.conf? Also, if it would be possible, please attach a photo or screenshot of the screen that displays the corruption.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: Confirmed → Incomplete
Chris Jones (cmsj) wrote :

Xorg.0.log (I did a reboot, logged in, started compiz, suspended, resumed, took a photo, killed compiz and ran metacity, then copied the logfile)

Chris Jones (cmsj) wrote :

xorg.conf (this one is quite minimal, basically I tried to rip out everything that I could, but I don't think it should be related, since Soren sees this too).

Chris Jones (cmsj) wrote :

Photo of corrupted display.

Interestingly, this is actually a little different to what I've seen previously - this is more solid areas of colour where before it would have been more akin to static noise.

Hopefully you can see that this is me browsing the Places menu (with tooltip), with a couple of other windows open.

Bryce Harrington (bryce) on 2007-09-25
Changed in xserver-xorg-video-intel:
status: Incomplete → Triaged
Bryce Harrington (bryce) wrote :

Thanks for trimming the xorg.conf down so much. There's a number of errors and warnings in your log file, although none that look like they'd cause the problem you're seeing. This one looks unusual; I've not see this before:

(II) Module sil164: vendor="X.Org Foundation"
 compiled for 1.3.0, module version = 1.0.0
 ABI class: X.Org Video Driver, version 1.2
(II) intel(0): I2C bus "DVOI2C_E" initialized.
(EE) intel(0): detecting sil164
(EE) intel(0): Unable to read from DVOI2C_E Slave 112.

Soren, can you compare your Xorg.0.log with Chris' to see what errors you both see in common?

Also, specific modules can be disabled by including this in the xorg.conf:

Section "Modules"
    Disable "<modulename>"
EndSection

It might be of interest to use this to disable modules like sil164 that are generating errors. I doubt it'll have an effect, but would be easy to test.

If it's possible, please test this on Tribe 5. That version preceded a bunch of xserver backport work that pulled in a number of patches, including a few that affected how the intel driver works. If we can rule that in or out it'll help narrow the search for the problem.

Chris Jones (cmsj) wrote :

(fwiw, I didn't trim down the config specifically for this - that *is* my X config ;)

I tried with:

Section "Module"
    Disable "sil164"
EndSection

and it didn't make a difference, but interestingly it still printed out the "detecting sil164" messages you quoted from the logs.

I'll try and install tribe5 tonight to test (since presumably i can't test suspend/resume from the LiveCD)

I think I'm seeing the same bug on a lifebook p7010 (although it behaves somewhat differently). After suspend I get black screen with the cursor. The cursor can be moved around, but nothing else works (can't click things in the dark, ctrl-alt-backspace doesn't work, etc.). The only thing that I can do at that point is to hard reboot the laptop.

On the other hand, if compiz is not enabled suspend + resume works just fine.

Should post more information here or file a new bugreport? If the former, which log files should post to help out?

Regards,
K.

By the way, I don't think this is a problem with the actual intel driver (if, indeed, I have the same problem as the original reporter). I tried to suspend and resume using the old i810-driver to narrow down the problem, and it failed also. In ubuntu versions prior to gutsy I've always been able to suspend and resume. So I would guess the problem is with the xserver or the mesa parts of the driver.

I really hope this bug can be squished :-)

Hi again,
I am really sorry to be spamming this bugreport. I' m just commenting to say say that I was probably mistaken in my last comment. Right now I'm using the old i810 driver and suspend + resume works just fine with compiz running. The failure I referred to before must have been due to something else.
So; resume fails with the intel driver only. (Sometimes even going into suspend mode seems to fail with the intel driver).

Bryce Harrington (bryce) wrote :

Chris, note it's "Modules" not "Module" - this might explain why you're still seeing the message?

I doubt it fixes it, but I've uploaded a new xserver today that fixes an error in mesa that causes it to inappropriately free too many visuals when switching video modes. I'd be a little surprised if that fix also fixes this bug, but it's possible and worth testing.

Bryce, thanks for the fix on xserver-xorg-core. With that patch I no longer have problems going into suspend (as expected), but I'm still having problems waking up. So, I guess there were two different problems after all.

Chris Jones (cmsj) wrote :

Bryce, I did try with "Modules" first and Xorg refused to accept my config file. I changed it to "Module" per xorg.conf's manpage.

Bryce Harrington (bryce) wrote :

On the off chance that this issue is fixed already upstream, I've packaged up the current git HEAD of the -intel driver:

http://people.ubuntu.com/~bryce/Testing/intel/

Would someone mind giving this .deb a spin? If this addresses the issue, we could try to identify which change fixed it and backport it to our driver.

Chris Jones (cmsj) wrote :

Thanks very much Bryce.

Interestingly, GL textures are no longer corrupted on resume, but rendering is falling back to indirect so is rather slow.

Chris Jones (cmsj) wrote :

err, obviously I forgot to attach any kind of errors:

-(cmsj@waishou)-(~)- glxgears
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering

Chris Jones (cmsj) wrote :

I powered down, booted up, suspended, resumed, ran a GL app or two. Attached is the Xorg log.

with the git deb I have no accelerated rendering, so resume seems to work. But that's not a surprise, I guess, since there's no aiglx to start with. Attached log...

Bryce Harrington (bryce) wrote :

Hmm... well do you guys feel that slow rendering is an improvement over corruption, or should we hold off until a proper fix is available?

I'm assuming the corruption went away because the rendering got clobbered, but I'll browse through the changelog to see what exactly caused the change.

I say rather acceleration than not. I mean, I might not have the same problem as others here, but even without the fix, suspend/resume works (sometimes) if compiz is not running. Then all one needs to do to get acceleration back on is to restart the server.
Please don't add this fix.

Also, has the patch here https://bugs.freedesktop.org/show_bug.cgi?id=11432 been tested?

Chris Jones (cmsj) wrote :

Personally, I suspend/resume multiple times a day, so either version of the driver is going to leave me with largely unusable 3D. I guess it would be more useful to have the old driver and know that I can at least restart the server if I want to run google earth or whatever.
If we can't fix it then this chipset should definitely be blacklisted for compiz.

Bryce Harrington (bryce) wrote :

Here's a deb of the patch on fdo 11432, if anyone would like to test it:

http://people.ubuntu.com/~bryce/Testing/intel/xserver-xorg-video-intel_2.1.1-0ubuntu3~bwh1_i386.deb

Others have confirmed that DRI is busted with this git head driver, so I suspect it's not worth further testing work. However, if anyone knows of fixes to this issue, point 'em out and we can test the individual commits.

I fear though that this might be the (still unfixed) DRM issue being discussed on the Xorg list, that I referenced above. It sounds like the fix will require kernel changes. In this case, I think we're going to have to punt this bug to Hardy, as this would likely be too invasive to fix for Gutsy.

Can anyone confirm that disabling DRI fixes the issue for the plain 2.1.1-0ubuntu5 driver? If so, then maybe we can just identify that as the workaround for now?

the new deb didn't work for me. I guess this needs to pass on to hardy...

Chris Jones (cmsj) wrote :

I was just browsing the Xorg list archives looking for the thread bryce mentioned when I noticed this:

http://lists.freedesktop.org/archives/xorg/2007-October/028963.html

Could it be because we're mixing and matching different bits of X releases?

Bryce Harrington (bryce) wrote :

In general I don't think it should matter, however I am a little concerned our drm might be dated. But in any case, I'm hopeful that if we have to postpone it to Hardy, that between upgrading our mesa, drm, and xserver, if there are any version mismatches, they'll be squared away at that point.

Changed in xserver-xorg-video-intel:
status: Unknown → New
climatewarrior (gabrieljoel) wrote :

I have the same exact video card on a Dell Latitude X300 laptop. Suspend and hibernate worked perfectly on Feisty but now I upgraded to Gutsy Release candidate and suspend doesnt work at all. I hace compiz fusion enabled and it works perfectly. I also had it in Feisty and suspend worked with that too. The only difference in my problem is that after putting my password to come back from suspend I just get a completely black screen. I tried using ctrl +alt+f1 and even that does nothing to my computer. Bye! thanksfor the great work

climatewarrior (gabrieljoel) wrote :

Never mind. I just fixed it with this.

http://ubuntuforums.org/showthread.php?t=350265

Cory Maccarrone (darkstar6262) wrote :

I'm seeing a similar problem on my laptop (i885GM) -- after resume, textures are all black. I discovered that if I start a second X session and close out of it again, textures work again. I even confirmed that immediately after resuming, if a second X session is started and stopped, resuming the compiz session works.

So, as a workaround, we would need to:

    - Suspend
    - Resume to text console
    - Start X :1, and then close it out again
    - Switch back to original X session

I guess something about the initialization of the second X server enables the textures to work again. Can anyone confirm this?

Bryce Harrington (bryce) wrote :

climatewarrior, thanks for pointing that out, however it looks like just a workaround, not a true fix.

Khashayar Naderehvandi, that could be a fix; that actually came out of work we have been doing for bug 127101. After mentioning it upstream, Jesse came up with that patch. You can test Jesse's patch in this package:

 http://people.ubuntu.com/~bryce/Testing/bug127101/xserver-xorg-video-intel_2.1.1-0ubuntu8~bwh1_i386.deb

The fix I ultimately committed for Gutsy is Peter Clifton's patch, which can also be downloaded here:

 http://people.ubuntu.com/~bryce/Testing/bug127101/xserver-xorg-video-intel_2.1.1-0ubuntu9_i386.deb

Please let me know if either of these fixes this bug. If not, we can dig into this deeper and hopefully get a fix out as an update or backport.

Chris Jones (cmsj) wrote :

Bryce: I just tested both of those packages and neither appears to fix this bug.

For kicks, I also tried the X :1 trick and after killing the second X server my laptop hung ;)

I just tried both of them as well. The first one (0ubuntu8~bwh1) causes a lockup before the computer has entered sleep mode. It looks as if the crash is caused by the VT switching but I'm not sure.

The second package results in the original behaviour: A seemingly working cursor against a black screen.

Let's keep digging! :-)

Peter Clifton (pcjc2) wrote :

http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2_i386.deb

Is my latest attempt to avoid the various crash on VT switch bugs being seen with the 855 hardware, but doesn't address the possible causes for this bug directly.

Thanks for the new package, Peter. Unfortunately, I still have the same behaviour. However, I'm not getting this in the logs anymore:

(EE) intel(0): I830 Vblank Pipe Setup Failed 0

Peter Clifton (pcjc2) wrote :

Dear all,

For your testing enjoyment:
http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2.2_i386.deb

This encorporates all other unreleased fixes I've been working on, and an additional line which aims to reset the 3D state of the card after VT switch. This may help after suspend, and at least one user has reported this helping.

Please let me know if this works.

Peter Clifton (pcjc2) on 2007-10-21
Changed in xserver-xorg-video-intel:
status: Triaged → In Progress
Cory Maccarrone (darkstar6262) wrote :

It worked beautifully for me. Both suspend to RAM and hibernate work correctly now.

Chris Jones (cmsj) wrote :

Peter's latest test package solves this bug for me.

Chris Jones (cmsj) wrote :

Setting compiz to invalid since this is an X driver bug

Changed in compiz:
status: New → Invalid

Fantastic!! I don't know what patches have gone in, but suspend/resume now works flawlessly (well, I've only tried one cycle so far and that worked just fine)! Thanks a lot to everyone involved! I'm indebted :-)

Peter's driver allows me to suspend and resume correctly also. Intel Corporation 82852/855GM Integrated Graphics Device (rev 02) on HP nx5000.

era (era) wrote :

So am I correct in assuming that for me, with Toshiba Libretto U105, intel driver (lspci sez 82852/855GM), I should be able to turn Compiz back on when/if xserver-xorg-video-intel is upgraded, without breaking suspend/hibernate (assuming this goes in)?

Runar Ingebrigtsen (ringe) wrote :

Thank you Peter! Your driver fixes my suspend/resume problems. Yay!

Soren Hansen (soren) wrote :

This works excellently for me, too! Thanks very much, Peter!

anco (ancovanbergeijk) wrote :

I just tried the this latest driver too on my toshiba R15-S829 82852/855GM

For me no luck at all even closing my laptop lid often gives a full crash, Dark, after hitting Fn-F5 to change output one centimeter garbidge in the top off the screen, rest of the screen last picture before closing the lid. Total crash no mouse movement, no alt-F? switching possible.

suspend also results in crash. getting loops of red, green, blue white, gray and black screen. Till I hard reset it....

I don't know what you guys are talking about compiz etc. I was just a satisfied ubuntu user for last two years on this laptop, now it is suddenly unworkable. Even screensaver I had to switch it off, because 5 out of 10 times it would freeze and it still freezes after just sitten for two hours or more. I regret my upgrade to gutsy.

I read other people switched back to i810, but don't say how. Feisty worked fine for me, so probably I'm the kind off user who needs to switch back till other people with knowhow figure this stuff out. Anybody having a hint for me how to change back?

thanks and many thanks to people who sort this kind of stuff out as their work/hobby.... Thanks!!!!

Hey Anco,

If you want to try to switch back to i810 temporarily, the only thing you need to do is to edit /etc/X11/xorg.conf (open a terminal and enter "gksu gedit /etc/X11/xorg.conf"). Then look for the line that reads
 Driver "intel"
It's under the "device" section. Change it to
 Driver "i810"

Hope this helps.

I hope this helps for now, until the other intel problems are resolved.

Regards,
K.

(By the way, was the patched intel package uploaded to the servers?)

anco (ancovanbergeijk) wrote :

Khashayar,

Thank you very much!!!! It works way better now, but don't know too well what the hack is happening
As you told me I looked at /etc/X11/xorg.conf and the line there was Driver "i810" already... So since I did the upgrade to gutsy via the update menu is must have been like this as I was running Feisty before and I never touched this file before to change a driver.

So all my X problems "closing lid crash, suspend crash, screensaver crash" happened after upgrade to gutsy, but with I810 driver selected in xorg.conf. Maybe this makes sense for some developers. Does the upgrade from Feisty to Gutsy not automaticly change to the intel driver?

anyhow I had already tried Peter Clifton's driver and another from a few days earlier. It all didn't make any difference due to my xorg.conf being on i810.. Sorry I didn't know,

So now I am happy to agree with above posts that every thing works fine with the driver in Peter's post 2007-10-21
I just closed my lid like 15 times, and no crash, tried suspend and no crash. Great.

Thank you,

anco (ancovanbergeijk) wrote :

Khashayar,

One more thought and than I quit giving mayby useless information... I stated:

anyhow I had already tried Peter Clifton's driver and another from a few days earlier. It all didn't make any difference due to my xorg.conf being on i810.. Sorry I didn't know,

This is not exactly true. eventhough I never touched xorg.conf and thus assume it was till today choosing Driver i810 peters drivers seemed to make some difference after installing them, like with the last one i got that loop after resuming from suspend seeing full red, green, bleu, grey screens. So just curius can you really go back to i810 driver with just one line in xorg and than all my X problems after upgrading to Gutsy must have been related to other new software.. messing up the old i810 driver, because feisty was running great....

Anyhow Gutsy starts to run great too now. Thank you developers.

dmontalvao (dmontalvao) wrote :

Peter's test package (10-21) didn't solve my problem... :(

I can actually suspend, introduce the password to unlock the session, but it freezes after that and I have to hard boot.

I didn't try to hibernate.

Ty anyway!

Peter Clifton (pcjc2) wrote :

dmontalvao, sounds like your experiencing a different bug. There are various open bugs, but I'm not sure which fits the issue you're seeing. Can you file a separate bug for that problem (or identify any of the existing ones which match your symptoms)?

Timo Aaltonen (tjaalton) wrote :

xserver-xorg-video-intel (2:2.1.1-0ubuntu10) hardy; urgency=low

  [ Bryce Harrington ]
  [Peter Clifton]
  * 08_fix_855_3D_state.diff
    - Emit the invariant 3D state to the GPU during EnterVT after
      marking the 3D state as clobbered. This fixes / works around
      textured surface corruption after resume on 855GM hardware.
      (Closes LP: #133118)
  * 07_fix_startup_blink.diff
    - Alter startup sequence to avoid blinking the display whilst
      initialising the graphics chip.
      (Closes LP: #148686)
  * 04_fix_hw_restore.diff
    - Only restore PIPE[AB]CONF if the DPLL for that PIPE is running
      and not in VGA pipeline mode.
      (Closes LP: #108056)

  [Kyle McMartin, Bryce Harrington]
  * 06_sync_quirks.diff:
    - Sync TV out quirks with upstream

 -- Timo Aaltonen <email address hidden> Thu, 01 Nov 2007 21:44:36 +0200

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
era (era) wrote :

So, what are the odds we'd get a backport of this for Gutsy?

Chris Jones (cmsj) wrote :

Is anyone else seeing occasional segfaults of X on resume with this driver? (the symptom would be that when you resume you get a login screen rather than a screensaver dialog)

I've lost the log, but the next time it happens I will be sure to grab it.

@Chris Jones - yes I've seen this happen a couple of times. I wasn't aware that X was crashing. Next time it happens I'll grab the log too.

Chris Jones (cmsj) wrote :

Attached is a complete X log that includes some successful suspend/resumes and ends with a resume that segfaults the X server.

Peter Clifton (pcjc2) wrote :

Super, thanks Chris..

I've seen that backtrace before, my notes remind me that I got it myself, resuming from suspend, so its not an 855 specific issue. I'm collecting Xorg bactraces here, and will try to go over them and figure out which bugs they correspond to when I've got some free time. (I've also got one which crashes in libextmod.so when I started playing a DVD).

Bryce Harrington (bryce) wrote :

For the record, here is peter's patch:
Index: xserver-xorg-video-intel-2.1.1/src/i830_driver.c
===================================================================
--- xserver-xorg-video-intel-2.1.1.orig/src/i830_driver.c 2007-10-21 22:08
:58.000000000 +0100
+++ xserver-xorg-video-intel-2.1.1/src/i830_driver.c 2007-10-21 22:28:04.0000
00000 +0100
@@ -3055,6 +3067,7 @@

    /* Mark 3D state as being clobbered */
    *pI830->last_3d = LAST_3D_OTHER;
+ IntelEmitInvarientState(pScrn);

    return TRUE;
 }

Bryce Harrington (bryce) wrote :
description: updated
Changed in xserver-xorg-video-intel:
milestone: ubuntu-7.10-rc → gutsy-updates
Peter Clifton (pcjc2) on 2007-11-09
description: updated
Changed in xserver-xorg-video-intel:
status: New → Fix Released
Bryce Harrington (bryce) wrote :

Subscribing ubuntu-sru, for Gutsy.

Changed in xserver-xorg-video-intel:
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Fixed in hardy. Please do not reopen hardy tasks for already fixed bugs. Use release tasks for this.

Changed in compiz:
status: New → Invalid
Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Ack'ed this patch for SRU.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: New → In Progress
January (january-weiner) wrote :

I am just adding this comment for the reference.

I had the same problem with Thinkpad X40. I have filed another bug report (#164456), because I failed to find this thread first.

 Downloading the package from http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/ solved the problem. My thinkpad is now waking up as it supposed.

I don't know what exactly is going on, but this problem returned as of today (I'm not aware of any package upgrades so I am baffled to say the least). Is anyone else seeing this?

Regards,
K.

Martin Pitt (pitti) wrote :

Sponsored and accepted into gutsy-proposed, please test.

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Chris Jones, anyone else with that hardware, can you please test the package in gutsy-proposed and give feedback here? Thank you!

Chris Jones (cmsj) wrote :

I'm moderately sure I was running the gutsy-proposed version, but I can't easily be sure because I have now upgraded the affected machine to Hardy, sorry!

era (era) wrote :

I can hibernate and wake back up on a Toshiba Libretto U105, with Gutsy proposed updates enabled and installed. I turned Compiz back on and tried, and the first experience is moderately positive. There was still a bit of an artefact when I turned the machine back on but it was quickly covered by the Gnome screensaver password dialog, and everything looked dandy after that.

This was hibernate (Fn+F3 on this machine, with a blue "save to memory" icon on the F3 key); proper suspend (Fn+F4, "save to hard disk" icon) does not seem to work. That is, when it booted back up, it didn't seem to find the stored state, and instead gave me a fresh Gnome log-in screen. (I'll see if I can find anything useful with "nosplash" and the "quiet" boot arg removed.) This could be related to this particular machine; I might not have been able to figure out how exactly to configure this part properly.

Jimmy (jimdbui) wrote :

hey guys,

i'm very new to the linux OS, but joined because i heard Ubuntu was relatively user-friendly. i thought i was adequate with computers until i ran into alot of little snags with ubuntu 7.10 on my dell 700m laptop. i also have the shutdown problem and in my search, found this thread and this great community of helpful people. i apologize ahead of time for the very nubile question, but what do i do with Peter's Patch? what do i do with that text code to install it? again, sorry for my lack of linux know-how, but your help would be much appreciative. thanks ahead of time guys!

- jim

Martin Pitt (pitti) wrote :

Jimmy,

if by "Peter's patch" you mean the solution to this bug (broken graphical display after suspend to RAM), then please enable System -> Administration -> Software sources -> Updates -> gutsy-proposed, update your system, and tell us here whether the problem was fixed for you.

Bryce Harrington (bryce) wrote :

Martin, can this be marked as Fix Released?

Jimmy (jimdbui) wrote :

Thank you Martin! the simple update fixed my troubles!

Martin Pitt (pitti) wrote :

If you have evidence that this doesn't regress on other hardware and fixes this bug, then we can move this to -updates. Jimmy's response seems to suggest that it works for him. Can you also test this yourself on your hardware, or know someone else who has?

Peter Clifton (pcjc2) wrote :

I've been running this (and other) patches to the intel driver since gutsy was released, on 945GM hardware. I've not seen any bugs which I'd attribute to this change.

The patch was applied upstream too:

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=commit;h=b8770f710729d616b3ac72544aa522161a78f819

Martin Pitt (pitti) wrote :

With two positive feedbacks I consider this verified, thank you! Copied to gutsy-updates.

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Rasyid (cid79-m) on 2010-09-07
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → Rasyid (cid79-m)
assignee: Rasyid (cid79-m) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.