new X1 Carbon 2014 + Onelink Pro dock + 30inch monitor: no native resolution

Bug #1307623 reported by Chunlei Wu
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Expired
Low
Unassigned

Bug Description

X1 Carbon 2014 model (20A7CTO1WW)
Thinkpad Onelink Pro dock (4X10E52935)
Dell U3011 30 inch monitor (native resolution: 2560x1600), connected to displayport on Onelink pro dock
Installed Ubuntu 14.04 (beta)

Max resolution on U3011 I can get is 1920x1440 right now.

Tried on Win 8.1 pro (dual boot), works fine at 2560x1600.
Tried the mini displayport on X1, works fine as well.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Apr 10 12:02:48 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:2218]
InstallationDate: Installed on 2014-04-04 (5 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
MachineType: LENOVO 20A7CTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic.efi.signed root=UUID=aa3a0809-4d57-42b1-bdbc-8eae27a9cde2 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/13/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: GRET30WW (1.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20A7CTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0E50510 Pro
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGRET30WW(1.07):bd01/13/2014:svnLENOVO:pn20A7CTO1WW:pvrThinkPadX1Carbon2nd:rvnLENOVO:rn20A7CTO1WW:rvrSDK0E50510Pro:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20A7CTO1WW
dmi.product.version: ThinkPad X1 Carbon 2nd
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Apr 10 09:27:26 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 1048
 vendor LGD
xserver.version: 2:1.15.0-1ubuntu7

Revision history for this message
Chunlei Wu (anewgene) wrote :
Timo Aaltonen (tjaalton)
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Revision history for this message
Chunlei Wu (anewgene) wrote :

I tried "Adding undetected resolutions" section from here (https://wiki.ubuntu.com/X/Config/Resolution#Adding_undetected_resolutions):

$ cvt 2560 1600 60
$ xrandr --newmode "2560x1600_60" 348.50 2560 2760 3032 3504 1600 1603 1609 1658 -hsync +vsync
$ xrandr --addmode DP2 2560x1600_60
$ xrandr --output DP2 --mode 2560x1600_60

Then I got the error "xrandr: Configure crtc 0 failed".

However, "2560x1440" resolution actually works fine:

$ xrandr --output DP2 --mode 2560x1440

"2560x1440" is an available mode, so I don't need to add it.

Revision history for this message
Chris Wilson (ickle) wrote :

Can you please try a recent kernel from ppa:mainline #drm-intel-nightly, and attach xrandr --verbose with the monitor attached to the mini-dp on the laptop as well as through the dock?

Revision history for this message
Chunlei Wu (anewgene) wrote :

Ok, installed these two debs from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/current/

    linux-headers-3.14.0-994-generic_3.14.0-994.201404150253_amd64.deb
    linux-image-3.14.0-994-generic_3.14.0-994.201404150253_amd64.deb

I actually had error during the installation (see attached "kernel_install_error.txt")

Nevertheless, I rebooted and 3.14 kernel is available from grub menu and I booted with that kernel, here is what I got:

* build-in mini-DP port (DP1) still works at 2560x1600 (see attached "xrandr_dp1.txt")
* DP port from the Onelink Pro dock (DP2) works at 2560x1600 now. Yeah!! (see attached "xrandr_dp2.txt")
* However, my laptop display is always dark, even though it shows "on" from "Displays" settings. It actually flashed once and then turned dark when it's turned on. Even when I reboot the laptop without any external monitor, it's still dark.

To summary, looks like the latest "3.14.0-994.201404150253" kernel fixed the issue with the external monitor on the onelink pro dock, but had another bug with my new X1 Carbon touch's build-in display.

(Why I cannot attach multiple files in one comment? I will add two more attachments in the following comments.)

Revision history for this message
Chunlei Wu (anewgene) wrote :
Revision history for this message
Chunlei Wu (anewgene) wrote :
Revision history for this message
Chunlei Wu (anewgene) wrote :

scratch that "kernel_install_errors.txt" in previous comment. There was another deb package I should have installed:

linux-headers-3.14.0-994_3.14.0-994.201404150253_all.deb

After all three debs installed, the display issue still the same.

Revision history for this message
Chris Wilson (ickle) wrote :

Ok, that should be sufficient. The kernel patches for high dotclock modes was in v3.12, but Xserver support only landed in xorg-server-1.15.99.901.

Revision history for this message
Chunlei Wu (anewgene) wrote :

Thanks. Is there a way to get xorg-server-1.15.99.901 on Ubuntu Trusty, or just wait for the upstream updates?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Chunlei Wu, any change updating to the Vivid enablement stack as outlined in https://wiki.ubuntu.com/Kernel/LTSEnablementStack ?

tags: added: bios-outdated-1.22
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers