[HSW mesa kde needs Xorg-1.15.1] Multiple tiling-esque artifacts in KDE

Bug #1294666 reported by Rohan Garg on 2014-03-19
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

This is a fresh install of Trusty on a computer with a Intel card

Screenshots of issues attached.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Wed Mar 19 14:56:28 2014
InstallationDate: Installed on 2014-03-18 (0 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140318)
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2014-03-18 (0 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140318)
Package: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Tags: trusty
Uname: Linux 3.13.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
---
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: kwin
CurrentDesktop: KDE
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: kubuntu
DkmsStatus:
 virtualbox, 4.3.6, 3.13.0-17-generic, x86_64: installed
 virtualbox, 4.3.6, 3.13.0-18-generic, x86_64: installed
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8534]
InstallationDate: Installed on 2014-03-18 (0 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140318)
MachineType: ASUS All Series
Package: xorg 1:7.7+1ubuntu8
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-18-generic root=UUID=73e39066-99b2-4d28-8ba0-b84cc94d256b ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Tags: trusty kubuntu single-occurrence reproducible has-fix
Uname: Linux 3.13.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 10/25/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0903
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z87-K
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0903:bd10/25/2013:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ87-K:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Tue Mar 18 18:24:10 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 9363
 vendor ACI
xserver.version: 2:1.15.0-1ubuntu7

Rohan Garg (rohangarg) wrote :
Rohan Garg (rohangarg) wrote :
tags: added: apport-collected
description: updated

apport information

apport information

apport information

tags: added: has-fix kubuntu reproducible single-occurrence
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Robert Hooker (sarvatt) on 2014-03-19
summary: - Multiple graphical artifacts in KDE with i915 driver
+ [HSW] Multiple graphical artifacts in KDE with i915 driver
Chris Wilson (ickle) on 2014-03-19
summary: - [HSW] Multiple graphical artifacts in KDE with i915 driver
+ [HSW mesa kde] Multiple tiling-esque artifacts in KDE

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

It prevents the package (or a dependent one) from functioning correctly at all.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Chris Wilson (ickle) wrote :

A workaround for this bug should be in Xorg-1.15.1. The underlying bug in mesa still remains at large though.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed
summary: - [HSW mesa kde] Multiple tiling-esque artifacts in KDE
+ [HSW mesa kde needs Xorg-1.15.1] Multiple tiling-esque artifacts in KDE
Rohan Garg (rohangarg) wrote :

@Chris Do you think we can release with the patch in the package? I'd consider this a release blocker to be honest since it renders KDE pretty much unusable on Intel cards.

Chris Wilson (ickle) wrote :

Yes, the patch is pretty innocuous and has had many people succesfsully test it.

For reference, the patch in question is:

commit eec04d76a39a7334de4e00ef9f0f6e44c92b3d91
Author: Eric Anholt <email address hidden>
Date: Thu Mar 6 18:50:07 2014 -0800

    glx: Clear new FBConfig attributes to 0 by default.

    The visualSelectGroup wasn't getting set (since our DRI drivers don't
    use it), and and since it's the top priority in the sort order, you
    got random sorting of your visuals unless malloc really returned you
    new memory. This manifested as Xephyr -glamor rendering to a
    multisampled window on my system, which as you might guess was
    slightly lower performance than expected.

    Signed-off-by: Eric Anholt <email address hidden>
    Reviewed-by: Michel Dänzer <email address hidden>

Rohan Garg (rohangarg) wrote :

Could you patch the package and upload it? Would be really appreciated :)

Nikola Snele (n-schnelle) wrote :

I can confirm that bug is fixed with latest update.

anavarre (aurelien.navarre) wrote :

Maybe I missed something here but it's unfortunately not fixing my compositing issues with Kubuntu. I got Kwin to crash twice and noticed one artifact (there's progress already since I got many before) - Please see attached.

$ dpkg -l | grep xserver-xorg-video-intel
ii xserver-xorg-video-intel 2:2.99.910-0ubuntu1 amd64

Nikola Snele (n-schnelle) wrote :

I think you should reset kwin to default settings. This is what I did:

1) Update system
2) Log out and ctrl+alt+f1 and log in
3) sudo service lightdm stop
4) rm ~/.kde/share/config/kwinrc
5) sudo reboot

anavarre (aurelien.navarre) wrote :

Thanks, Nikola. I followed your recommendation and it does look better now. I'll be trying to test things more today and will report back here.

anavarre (aurelien.navarre) wrote :

After spending several hours back with compositing I'm glad to report all artifact issues seem to be fixed! Many thanks.

Rohan Garg (rohangarg) wrote :

I can confirm this is fixed on my system as well. Marking as fixed.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.