[gutsy] animations and video watching aren't possible with an external monitor on an Intel laptop

Bug #129025 reported by unggnu on 2007-07-29
6
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I am using a Sony TX2 laptop which is shipped with Intel 915 onboard graphic. I have checked the new Intel driver with the second Ubuntu Gutsy Live CD (Tribe 3) which is shipped with the xserver-xorg-video-intel (2:2.1.0-1ubuntu1) driver and Xorg 7.3 git. It works fine with my external monitor (1680x1050) if I change the driver from "i810" to "intel" in xorg.conf but it doesn't shut down the LFP like the old i810-modesetting driver. It always show an extract of the external on the LFP (1366x768). It is possible with xrandr to disable LFP (xrandr --output LVDS --off) but Video watching or 3D animations are still impossible because of huge lags and displaced output. It seems that the monitor was disabled but the graphic card doesn't realized that. I don't have this problems with videos with i810-modesetting since this disables the monitor in xorg.conf with MonitorLayout.
But since i810-modesetting couldn't display my native laptop resolution I have to switch between the standard i810 driver (the Feisty intel driver couldn't display 1366x768 too) and modesetting everytime I want to use the external or the internal.

Changed in xorg-server:
status: Unknown → Confirmed
unggnu (unggnu) wrote :

This seems to be fixed in current Gutsy. The problem with Clone mode is still there but this could be fixed through adding something like that to /etc/gdm/Init/Default:

#disable lfp if external monitor is connected
if xrandr | grep -q "VGA connected"
then
        xrandr --output LVDS --off
fi

Compiz works but it is very slow on 1680x1050 screen. Maybe it is fault of the weak i915 chip.

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Changed in xorg-server:
status: Confirmed → Fix Released
unggnu (unggnu) wrote :

Through some testings with the intel crash bugs I have removed the intel driver overlay fix of bug # 39050 which results in the same problem. Without it video watching is nearly impossible because of lags and fractals and so on.

unggnu (unggnu) wrote :

Sorry, the patch is from bug # 111257.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.