Intel driver breaks 1680x1050 on TMDS-1 output

Bug #128927 reported by Anthony Liguori on 2007-07-28
2
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Medium
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

When using 1680x1050 and outputting to an external monitor via DVI, the driver outputs in 1680x1053 causing portions of the screen to be scaled and fuzzy. This problem has been discussed and fixed in the upstream tree. More information is available at http://lists.freedesktop.org/archives/xorg/2007-July/026528.html

I have confirmed that this bug is present in the latest gutsy package (2:2.1.0-1ubuntu1). I have also confirmed that this is fixed upstream (I'm using 15f71edba37738f8ba279fa07452fda10cc65298).

I'm using a T61 laptop and have an Samsung 206bw monitor.

Created an attachment (id=10809)
xorg.conf.good-bad

Created an attachment (id=10810)
Xorg.0.log.good

Created an attachment (id=10811)
Xorg.0.log.bad

Logfiles have been generated with "Xorg -verbose 9 -logverbose 9". There are no real differences between the "good" and the "bad" one.

Several problem have been reported in driver 2.1.0 due to this commit, and they have been fixed since then. So your bug is very probably fixed in current git HEAD.

*** This bug has been marked as a duplicate of bug 11606 ***

Subject: Re: Latest intel driver breaks 1680x1050 mode on TMDS-1 output
From: Keith Packard
To: Stefan Dirsch <email address hidden>
Date: Fri, 20 Jul 2007 11:29:22 -0700

On Fri, 2007-07-20 at 12:00 +0200, Stefan Dirsch wrote:
> Hi
>
> Latest intel driver breaks 1680x1050 mode on TMDS-1 output only (works
> fine when using VGA output). Monitor gets 1680x1053 instead and breaks
> the picture by scaling in y direction.

Did you try master? Should be fixed already.

Binary package hint: xserver-xorg-video-intel

When using 1680x1050 and outputting to an external monitor via DVI, the driver outputs in 1680x1053 causing portions of the screen to be scaled and fuzzy. This problem has been discussed and fixed in the upstream tree. More information is available at http://lists.freedesktop.org/archives/xorg/2007-July/026528.html

I have confirmed that this bug is present in the latest gutsy package (2:2.1.0-1ubuntu1). I have also confirmed that this is fixed upstream (I'm using 15f71edba37738f8ba279fa07452fda10cc65298).

I'm using a T61 laptop and have an Samsung 206bw monitor.

Yes, this has been fixed in master branch. Latest changelog entry:

commit 15f71edba37738f8ba279fa07452fda10cc65298
Author: Zhenyu Wang <email address hidden>
Date: Sat Jul 28 17:43:29 2007 +0800

    Update Lenovo TV quirk info

Changed in xorg-server:
status: Unknown → Invalid
Timo Aaltonen (tjaalton) wrote :

Gutsy has 2.1.1, so this bug should be fixed. If not, please reopen.

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Changed in xorg-server:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.