[2.99.910] Graphical artifacts in button with some toolkits (eg. in pgadmin)

Bug #1277143 reported by Franck on 2014-02-06
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

After upgrading to latest version of xserver-xorg-video-intel, I see some visual artifacts on the buttons of some of my applications, espacially in the "save under" dialogs (but probably not only).

Some examples are attached.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-video-intel 2:2.99.909-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-7.26-generic 3.13.1
Uname: Linux 3.13.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Feb 6 16:44:17 2014
DistUpgraded: 2014-01-22 17:41:22,726 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 acpi-call, 20130623, 3.13.0-7-generic, x86_64: installed
 virtualbox, 4.3.2, 3.13.0-7-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21fb]
InstallationDate: Installed on 2013-02-16 (354 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130216)
MachineType: LENOVO 2353CTO
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-7-generic root=UUID=bb7483c9-09ca-49c5-9cb5-fd6ecf814340 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to trusty on 2014-01-22 (14 days ago)
dmi.bios.date: 04/30/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ET94WW (2.54 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2353CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ET94WW(2.54):bd04/30/2013:svnLENOVO:pn2353CTO:pvrThinkPadT430s:rvnLENOVO:rn2353CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2353CTO
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 10.0.1-1ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.909-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Thu Feb 6 09:59:44 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12876
 vendor SEC
xserver.version: 2:1.15.0-1ubuntu2

Franck (alci) wrote :
Franck (alci) wrote :

Another example

Chris Wilson (ickle) wrote :

commit 853588ad5be9407d2123f6055458ca84e72b8eb9
Author: Chris Wilson <email address hidden>
Date: Sat Feb 1 21:55:09 2014 +0000

    sna: If IGNORE_CPU is not set we must mark the move as MOVE_READ

    Logic reversal in discarding CPU damage. An old bug revealed by the more
    aggressive attempts to discard CPU damage.

    Signed-off-by: Chris Wilson <email address hidden>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Chris Wilson (ickle) wrote :

Fixed upstream in 2.99.910

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed
summary: - Graphical artifacts in button with some toolkits (eg. in pgadmin)
+ [2.99.910] Graphical artifacts in button with some toolkits (eg. in
+ pgadmin)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.910-0ubuntu1

---------------
xserver-xorg-video-intel (2:2.99.910-0ubuntu1) trusty; urgency=medium

  * Merge from Debian git. (LP: #1277143)
 -- Timo Aaltonen <email address hidden> Mon, 10 Feb 2014 14:03:01 +0200

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.