[SRU] Build and distribute intel-virtual-output

Bug #1247528 reported by Jethro Beekman on 2013-11-03
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
Wishlist
Unassigned
Trusty
Wishlist
Daniel Gimpelevich

Bug Description

[Impact]

xserver-xorg-video-intel 2.99.904 adds support for virtual displays that can be used to clone to discrete outputs. The tool to do this is included with the xserver-xorg-video-intel source (with not-so-great man page and all), but the binary is currently not shipped by Ubuntu trusty, despite being built. It is shipped in utopic and later.

The tool will allocate a virtual output for the specified outputs on a different X server (or for all outputs with the -a parameter). It will also copy over resolution information etc from xrandr. You can then use your desktop environment's display tool to configure these external displays the way you would normally do in a non-hybrid situation.

Since the trusty release is LTS, this bug qualifies for SRU status "to enable new hardware," or rather, newly supported at the time of the trusty release.

[Test Case]

1) Install the package.
2) Attempt to execute /usr/bin/intel-virtual-output in a shell.

[Regression Potential]

Absolutely none.

[Other Info]

The intel-gpu-tools package is the only reverse dependency, and that package has no reverse dependencies in turn.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Raul Dias (rsd) wrote :
Florian Echtler (floe) wrote :

This bug is still present in the 14.04 beta, and it's a one-line fix:
    echo "usr/bin/intel-virtual-output" >> debian/xserver-xorg-video-intel.install
Would make things a lot easier for those using bumblebee instead of nvidia-prime.

Florian Echtler (floe) wrote :

Here's a slightly more detailed list of instructions to get the intel-virtual-output tool:

sudo apt-get build-dep xserver-xorg-video-intel
apt-get source xserver-xorg-video-intel
cd xserver-xorg-video-intel-2.99.910/ # adjust version number if necessary
echo "usr/bin/intel-virtual-output" >> debian/xserver-xorg-video-intel.install
debuild
cd ..
sudo dpkg -i xserver-xorg-video-intel*.deb

Hope this helps!

tags: added: trusty xenial

How do we nominate this for trusty-updates?

tags: removed: xenial
Changed in xserver-xorg-video-intel (Debian):
status: Unknown → Fix Released
description: updated
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Wishlist
Gunnar Hjalmarsson (gunnarhj) wrote :

@Daniel: To get it done, I'd advise you to provide a patch and subscribe ubuntu-sponsors.

Gunnar Hjalmarsson (gunnarhj) wrote :

Nice, Daniel. If you also include in the patch the necessary entry in debian/changelog, you increase the chances that the sponsor uploads directly to the -trusty queue instead of pointing out that more work is neeed.

tags: added: patch
Gunnar Hjalmarsson (gunnarhj) wrote :

This item is now visible on <http://reqorts.qa.ubuntu.com/reports/sponsoring> and will be reviewed of a sponsor in a few days (or weeks).

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed
Gunnar Hjalmarsson (gunnarhj) wrote :

@Mathew: It's *not* committed yet.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → In Progress
Mathew Hodson (mathew-hodson) wrote :

I changed the status because according to the description, "It is shipped in utopic and later." According to that the development task is actually Fix Released. I left it at Committed, because the Trusty task hasn't been added yet, and I wanted to make sure the bug still showed up on the list.

Gunnar Hjalmarsson (gunnarhj) wrote :

Aha, right Mathew, I forgot that the trusty task isn't there yet. The list was indeed my concern, and now I understand that you thought of that too. Sorry if I sounded harsh.

Any progress?

You guys have had the patch for 4 months now. How much longer?

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Incomplete
Dmitry Shachnev (mitya57) wrote :

In the zesty package /usr/bin/intel-virtual-output is installed, so closing this bug in Ubuntu and adding an Ubuntu (Xenial) task.

The patch is incomplete — according to the Debian package changelog, you need to add some build-dependencies.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Since I made some noise on the ubuntu-devel list about this, I thought I'd help out.

I added those build dependencies, and could build it successfully:

https://launchpad.net/~gunnarhj/+archive/ubuntu/intel-virtual-output

New debdiff attached.

Thanks LocutusOfBorg and Dmitry for your assistance!

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
assignee: nobody → Daniel Gimpelevich (daniel-gimpelevich)
importance: Undecided → Wishlist
status: New → In Progress
no longer affects: xserver-xorg-video-intel (Ubuntu Xenial)

Hi, I sponsored it, even if the package increased its size for about 1MB.
The patch was sane enough, a cherry-pick from later releases, and just a new tool added
(I also melded both changelogs, to see if the new dependencies were carrying new hidden tools/flags).
the package is now in unapproved queue
https://launchpad.net/ubuntu/trusty/+queue?queue_state=1&queue_text=

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: In Progress → Fix Committed
summary: - Build and distribute intel-virtual-output
+ [SRU] Build and distribute intel-virtual-output

Hello Jethro, or anyone else affected,

Accepted xserver-xorg-video-intel into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.910-0ubuntu1.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

the new binary is here now.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.910-0ubuntu1.7

---------------
xserver-xorg-video-intel (2:2.99.910-0ubuntu1.7) trusty-proposed; urgency=medium

  * Package intel-virtual-output (LP: #1247528)
    - debian/xserver-xorg-video-intel.install: Install it
    - debian/control: Additional build dependencies: libxinerama-dev,
      libxrandr-dev, libxdamage-dev, libxcursor-dev, libxtst-dev,
      libxrender-dev, libpixman-1-dev

 -- Daniel Gimpelevich <email address hidden> Wed, 17 Aug 2016 18:57:05 -0700

Changed in xserver-xorg-video-intel (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.