Intel mobile graphics controller not detected on GMCHB0ICHB0

Bug #122886 reported by Marc Tardif on 2007-06-28
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

The mobile graphics controller on the GMCHB0ICHB0 motherboard does not seem to be detected properly.

First, when rebooting the machine, I get an xorg error message on blue background. So, I have attached the corresponding Xorg.0.log.

Then, when looking at the xorg.conf, I see that the xorg.conf file contains "vesa" as the driver. So, I have attached that file as well.

Second, I changed the driver to "intel" and tried restarting gdm but I still got the same behavior. So, I looked at the Xorg.0.log file and noticed the following error message:

Parse error on line 72 of section Monitor in file /etc/X11/xorg.conf
    The HorizSync keyword must be followed by a list of numbers or ranges.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Third, I ran dpkg-reconfigure xserver-xorg to autodetect the monitor and it finally worked. Could the problem be that the monitor was not configured during the installation process?

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Kyle McMartin (kyle) on 2007-06-28
Changed in xserver-xorg-video-intel:
assignee: nobody → kyle
Kyle McMartin (kyle) wrote :

GMCHB0ICHB0 isn't a particularly useful identifier for this board. Is it not marked with anything else?

Anyway, from the pci ids, I can see that it's a 965GM.

Please try tomorrow's daily as it will have an updated discover-data.

Kyle McMartin (kyle) wrote :

btw, the EDID data is like, ultra corrupted. Is it connected to a kvm or something?

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Kyle McMartin (kyle) wrote :

Can you attach the output of "sudo ddcprobe" to this bug report?

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Yes, the machine is indeed connected to a KVM. By the way, when I managed to get it working as described initially, it was still connected to a KVM.

Kyle McMartin (kyle) wrote :

Ok. The ddcprobe output looks good. Can you try reproducing this to see if it wasn't just a freak accident?

Henrik Nilsen Omma (henrik) wrote :

I don't really like the grey bug icons. Setting importance.

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
Kyle McMartin (kyle) wrote :

Able to reproduce with tribe3?

Martin Pitt (pitti) wrote :

Not a showstopper for Tribe 4, since this seems to be quite hardware specific, and waiting for answer from Marc. Moving.

Henrik Nilsen Omma (henrik) wrote :

Moving to tribe 6.

Henrik Nilsen Omma (henrik) wrote :

Moving milestone to beta.

Colin Watson (cjwatson) wrote :

Moving milestone forward. Marc, please respond to the request for feedback from you.

Mathew Chacko (yesmathew) wrote :

Is my problem related to this same bug?

- Mac Mini intel, Mobile Intel 945GM, Acer AL1713 display.

Gutsy beta, daily livecd 02-10-2007, edubuntu 7.10 beta. GDM fails to start after:
* Running local boot scripts (/etc/rc.local) ------------- [OK]

Marc Tardif (cr3) wrote :

I have tried to reproduce this problem on the Intel GMCHB0ICHB0 and the graphics controller works just fine. This bug can be closed as far as I'm concerned.

Marc Tardif (cr3) wrote :

By the way, I tested beta.

Brian Murray (brian-murray) wrote :

mathew.chacko - you bug report is probably not related to this one as it is about a different video card. Please open a new bug report about xorg and include your '/etc/X11/Xorg.conf' and '/var/log/Xorg.0.log' and feel free to subscribe me to it. Thanks in advance.

Brian Murray (brian-murray) wrote :

Marking as fix released as it is no longer reproducable with the Beta CD.

Changed in xserver-xorg-video-intel:
assignee: kyle → nobody
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers