Webcam capture plays green screen through xv on Haswell platform

Bug #1220645 reported by Yung Shen on 2013-09-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Critical
Robert Hooker
Raring
Critical
Robert Hooker
xserver-xorg-video-intel-lts-raring (Ubuntu)
Critical
Unassigned
Precise
Undecided
Unassigned

Bug Description

xv driver is having playback issue with webcam capture, it plays green screen.

It was firstly found when using stock 12.04.3 image, during on installing step of "Choose a Picture", the webcam view only playback with green screen, but it still can capture correctly if you hit the button.

After completely installed 12.04.3 system or upgrade your X driver stack to lts-raring,
on system with haswell chipset, webcam capture will playback with green screen.

To reproduced this problem we could use:

guvcview

luvcview

mplayer tv:///dev/video0 -vo xv

vlc v4l2:/ //dev/video0 -V xv

On the same hardware system,

To validate that webcam works fine with other output drivers:

luvcview -w

mplayer tv:///dev/video0 -vo x11

vlc v4l2:/ //dev/video0 -V glx

By downgrade to xserver-xorg-lts-quantal also fixes this issue,
its also verified on 12.04.2 stock image with the same webcam.
Affected webcams:

1bcf:289e Sunplus
1bcf:2985 Sunplus
0c45:64af Microdia
0c45:64ad Microdia
064e:812c Suyin

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-lts-raring 1:7.7+1ubuntu4~precise1
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
Uname: Linux 3.8.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Wed Sep 4 06:59:59 2013
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg-lts-raring
UpgradeStatus: No upgrade log present (probably fresh install)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1311 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7e14000 irq 62'
   Mixer name : 'Intel Haswell HDMI'
   Components : 'HDA:80862807,80860101,00100000'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
Card1.Amixer.info:
 Card hw:1 'PCH'/'HDA Intel PCH at 0xf7e10000 irq 62'
   Mixer name : 'Realtek ALC283'
   Components : 'HDA:10ec0283,102805f3,00100003'
   Controls : 14
   Simple ctrls : 7
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=65f73994-7b9b-40b6-a815-0beafb8c94ef
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Dell Inc. Inspiron 3437
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-39-generic root=UUID=6bde1692-22e7-4822-95b8-59fd86f63632 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-39.60~precise1-generic 3.5.7.17
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-39-generic N/A
 linux-backports-modules-3.5.0-39-generic N/A
 linux-firmware 1.79.6
RfKill:

Tags: precise running-unity
Uname: Linux 3.5.0-39-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 06/06/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X19
dmi.board.vendor: Dell Inc.
dmi.board.version: X19
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrX19:bd06/06/2013:svnDellInc.:pnInspiron3437:pvrNotSpecified:rvnDellInc.:rn:rvrX19:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Inspiron 3437
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1311 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7e14000 irq 62'
   Mixer name : 'Intel Haswell HDMI'
   Components : 'HDA:80862807,80860101,00100000'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
Card1.Amixer.info:
 Card hw:1 'PCH'/'HDA Intel PCH at 0xf7e10000 irq 62'
   Mixer name : 'Realtek ALC283'
   Components : 'HDA:10ec0283,102805f3,00100003'
   Controls : 14
   Simple ctrls : 7
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=65f73994-7b9b-40b6-a815-0beafb8c94ef
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Dell Inc. Inspiron 3437
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-39-generic root=UUID=6bde1692-22e7-4822-95b8-59fd86f63632 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-39.60~precise1-generic 3.5.7.17
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-39-generic N/A
 linux-backports-modules-3.5.0-39-generic N/A
 linux-firmware 1.79.6
RfKill:

Tags: precise running-unity
Uname: Linux 3.5.0-39-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 06/06/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X19
dmi.board.vendor: Dell Inc.
dmi.board.version: X19
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrX19:bd06/06/2013:svnDellInc.:pnInspiron3437:pvrNotSpecified:rvnDellInc.:rn:rvrX19:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Inspiron 3437
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.

Yung Shen (kaxing) wrote :
Yung Shen (kaxing) on 2013-09-04
description: updated
Dimitri John Ledkov (xnox) wrote :

Ubiquity bugs are only tracked in Ubuntu ubiquity package.

This issue will not be fixed, in later releases webcam step has been altogether removed, due to being buggy, creepy and not providing significant benefit to the users. We may push a change in ubiquity to also remove the webcam step in 12.04.4 release but I'm not sure that qualifies under stable release updates policy.

Changed in xorg-lts-raring (Ubuntu):
status: New → Won't Fix
affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Won't Fix
Yung Shen (kaxing) wrote :

@xnox
thanks for the informative comment, I will remove ubiquity from affected package and update the description.

description: updated
Changed in xorg-lts-raring (Ubuntu):
status: Won't Fix → New
Yung Shen (kaxing) on 2013-09-06
summary: - Webcam view shows green screen
+ Webcam capture plays green screen on Haswell platform through xv
summary: - Webcam capture plays green screen on Haswell platform through xv
+ Webcam capture plays green screen through xv on Haswell platform
Yung Shen (kaxing) on 2013-09-06
description: updated
Yung Shen (kaxing) wrote :

Some more updates to this bug:

When you recording from webcam directly to a file,
and play this file with totem it plays green screen,
however using other video output driver could play normally.

to record:

$ avconv -f video4linux2 -i /dev/video0 -f avi output.avi

then:

$ mplayer output.avi
result: green

$ mplayer output.avi -vo x11
result: normal

Yung Shen (kaxing) on 2013-09-06
Changed in xorg-lts-raring (Ubuntu):
status: New → Confirmed
assignee: nobody → Anthony Wong (anthonywong)
Yung Shen (kaxing) on 2013-09-06
tags: added: apport-collected
description: updated
description: updated
Changed in xorg-lts-raring (Ubuntu):
assignee: Anthony Wong (anthonywong) → Robert Hooker (sarvatt)
Yung Shen (kaxing) wrote :

according to bug 1219446 , comment #1, it's been fixed in xorg upstream[0]

[0] https://bugs.freedesktop.org/show_bug.cgi?id=65699

Ara Pulido (ara) on 2013-09-17
Changed in xorg-lts-raring (Ubuntu):
importance: Undecided → High
Yung Shen (kaxing) wrote :

Double check this issue with x-edgers [0]

It does not happen with following driver version:

xserver-xorg-video-intel 2:2.21.15+git20130821.f57ce6ef-0ubuntu0sarvatt~precise

[0] https://launchpad.net/~xorg-edgers/+archive/ppa

Ara Pulido (ara) on 2013-09-18
Changed in xorg-lts-raring (Ubuntu):
importance: High → Critical
tags: added: blocks-hwcert-enablement
Robert Hooker (sarvatt) wrote :
Changed in xorg-lts-raring (Ubuntu):
status: Confirmed → In Progress
Yung Shen (kaxing) wrote :

@sarvatt your ppa fix this issue.

with version xserver-xorg-video-intel-lts-raring 2:2.21.6-0ubuntu4.1~precise2~lp1220645

Robert Hooker (sarvatt) wrote :

debdiff containing the fix for 13.04.

xserver-xorg-video-intel (2:2.21.6-0ubuntu4.2) raring-proposed; urgency=low

  * Add hsw-green-xv.patch, backport from 2.21.10 to fix green screens when using XV
    on Haswell generation GPUs. (LP: #1220645)

 -- Robert Hooker <email address hidden> Fri, 27 Sep 2013 16:25:34 -0400

Robert Hooker (sarvatt) wrote :

debdiff containing the fix for 12.04

xserver-xorg-video-intel-lts-raring (2:2.21.6-0ubuntu4.2~precise1) precise-proposed; urgency=low

  * Add hsw-green-xv.patch, backport from 2.21.10 to fix green screens when using XV
    on Haswell generation GPUs. (LP: #1220645)

 -- Robert Hooker <email address hidden> Fri, 27 Sep 2013 16:25:34 -0400

affects: xorg-lts-raring (Ubuntu) → xserver-xorg-video-intel (Ubuntu)

The attachment "xserver-xorg-video-intel_2.21.6-0ubuntu4.2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Timo Aaltonen (tjaalton) wrote :

raring version uploaded, dropped ubuntu-sponsors from subscribers

Timo Aaltonen (tjaalton) on 2013-09-30
no longer affects: ubiquity (Ubuntu)
no longer affects: ubiquity (Ubuntu Precise)
no longer affects: ubiquity (Ubuntu Raring)
no longer affects: xserver-xorg-video-intel (Ubuntu Precise)
no longer affects: xserver-xorg-video-intel-lts-raring (Ubuntu Raring)
Changed in xserver-xorg-video-intel (Ubuntu Raring):
status: New → In Progress
Changed in xserver-xorg-video-intel-lts-raring (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-video-intel (Ubuntu Raring):
importance: Undecided → Critical
assignee: nobody → Robert Hooker (sarvatt)
Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Invalid
Ara Pulido (ara) wrote :

Subscribing SRU to get it approved in Raring

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

Hello Yung, or anyone else affected,

Accepted xserver-xorg-video-intel into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.21.6-0ubuntu4.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Aaltonen (tjaalton) wrote :

lts version uploaded

Changed in xserver-xorg-video-intel-lts-raring (Ubuntu Precise):
status: New → In Progress
Pete Eberlein (pete-eberlein) wrote :

Tested xserver-xorg-video-intel/2:2.21.6-0ubuntu4.3, previously green xv video in mplayer is now working properly.

Timo Aaltonen (tjaalton) wrote :

thanks for testing!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.21.6-0ubuntu4.3

---------------
xserver-xorg-video-intel (2:2.21.6-0ubuntu4.3) raring-proposed; urgency=low

  * sna-fixup-possible-clones.diff: Backport from 2.21.9 to fix
    clone mode on haswell laptops. (LP: #1202524)

xserver-xorg-video-intel (2:2.21.6-0ubuntu4.2) raring-proposed; urgency=low

  * Add hsw-green-xv.patch, backport from 2.21.10 to fix green screens when using XV
    on Haswell generation GPUs. (LP: #1220645)
 -- Timo Aaltonen <email address hidden> Fri, 04 Oct 2013 11:39:07 +0300

Changed in xserver-xorg-video-intel (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Ara Pulido (ara) on 2013-10-29
Changed in xserver-xorg-video-intel-lts-raring (Ubuntu Precise):
status: In Progress → Fix Committed
Yung Shen (kaxing) wrote :

Verify this with precise-proposed, tested with original affected system, no more green playback issue.

Yung Shen (kaxing) on 2013-10-30
tags: added: verification-done-precise
Taihsiang Ho (taihsiangho) wrote :

verify package xserver-xorg-video-intel-lts-raring(2:2.21.6-0ubuntu4.3~precise1) on CID 201305-13636

 * check update source: proposed
 * apt-get update
 * apt-get install xserver-xorg-video-intel-lts-raring
 * reboot
 * verify by "/usr/share/checkbox/scripts/camera_test display"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel-lts-raring - 2:2.21.6-0ubuntu4.3~precise1

---------------
xserver-xorg-video-intel-lts-raring (2:2.21.6-0ubuntu4.3~precise1) precise-proposed; urgency=low

  * Sync from -intel.

xserver-xorg-video-intel (2:2.21.6-0ubuntu4.3) raring-proposed; urgency=low

  * sna-fixup-possible-clones.diff: Backport from 2.21.9 to fix
    clone mode on haswell laptops. (LP: #1202524)

xserver-xorg-video-intel (2:2.21.6-0ubuntu4.2) raring-proposed; urgency=low

  * Add hsw-green-xv.patch, backport from 2.21.10 to fix green screens when using XV
    on Haswell generation GPUs. (LP: #1220645)
 -- Timo Aaltonen <email address hidden> Fri, 04 Oct 2013 12:07:51 +0300

Changed in xserver-xorg-video-intel-lts-raring (Ubuntu Precise):
status: Fix Committed → Fix Released
Taihsiang Ho (taihsiangho) wrote :

verified: 12.04.3 updates could does resolve this issue on 201305-13636

Daniel Manrique (roadmr) on 2014-01-17
Changed in xserver-xorg-video-intel-lts-raring (Ubuntu):
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.