Regression: power on/off of external monitor not detected

Bug #1173478 reported by franco_bez on 2013-04-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

I switch the power of a connected monitor on and off, the state does not get detected.

When I switch the external monitor off, the system continues to "think" there are two monitors connected. Sometimes it helps to push the button "detect monitors" in the display setiings, or to hit the hardware button that toggles trough the display states (internal-only, mirror screens, external-only, extended screen) , on my machine it's the Fn-F5 key. But sometimes this does not help at all. Even worse, when I put the laptop in the docking-station with the external-monitor powered off, and the cold-boot the laptop, X "thinks" that the external monitor were powered on. As I have a laptop and two docking-stations, one at home the other at work, with two different external monitors connected I could see a really strange effect. Even with the monitor powered off I can see the correct monitor information in the display settings dialog, so some how the information is read from the powerless monitor. If connected and turned on, the displays otherwise work normally, no screen corruption of any kind. Just the state of the monitors is not correctly detected. On Quantal using precisely the same hardware it worked as expected. On external monitor on/off or dock/undock the display settings adjusted themselves to the new situation without any manual interaction. I verified this behavior also with a live USB Stick of raring-beta2.

It just worked with all Ubuntu Versions from Karmic up to Quantal, and now using Raring it does no longer work.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,regex,grid,vpswitch,imgjpeg,commands,mousepoll,move,imgpng,resize,place,animation,imgsvg,gnomecompat,snap,session,wall,workarounds,expo,fade,scale,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Apr 27 07:08:01 2013
DistUpgraded: 2013-04-23 06:09:45,803 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus: vboxhost, 4.2.12, 3.8.0-19-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:011b]
   Subsystem: Acer Incorporated [ALI] Device [1025:011b]
InstallationDate: Installed on 2009-11-19 (1254 days ago)
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Acer, inc. TravelMate 6292
MarkForUpload: True
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-19-generic root=UUID=d80ce3a6-4fc4-41f7-b7ee-5faf50197e82 ro kopt=quiet splash
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to raring on 2013-04-23 (4 days ago)
dmi.bios.date: 03/03/2008
dmi.bios.vendor: Acer
dmi.bios.version: v1.3601
dmi.board.name: Victoria
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3601:bd03/03/2008:svnAcer,inc.:pnTravelMate6292:pvrNotApplicable:rvnAcer,Inc.:rnVictoria:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: TravelMate 6292
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Fri Apr 26 23:03:39 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu6
xserver.video_driver: intel
---
.tmp.unity.support.test.0:

ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.336ubuntu1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
CurrentDmesg:
 [ 23.706435] tg3 0000:04:00.0 eth0: Flow control is on for TX and on for RX
 [ 23.706459] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 201.588699] systemd-hostnamed[3777]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
 [ 220.990475] EXT4-fs (sda3): recovery complete
 [ 221.048971] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:011b]
   Subsystem: Acer Incorporated [ALI] Device [1025:011b]
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140107)
MachineType: Acer, inc. TravelMate 6292
MarkForUpload: True
Package: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
PackageArchitecture: amd64
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=de keyboard-configuration/layoutcode?=de
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Tags: trusty ubuntu single-occurrence reproducible compiz-0.9
Uname: Linux 3.12.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 03/03/2008
dmi.bios.vendor: Acer
dmi.bios.version: v1.3601
dmi.board.name: Victoria
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3601:bd03/03/2008:svnAcer,inc.:pnTravelMate6292:pvrNotApplicable:rvnAcer,Inc.:rnVictoria:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: TravelMate 6292
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.50-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Tue Jan 7 22:38:33 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 13844
 vendor AUO
xserver.version: 2:1.14.5-1ubuntu2
---
.tmp.unity.support.test.0:

ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.336ubuntu1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
CurrentDmesg:
 [ 23.706435] tg3 0000:04:00.0 eth0: Flow control is on for TX and on for RX
 [ 23.706459] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 201.588699] systemd-hostnamed[3777]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
 [ 220.990475] EXT4-fs (sda3): recovery complete
 [ 221.048971] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:011b]
   Subsystem: Acer Incorporated [ALI] Device [1025:011b]
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140107)
MachineType: Acer, inc. TravelMate 6292
MarkForUpload: True
Package: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
PackageArchitecture: amd64
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=de keyboard-configuration/layoutcode?=de
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Tags: trusty ubuntu single-occurrence reproducible compiz-0.9
Uname: Linux 3.12.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 03/03/2008
dmi.bios.vendor: Acer
dmi.bios.version: v1.3601
dmi.board.name: Victoria
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3601:bd03/03/2008:svnAcer,inc.:pnTravelMate6292:pvrNotApplicable:rvnAcer,Inc.:rnVictoria:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: TravelMate 6292
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.50-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Tue Jan 7 22:38:33 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 13844
 vendor AUO
xserver.version: 2:1.14.5-1ubuntu2

franco_bez (franco-bez) wrote :
Timo Aaltonen (tjaalton) wrote :

works just fine here with similar hw

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
franco_bez (franco-bez) wrote :

Hi Timo,
glad to hear it works for you.

On my machine the situation is still the same.
In the meantime I verified the bug to exist in the live usb of xbuntu and lubuntu as well.

Ciao,
  Franco

bugbot (bugbot) on 2013-05-16
tags: added: dual-head
franco_bez (franco-bez) wrote :

One of the recent updates has changed the situation on my machine to the better :-)
Dock and Undock events are working again
Also Plug and Unplug events are working again

Only remaining regression is that Power On/Off events of the external monitor are not recognised.

franco_bez, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-intel REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

summary: - Regression: power on/off and connect/disconnect of external monitor not
- detected
+ Regression: power on/off of external monitor not detected
description: updated
tags: added: latest-bios-3601
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected reproducible single-occurrence trusty
description: updated
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

franco_bez (franco-bez) wrote :

Situaion still unchanged

tags: added: regression-release
removed: single-occurrence
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers