Ubuntu

Ubuntu 13.04 boots to dark screen on HP G6 laptop - ACPI backlight woes

Reported by Peter Forward on 2013-04-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Grub menu displayed normally. On boot screen appears dark but brightness can be increased by laptop fn keys.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Apr 26 08:50:54 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:166f]
InstallationDate: Installed on 2013-04-25 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
MachineType: Hewlett-Packard HP Pavilion g6 Notebook PC
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=0db174be-c19b-4286-a813-cbd396894ca8 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/24/2013
dmi.bios.vendor: Insyde
dmi.bios.version: F.66
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 166F
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 09.4C
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.66:bd01/24/2013:svnHewlett-Packard:pnHPPaviliong6NotebookPC:pvr0593110000204610000620100:rvnHewlett-Packard:rn166F:rvr09.4C:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion g6 Notebook PC
dmi.product.version: 0593110000204610000620100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 9.1.1-0ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Fri Apr 26 08:34:56 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu6
xserver.video_driver: intel

Peter Forward (l6t7g) wrote :
Peter Forward (l6t7g) wrote :

Have managed to get round this problem by modifying grub as follows:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Timo Aaltonen (tjaalton) wrote :

I guess this needs a quirk set somewhere..

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Chris Wilson (ickle) wrote :

In the acpi backlight driver...

cllee 李嘉陵 (lchialing) wrote :

Thank you Peter for your suggestion of "acpi_osi=Linux acpi_backlight=vendor". I added those to /etc/default/grub and ran update-grub2 and indeed the laptop now does not boot into a dark screen. It has been booting into a dark screen since 12.04, but I only found this tip after I have updated to 13.04. Still, it helps!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Chris Wilson (ickle) on 2013-05-22
summary: - Ubuntu 13.04 boots to dark screen on HP G6 laptop
+ Ubuntu 13.04 boots to dark screen on HP G6 laptop - ACPI backlight woes
bugbot (bugbot) on 2013-05-23
tags: added: backlight
madbiologist (me-again) wrote :

This is fixed upstream in the 3.10-rc4 kernel by this commit:

author Ash Willis 2013-05-29
committer Rafael J. Wysocki 2013-06-01
commit 780a6ec640a3fed671fc2c40e4dd30c03eca3ac3

    ACPI / video: ignore BIOS initial backlight value for HP Pavilion g6

    This patch addresses kernel bug 56661. BIOS reports an incorrect
    backlight value, causing the driver to switch off the backlight
    completely during startup. This patch ignores the incorrect value from
    BIOS.

    References: https://bugzilla.kernel.org/show_bug.cgi?id=56661
    Signed-off-by: Ash Willis <email address hidden>
    Signed-off-by: Rafael J. Wysocki <email address hidden>
    Signed-off-by: Ben Hutchings <email address hidden>

This has been backported to the upstream 3.2.47 kernel as commit 8de5f8abdee26b1dc13e98c401a68637df2ad0dc
The progress of having the 3.2.47 kernel SRU's to Ubuntu 12.04 "Precise Pangolin" can be followed at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1193029

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed
Maarten Lankhorst (mlankhorst) wrote :

saucy has 3.11 now, so I'm guessing fix released.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.