8086:2a42 [Lenovo ThinkPad T400] xfwm4 displays window borders visually glitched

Bug #1171411 reported by b3nmore on 2013-04-22
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Unknown
Unknown
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

Since sna acceleration of the intel display driver is enabled by default, sometimes windows have visually glitched borders.

WORKAROUND: Switch to uxa via xorg.conf .
WORKAROUND: Disable compositing in xfwm4.
WORKAROUND: Replace xfwm4 with mutter or metacity.

---
ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.336ubuntu1
CurrentDesktop: XFCE
DistroRelease: Ubuntu 14.04
LiveMediaBuild: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140107)
MarkForUpload: True
Package: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Tags: trusty
Uname: Linux 3.12.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
---
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: XFCE
DistUpgraded: Fresh install
DistroCodename: trusty
DistroRelease: Ubuntu 14.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:2112]
   Subsystem: Lenovo Device [17aa:2112]
InstallationDate: Installed on 2014-01-11 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140107)
MachineType: LENOVO 2767WSD
Package: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
PackageArchitecture: amd64
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-1-generic root=UUID=aaef342f-8a39-4660-b8fd-c1fe9349d82a ro quiet splash
ProcVersionSignature: Ubuntu 3.13.0-1.16-generic 3.13.0-rc7
Tags: trusty ubuntu reproducible
Uname: Linux 3.13.0-1-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 10/17/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET94WW (3.24 )
dmi.board.name: 2767WSD
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET94WW(3.24):bd10/17/2012:svnLENOVO:pn2767WSD:pvrThinkPadT400:rvnLENOVO:rn2767WSD:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2767WSD
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.50-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Sat Jan 11 13:41:34 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 16438
 vendor LEN
xserver.version: 2:1.14.5-1ubuntu2

b3nmore (b3nmore) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed

b3nmore, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-intel REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

no longer affects: xfwm4 (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Elfy (elfy) wrote :

http://cdimage.ubuntu.com/xubuntu/daily-live/current/

rather than the Ubuntu one please.

Ubuntu won't be using xfwm4 ;)

b3nmore (b3nmore) wrote :

I've played around a bit with the trusty daily image. So far I couldn't trigger any heavy distortions. The stippled window borders (c.f. attached screenshot) however still do occur occasionally (but with reduced frequency than before).

apport information

tags: added: apport-collected trusty
description: updated

apport information

b3nmore, thank your your comment. When you were performing the apport-collect did you have xdiagnose installed?

If so, did you get the following message and click yes:
"Your display manager log files may help developers diagnose the bug, but may contain sensitive information such as your hostname. Do you want to include these logs in your bug report?"

apport information

tags: added: reproducible ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

b3nmore (b3nmore) wrote : Lspci.txt

apport information

b3nmore (b3nmore) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

b3nmore (b3nmore) wrote : UdevDb.txt

apport information

apport information

apport information

apport information

b3nmore (b3nmore) wrote : Xrandr.txt

apport information

apport information

apport information

I should mention, that in contrast to the original report, the stippled window borders appear now independent of the compositor state (on or off).
I've also tested xfwm4 in combination with compton (standalone opengl compositor) with the same result: occasional appearance of stippled borders.

tags: added: latest-bios-3.24
description: updated
summary: - xfwm4 may show display distortions, when using compositing on intel with
- sna
+ 8086:2a42 [Lenovo ThinkPad T400] xfwm4 displays distortions when using
+ compositing on intel with sna

b3nmore, thank you for performing the requested test. Given the display distortions have ceased, let us refocus onto the window border striping.

Regarding this, so that a more updated version of the xorg stack may be tested, could you please test for this via https://launchpad.net/~xorg-edgers/+archive/ppa?field.series_filter=trusty and advise to the results?

b3nmore (b3nmore) wrote :

I've updated the packages from the mentioned ppa. Additional to the border issue I get now quit frequently character distortions (cf. the second "(II)"- line in the screenshot of the terminal window) in different programs.

Please note (cf. comment #31), that using a compositor or not does not seem to have any influence anymore. In both cases I get the striped border and now the character distortion; i.e. disabling the compositor isn't a valid workaround anymore.

b3nmore, thank you for performing the requested test. In order to streamline this report, it will only focus on the issue of the striped borders, as that is what is reproducible in Trusty. Hence, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://01.org/linuxgraphics/documentation/how-report-bugs ?

Please provide a direct URL to your bug report once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
description: updated
b3nmore (b3nmore) wrote :

Another annotation: I have the striped borders issue also on my desktop system: xubuntu 13.10, Intel i5-4570S with integrated hd4600 gpu. So I guess this issue isn't limited to a single set of hardware.

description: updated
summary: - 8086:2a42 [Lenovo ThinkPad T400] xfwm4 displays distortions when using
- compositing on intel with sna
+ 8086:2a42 [Lenovo ThinkPad T400] xfwm4 displays window borders visually
+ glitched

b3nmore, regarding your desktop, so your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Chris Wilson (ickle) wrote :

This should have been fixed by the upgrade to 2.99.909, now 2.99.910.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
b3nmore (b3nmore) wrote :

> This should have been fixed by the upgrade to 2.99.909, now 2.99.910.

Unfortunately not for me (c.f. attached screenshot). I still can reproduce the border issue (with and without the compositor) quite frequently.

b3nmore (b3nmore) wrote :

> > This should have been fixed by the upgrade to 2.99.909, now 2.99.910.
>
> Unfortunately not for me [...]

Oh, wait. Did this mean by upgrading *from* 2.99.909 to 2.99.910? If so, please ignore my previous comment, since I'm clearly running 2.99.909.

b3nmore (b3nmore) wrote :

Even 2.99.910 did not fix the issue.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Triaged
b3nmore (b3nmore) wrote :

Ok, thats weird: I still get the striped borders occasionally on a fully updated trusty, but only when I use the Greybird-compact xfwm4 theme (or so it seems). I replaced therefore all the left-*, right-*, bottom-* xpms of the theme with those of the normal Greybird theme and didn't see striped borders anymore.
It seems, that the intel driver with sna enabled chokes some times on the repeated use of those particular pixmaps.

b3nmore (b3nmore) wrote :
To post a comment you must log in.