[g33] Non-locking GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000002 IPEHR: 0x54f00006

Bug #1153302 reported by freedomrun on 2013-03-10
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

do not close this bug report I repeat do not close until it is repaired.
If any interested devs need any info on this just ask and you will get everything you need to fix this.

I found that this bug has been already reported before in: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1105619

this is similar but newer kernel and libs also not shure if this is same motherboard so I am reporting this one as new.

also on this system there is intel-microcode package installed.

It is true the bug report jumps in even nothing is done with machine and no input device is touched. Also in the middle of work:

- Firefox opened

.. happens again.

No mather what user does this happens so you see it is random, but to locate the real reason why this is happening you have to guide users to send you the logs so this issue can be resolved properly.

In the meantime Il try to explore logs and see if there is some meaningful line there..

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: xserver-xorg-video-intel 2:2.21.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-11.20-generic 3.8.2
Uname: Linux 3.8.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
Chipset: g33
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sun Mar 10 16:53:27 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DuplicateSignature: [g33] GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000002 IPEHR: 0x54f00006 Ubuntu 13.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:d000]
InstallationDate: Installed on 2013-03-10 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130303)
InterpreterPath: /usr/bin/python3.3
MachineType: Gigabyte Technology Co., Ltd. G31M-ES2L
MarkForUpload: True
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-11-generic root=UUID=100cb9bb-1604-41c5-a365-5e5ea15ffda6 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.7+1ubuntu4
 libdrm2 2.4.42-0ubuntu1
 xserver-xorg-video-intel 2:2.21.3-0ubuntu1
SourcePackage: xserver-xorg-video-intel
Title: [g33] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000002 IPEHR: 0x54f00006
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 08/20/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: G31M-ES2L
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd08/20/2008:svnGigabyteTechnologyCo.,Ltd.:pnG31M-ES2L:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnG31M-ES2L:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: G31M-ES2L
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.9~daily13.03.08-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Sun Mar 10 16:24:15 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input AT Translated Set 2 keyboard KEYBOARD, id 8
 input ImExPS/2 Logitech Wheel Mouse MOUSE, id 9
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu3
xserver.video_driver: intel

freedomrun (freedomrun) wrote :
tags: removed: need-duplicate-check
Chris Wilson (ickle) wrote :

Then please try this patch.

The attachment "0001-drm-i915-Flush-outstanding-memory-accesses-upon-fenc.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Bryce Harrington (bryce) on 2013-03-12
summary: - [g33] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000002 IPEHR:
- 0x54f00006
+ [g33] Non-locking GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000002
+ IPEHR: 0x54f00006
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

A kernel with ickle's patch is available for testing at:
http://people.canonical.com/~bradf/lp1153302/

freedomrun (freedomrun) wrote :

Thank you. Finally had time to test it and same bug report is jumping arround again. This time after new kernel was installed, reboot, login, opening firefox and few tabs = nothing happened, opening Opera = still nothing, after clicking on Nautilus it started to jump out like crazy. I really doubt this was coused by Nautilus maybe this was just delayed by disk activity or something.
Anyway if you need logs with this new kernel. just say which one and I`ll ssh this machine to pickit up over weekend.

Chris Wilson (ickle) wrote :

Ok. I think the root cause is some memory incoherence between the BAR and the GPU (i.e. some TLBs are not invalidated correctly), probably triggered by the use of wc updates through the BAR.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2013-04-01
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → In Progress

freedomrun, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-intel REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: In Progress → Incomplete
To post a comment you must log in.