Intel graphics fails when bringing monitor out of sleep

Bug #1135668 reported by Jussi Pakkanen on 2013-02-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Raring
High
Tim Gardner
xserver-xorg-video-intel (Ubuntu)
Undecided
Timo Aaltonen
Raring
Undecided
Timo Aaltonen

Bug Description

I have a HP LP2475w monitor. Sometimes when the system has put it to sleep, it fails in bringing it back up again. The screen remains blank. Even changing virtual terminals with ctrl+alt+f1 does not work. Ssh'ing in and running 'sudo service lightdm restart' makes it come back up again.

This error shows up in dmesg:

[18380.721810] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 125

This monitor worked flawlessly on my previous computer which had NVidia + the binary driver.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: Error: command ['gsettings', 'get', 'org.compiz.opengl:/org/compiz/', 'unredirect-driver-blacklist'] failed with exit code 1: No such key 'unredirect-driver-blacklist'
CompositorUnredirectFSW: true
Date: Thu Feb 28 14:21:03 2013
DistUpgraded: 2013-01-14 14:23:18,255 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0162] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:2032]
InstallationDate: Installed on 2012-10-09 (142 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120918.1)
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-3.8.0-7-generic root=UUID=13f61e3f-9582-47a8-988c-a29fed44d3af ro rootflags=subvol=@ quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to raring on 2013-01-14 (44 days ago)
dmi.bios.date: 01/25/2013
dmi.bios.vendor: Intel Corp.
dmi.bios.version: EBH7710H.86A.0099.2013.0125.1400
dmi.board.name: DH77EB
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG39073-304
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrEBH7710H.86A.0099.2013.0125.1400:bd01/25/2013:svn:pn:pvr:rvnIntelCorporation:rnDH77EB:rvrAAG39073-304:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.9~daily12.12.05-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Thu Feb 28 14:12:29 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Related branches

CVE References

Jussi Pakkanen (jpakkane) wrote :
bugbot (bugbot) on 2013-02-28
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Chris Wilson (ickle) wrote :

Usually this is a sign of FDI or DP link training error. Can you please add drm.debug=6 to your kernel command line and attach the output of dmesg after your monitor fails to wake up?

Jussi Pakkanen (jpakkane) wrote :

Debug log attached.

However in this case it brought the monitor up but at the wrong resolution (1024x768). That happens sometimes. Going to system settings -> displays -> detect displays makes it detect the resoutions properly. I'll try to get a new log which shows the case where it fails to bring the monitor up.

Chris Wilson (ickle) wrote :

That's the less severe case where we get some garbage whilst reading the EDID and replace it with a default set of modes. For this EDID error, I think we can make it try harder once we know we have a valid EDID header.

Jussi Pakkanen (jpakkane) wrote :

Here's the log when the monitor remains black.

Chris Wilson (ickle) wrote :

Hmm. We get a hotplug disconnection event from the HDMI:

[ 6866.046586] [drm:drm_helper_hpd_irq_event], [CONNECTOR:20:HDMI-A-3] status updated from 1 to 2

and then proceed to turn it off. We've been having issues with HDMI hotplug detection on IvyBridge and there is one patch en route that should help:

commit 202adf4b9f5957b26a1cb97267d78e0edb319c5e
Author: Daniel Vetter <email address hidden>
Date: Fri Feb 22 00:53:04 2013 +0100

    drm/i915: Revert hdmi HDP pin checks

Hopefully that will turn up in the Ubuntu kernel in time.

Chris Wilson (ickle) wrote :

Note you should be able to install a recent kernel from the ppa:mainline 'drm-intel-experimental' (or maybe it is now called drm-intel-nightly after our upstream name) that contains what I think is the fix.

Timo Aaltonen (tjaalton) wrote :

yep, please give either drm-intel-fixes or drm-intel-nightly a go (both contain the commit):

http://kernel.ubuntu.com/~kernel-ppa/mainline/

remember to install both linux-image-.. and -extra packages for your arch.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Jussi Pakkanen (jpakkane) wrote :

I tried drm-intel-nightly version 03-05. I suspended an woke the monitor 10 times in a row and it worked fine. There was no unexpected output in dmesg.

So this bug is probably fixed by said commit.

Chris Wilson (ickle) on 2013-03-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → In Progress
Timo Aaltonen (tjaalton) wrote :

thanks for testing!

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Tim Gardner (timg-tpi) wrote :

Backport of 202adf4b9f5957b26a1cb97267d78e0edb319c5e for Raring 3.8

Changed in linux (Ubuntu Raring):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Changed in xserver-xorg-video-intel (Ubuntu Raring):
status: In Progress → Invalid
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-13.23

---------------
linux (3.8.0-13.23) raring; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: enable irqs earlier when resuming"
    - LP: #1156310
  * Revert "drm/i915: reorder setup sequence to have irqs for output setup"
    - LP: #1156310
  * x86/apic: Remove noisy zero-mask warning from
    default_send_IPI_mask_logical()
    - LP: #1100202
  * drm/i915: Fix races in gen4 page flip interrupt handling
    - LP: #1116587
  * drm/i915: Revert hdmi HDP pin checks
    - LP: #1135668
  * signal: always clear sa_restorer on execve
    - LP: #1153813
    - CVE-2013-0914
 -- Tim Gardner <email address hidden> Mon, 18 Mar 2013 10:04:33 -0600

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
Jussi Pakkanen (jpakkane) wrote :

This still happens with release version of raring.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Changed in linux (Ubuntu Raring):
status: Fix Released → Confirmed
Jussi Pakkanen (jpakkane) wrote :

Here's the raw EDID block from dmesg:

[11903.844749] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 195
[11903.844754] Raw EDID:
[11903.844756] 00 ff ff ff ff ff ff 00 22 f0 f8 26 01 01 01 01
[11903.844758] 32 12 01 03 80 36 23 78 ee ce 50 a3 54 4c 99 26
[11903.844760] 0f 50 54 a5 6b 80 81 40 a9 00 a9 40 b3 00 d1 00
[11903.844761] 01 01 01 01 01 01 28 3c 80 a0 70 b0 23 40 30 20
[11903.844763] 36 00 22 60 21 00 00 1a 00 00 00 fc 00 48 50 20
[11903.844765] ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[11903.844766] ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[11903.844768] ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

Brad Figg (brad-figg) on 2013-05-15
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu Raring):
importance: Undecided → High

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Jussi Pakkanen, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jussi Pakkanen (jpakkane) wrote :

I have a different graphics card now so I can't test this any longer.

Jussi Pakkanen, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1135668/comments/17 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Raring):
status: Confirmed → Invalid
To post a comment you must log in.