Visual artifacts are displayed with intel video driver (Ivy bridge)

Bug #1131134 reported by Franck on 2013-02-21
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Chris Wilson

Bug Description

From time to time, visual artifacts are poluting the display using Intel driver in raring.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xserver-xorg-video-intel 2:2.21.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.14-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Thu Feb 21 11:28:04 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.22, 3.8.0-7-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21fb]
InstallationDate: Installed on 2013-02-16 (4 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130216)
MachineType: LENOVO 2353CTO
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-7-generic root=UUID=bb7483c9-09ca-49c5-9cb5-fd6ecf814340 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/22/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ET91WW (2.51 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2353CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ET91WW(2.51):bd01/22/2013:svnLENOVO:pn2353CTO:pvrThinkPadT430s:rvnLENOVO:rn2353CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2353CTO
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.9~daily13.02.19-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.2-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Thu Feb 21 09:46:55 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Franck (alci) wrote :
Franck (alci) wrote :

Here is a screenshot showing the problem. The problem is triggered quite frequently with the copy window of nautilus...

Chris Wilson (ickle) wrote :

How frequently does it happen? Would you say there was a pattern to when it starts? When it starts, does it persist, or is it still sporadic?

Is the corruption always the same?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Franck (alci) wrote :

I can always (almost always ?) trigger the bug with the following procedure:
1) copy some directory from one drive to another (must be big enough to have nautilus copy window show)
2) the cancel button (a red button on the right side) has a black square on its upper right corner

Once this has been triggered, the restart (reboot ? Redémarrer in french) button in the restart/reboot dialog has the same problem.

If the mouse pointer goes uppon the artifact, it will disappear.

Chris Wilson (ickle) wrote :

Ok, I can reproduce this using the copy window. Thanks.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Chris Wilson (ickle)
status: Confirmed → In Progress
Chris Wilson (ickle) wrote :

It seems to be IVB specific, which should hopefully narrow down the problem.

Franck (alci) wrote :

Note for those (like me) that are not so much into xorg: IVB stands for Intel Ivy Bridge.

Chris Wilson (ickle) wrote :

So far this is my best lead:

diff --git a/src/sna/kgem.c b/src/sna/kgem.c
index c9b2011..1aed82c 100644
--- a/src/sna/kgem.c
+++ b/src/sna/kgem.c
@@ -62,7 +62,7 @@ search_snoop_cache(struct kgem *kgem, unsigned int num_pages,
 #define DBG_NO_CACHE_LEVEL 0
 #define DBG_NO_CPU 0
 #define DBG_NO_USERPTR 0
-#define DBG_NO_LLC 0
+#define DBG_NO_LLC 1
 #define DBG_NO_SEMAPHORES 0
 #define DBG_NO_MADV 0
 #define DBG_NO_UPLOAD_CACHE 0

Excuse me whilst I go sob in a corner.

Chris Wilson (ickle) wrote :

I've uploaded a fix. Not fully understanding the actual cause yet, so probably needs another tweak.

commit b129b434f98b9d875e44af206f6901de9bf28334
Author: Chris Wilson <email address hidden>
Date: Fri Feb 22 12:10:20 2013 +0000

    sna: Optimise mmap of GPU bo for read-read operations

    Signed-off-by: Chris Wilson <email address hidden>

commit 19bd005056a2083de64753681b96716996e4237d
Author: Chris Wilson <email address hidden>
Date: Fri Feb 22 12:05:04 2013 +0000

    sna: Avoid migrating and making the GPU bo busy prior to mmapping it

    References: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-int
    Signed-off-by: Chris Wilson <email address hidden>

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Fix Committed
Chris Wilson (ickle) on 2013-02-25
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
taj (othertaj) wrote :

Still happens in the final version, and not only in Thunar. See screenshot of firefox when opening launchpad. Pretty bad.
DistroRelease: Ubuntu 13.04
Ubuntu 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
xserver-xorg-video-intel version 2:2.21.6-0ubuntu4

To post a comment you must log in.