Black screen after resuming from suspend [Dell XPS 15z]

Bug #1130938 reported by Adam Bruce on 2013-02-20
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

The laptop suspends as normal

The laptop resumes as intended but the screen is black

If I plug into an external monitor and then unplug, the screen then shows up as normal on my laptop

If I use the external monitor, then suspend, then resume, the external monitor screen comes up black, I have to then unlug and it screen shows up on the laptop

My system needs the following boot parameters to turn the screen on after boot (https://wiki.ubuntu.com/HardwareSupport/Machines/Laptops/Dell/XPS/15z)

 acpi_backlight=vendor dell_laptop.backlight=0

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-7.14-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Feb 20 21:57:02 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0446]
 NVIDIA Corporation GF108 [GeForce GT 540M] [10de:0df5] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0446]
InstallationDate: Installed on 2013-02-11 (9 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130210)
MachineType: Dell Inc. Dell System XPS 15Z
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-7-generic root=UUID=93acc5a7-d531-4af3-a215-472a7bd065d6 ro acpi_backlight=vendor dell_laptop.backlight=0 quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/27/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 060G42
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd07/27/2011:svnDellInc.:pnDellSystemXPS15Z:pvr:rvnDellInc.:rn060G42:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS 15Z
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.9~daily13.02.19-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.2-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3

Timo Aaltonen (tjaalton) wrote :

hybrid laptop, and the external output seems to be owned by the nvidia chip

affects: xorg (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)

But do note that my Nvidia HDMI output does not work so I am using the MiniDisplay port

Which I believe is connected to the motherboard and not the nvidia graphics card

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Walter Ribeiro (wribeirojr) wrote :

Same thing here - HP Pavilion dv6000
GeForce 7150M / nForce 630M

SPT (sptiwari) wrote :

This bug also affected me.
System: HP Pavillion g4, intel HD graphics 4000.

Christoph Mende (cmende) wrote :

I encountered the same problem (at least it's the same symptoms). This seems to be a bug with the backlight (possibly http://<email address hidden>/msg18396.html, n
ot sure how nouveau is related - I got hit by this on an Intel HD4000).
Luckily, I've found a quick workaround for this. Run this as root (sudo -s):
cat << EOF >> /etc/pm/sleep.d/60intel
#!/bin/sh
# Force backlight on after resume

case "$1" in
        thaw|resume)
                cd /sys/class/backlight/intel_backlight
                cat max_brightness >brightness
                ;;
        *)
                exit $NA
                ;;
esac
EOF
chmod +x /etc/pm/sleep.d/60intel

That's it. This tells the system to set the backlight to full on resume. Even if it is already set to full, this causes the video driver to re-enable the backlight. Instead of max_brightness, one could also use actual_brightness to reset to the old value.
Of course the cd line would need to be changed according to the backlight driver (whatever's there in /sys/class/backlight), like I said, this version works on an Intel HD4000, it needs modification on non-Intel obviously.

eric (obrowny06) wrote :

Same problem here with ACER 1830t and intel graphic card.
striking the backlight key brings back the screen on.
But playing with backlight is not working well at all (pressing once gives me around 50 % backlight, twice 90% and 3 times 100%...)

@Christoph Mende, I agree that is probably the same bug as their bisect said it works on 3.7 and bug appears in 3.8

I have just installed the 3.7 kernel and confirm the bug does not exist, but it does in 3.8

Do you know if they have posted a bug report which we could track?

Christoph Mende (cmende) wrote :

This should be fixed in 3.8.5+ and indeed works fine for me on Intel and 3.8.0-17-generic.

Timo Aaltonen (tjaalton) wrote :

yeah you were right, DP-1 is owned by the intel chip, so closing as fixed by the kernel update

affects: xserver-xorg-video-nouveau (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.