Ubuntu

Xorg crashes in XvdiPutImage() when playing an mkv video with SNA

Reported by Federico Stempler on 2013-01-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

crashes when watching video

[ 11760.101] (EE)
[ 11760.101] (EE) Backtrace:
[ 11760.102] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0xb7746099]
[ 11760.103] (EE) 1: /usr/bin/X (0xb759e000+0x1abf86) [0xb7749f86]
[ 11760.103] (EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb757b40c]
[ 11760.103] (EE) 3: /lib/i386-linux-gnu/libc.so.6 (0xb71c0000+0x13ae8c) [0xb72fae8c]
[ 11760.103] (EE) 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb6ef8000+0x93f40) [0xb6f8bf40]
[ 11760.103] (EE) 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb6ef8000+0x96715) [0xb6f8e715]
[ 11760.103] (EE) 6: /usr/bin/X (0xb759e000+0x9adfa) [0xb7638dfa]
[ 11760.103] (EE) 7: /usr/bin/X (XvdiPutImage+0x1ff) [0xb7685e3f]
[ 11760.103] (EE) 8: /usr/bin/X (0xb759e000+0xead08) [0xb7688d08]
[ 11760.103] (EE) 9: /usr/bin/X (ProcXvDispatch+0x38) [0xb768a088]
[ 11760.103] (EE) 10: /usr/bin/X (0xb759e000+0x3cc15) [0xb75dac15]
[ 11760.103] (EE) 11: /usr/bin/X (0xb759e000+0x2a14a) [0xb75c814a]
[ 11760.103] (EE) 12: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf5) [0xb71d9715]
[ 11760.103] (EE) 13: /usr/bin/X (0xb759e000+0x2a529) [0xb75c8529]
[ 11760.103] (EE)
[ 11760.103] (EE) Segmentation fault at address 0xafe00000

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Thu Jan 24 13:34:13 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3975]
InstallationDate: Installed on 2013-01-22 (1 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
MachineType: LENOVO 20078
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-1-generic root=UUID=3b435cfd-51fa-44b5-9dd2-074b8f43cf08 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 40CN32WW(V2.18)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: LENOVO
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnLENOVO:bvr40CN32WW(V2.18):bd05/11/2012:svnLENOVO:pn20078:pvrLenovoG470:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: 20078
dmi.product.version: Lenovo G470
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.9~daily13.01.21-0ubuntu1
version.libdrm2: libdrm2 2.4.41-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.1-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.1-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.1.901-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.0.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.19-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu1
xserver.bootTime: Thu Jan 24 13:21:40 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.1.901-0ubuntu2
xserver.video_driver: intel

Federico Stempler (zackmango) wrote :
Martin Albisetti (beuno) on 2013-01-24
summary: - Xorg crash
+ Xorg crashes when playing a video

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

could you try grabbing this xorg.conf, and changing 'sna' to 'uxa':

https://wiki.ubuntu.com/X/Testing/IntelSNA?action=AttachFile&do=view&target=xorg.conf

then drop it in /etc/X11 and reboot.

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Federico Stempler (zackmango) wrote :

i tried it and now it works perfect!

Timo Aaltonen (tjaalton) wrote :

Ok, so we need the exact steps to reproduce the bug, could you provide them? Remember to change the xorg.conf back to sna or remove it before trying to reproduce.

Timo Aaltonen (tjaalton) wrote :

there's also warning messages from the kernel about your bios:

[ 3.934911] ACPI Warning: 0x00000428-0x0000042f SystemIO conflicts with Region \PMIO 1 (20121018/utaddress-251)
[ 3.934919] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 3.934924] ACPI Warning: 0x00000540-0x0000054f SystemIO conflicts with Region \GPIO 1 (20121018/utaddress-251)
[ 3.934929] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 3.934931] ACPI Warning: 0x00000530-0x0000053f SystemIO conflicts with Region \GPIO 1 (20121018/utaddress-251)
[ 3.934936] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 3.934938] ACPI Warning: 0x00000500-0x0000052f SystemIO conflicts with Region \GPIO 1 (20121018/utaddress-251)
[ 3.934942] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 3.934944] lpc_ich: Resource conflict(s) found affecting gpio_ich

Federico Stempler (zackmango) wrote :

Sure. All I have to do is remove the xorg.conf file, reboot and open a mkv video file with vlc.
Its reproduceable each time-
Not sure about those BIOS warnings, I get them with both SNA and no xorg.

Bryce Harrington (bryce) wrote :

Please collect a full backtrace on this crash - see http://wiki.ubuntu.com/X/Backtracing for guidance.

summary: - Xorg crashes when playing a video
+ Xorg crashes when playing an mkv video with SNA
description: updated
summary: - Xorg crashes when playing an mkv video with SNA
+ Xorg crashes in XvdiPutImage() when playing an mkv video with SNA
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
importance: Undecided → High
status: New → Incomplete
Alberto Aldegheri (albyrock87) wrote :

Attaching full backtrace.

What I did:
Start an MKV download in Chromium
Drag and drop the mkv.crdownload file to VLC
Xorg crashed

Regards

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.21.0-0ubuntu1

---------------
xserver-xorg-video-intel (2:2.21.0-0ubuntu1) raring; urgency=low

  * Merge from unreleased debian git.
    - new upstream release (LP: #1104180)
  * sna-compensate-clipextents.diff, upstream-snapshot-778dba90c.diff:
    Deleted, were from upstream.
 -- Timo Aaltonen <email address hidden> Tue, 05 Feb 2013 12:22:15 +0200

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.