Ubuntu

[raring] full screen video crashes after Intel SNA enabled by default on dual monitor setup

Reported by Alin Andrei on 2013-01-21
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

My system freezes (sometimes completely, sometimes I am able to recover by restarting LightDM) when playing a video using mplayer in full screen (in either Gnome Mplayer, Smplayer, etc.), after the recent Intel SNA by default change. This also crashes when using full screen Skype video calls and full screen HTML5 YouTube videos.

Changing "AccelMethod" to "uxa" in xorg.conf fixes this and full screen videos work without any issues. So this is definetly an SNA bug! Also, the crashes only occur when I'm using 2 monitors. It doesn't happen when I'm using only one display!

My system is a Dell XPS 17 L702X using the following graphics: NVIDIA GeForce GT 555M 3GB with Optimus technology and Intel(R) Sandybridge Mobile - 2nd Generation Core Processor Family Integrated Graphics Controller, running Ubuntu 13.04 Raring Ringtail 64bit.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
CompositorRunning: compiz
Date: Mon Jan 21 23:36:59 2013
DistUpgraded: 2013-01-12 16:20:44,289 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0571]
 NVIDIA Corporation Device [10de:124d] (rev ff) (prog-if ff)
InstallationDate: Installed on 2012-12-30 (22 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Dell Inc. Dell System XPS L702X
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-1-generic root=UUID=1cd2fc4f-7d99-4c7a-8ea7-6f9a2d4e5960 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to raring on 2013-01-12 (9 days ago)
dmi.bios.date: 11/11/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0XN71K
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd11/11/2011:svnDellInc.:pnDellSystemXPSL702X:pvr:rvnDellInc.:rn0XN71K:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L702X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.9~daily13.01.21-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.41-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.1-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.1-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.1.901-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.0.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.19-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu1

Alin Andrei (nilarimogard) wrote :
summary: - full screen video crashes after Intel SNA enabled by default
+ [raring] full screen video crashes after Intel SNA enabled by default
description: updated

please collect /sys/kernel/debug/dri/0/i915_error_state from the hung state and attach here.

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Alin Andrei (nilarimogard) wrote :

I've played a video which caused x to crash I think because as soon as I've started playing the video, the LightDM login screen showed up, and I'm attaching the i915_error_state file after logging back in following that crash.

Alin Andrei (nilarimogard) wrote :
Bryce Harrington (bryce) wrote :

Please attach your mplayer config and/or command line arguments you're using for running it.

Also, can you tell us or share the video? It can help developers to reproduce the problem.

The i915_error_state file must be collected *while* the system is frozen, so I'm not sure the i915_error_state you provided is going to match up to the actual error state.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Alin Andrei (nilarimogard) wrote :

Any video does this. Also, full-screen skype calls freeze the computer as well. The same for youtube videos played in HTML5. I don't know how to get the i915_error_stat if the system is frozen...

As for the mplayer configuration, now I'm using only defaults in Smplayer or GNOME Mplayer and it still freezes ("xv" video output"). So to replicate it, all I have to do is start playing a video with a mplayer-based video player in full-screen, that's all.

Bryce Harrington (bryce) wrote :

ssh in while it's frozen.

Playing videos (mp4) full screen through mplayer Works For Me.

Maybe your hardware's bad or something.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Alin Andrei (nilarimogard) wrote :

I don't think the hardware is broken, it used to work when I was using SNA in Ubuntu 12.10...

Alin Andrei (nilarimogard) wrote :

And unfortunately I don't have access to anothr computer to ssh while it's frozen :(

Timo Aaltonen (tjaalton) wrote :

How do you enable va-api for mplayer?

Alin Andrei (nilarimogard) wrote :

Update: I've added "AccelMethod" to "uxa" in xorg.conf and the bug is gone, full screen videos work without any issues. So this is definetly an SNA bug!

description: updated
Alin Andrei (nilarimogard) wrote :

I've found out what was causing this. The crashes (only when SNA is turned on) happen only when using 2 monitors. When using a single monitor and playing a video in full-screen with SNA enabled, the system doesn't crash! I'll update the description.

summary: - [raring] full screen video crashes after Intel SNA enabled by default
+ [raring] full screen video crashes after Intel SNA enabled by default on
+ dual monitor setup
description: updated
Timo Aaltonen (tjaalton) wrote :

Ok, I think this is a dupe of 1102390, I'll upload the fix soon..

Alin Andrei (nilarimogard) wrote :

Mmm I remember that bug even in Quantal without SNA so I don't think it's the same but once you'll fix it I'll try to reproduce both and will let you know. Thanks!

Timo Aaltonen (tjaalton) wrote :
Alin Andrei (nilarimogard) wrote :

At first I though it was fixed, but only for ~30 seconds. Then the soft freeze happened again. I've tried all combinations and here's what I got:

Dual monitor + SNA: mplayer in full-screen still gets the system to freeze, but now it happens after about 30 seconds after playing the video.

Single monitor + SNA: full-screen videos are ok.

Dual monitor + UXA: full screen videos are ok.

Both dual and single screen, both SNA and UXA:
- mplayer with vaapi support no longer works, the video is not displayed anymore
- Totem doesn't play videos anymore, no video is displayed (blank screen, just like for mplayer with vaapi)

Alin Andrei (nilarimogard) wrote :

Yes, full screen mplayer videos work with SNA enabled and two monitors using this kernel! Totem still can't display videos but maybe that's a different issue? Any idea? Also, mplayer with vaapi doesn't work any more but since vaapi is not officially supported for mplayer, I guess you won't care about that...

Alin Andrei (nilarimogard) wrote :

Mmm however, regarding Totem, I see it hasn't been updated in Raring since December (and Gstreamer 1.0 since 9th of January and it was working just a couple of days ago so that's not it either) so I think the xserver-xorg-video-intel upgrade had something to do with it. Videos don't work in Totem no matter what (with or without SNA, with 1 or 2 monitors) - should I open a new bug for xserver-xorg-video-intel?

bugbot (bugbot) on 2013-01-24
tags: added: crash
tags: added: dual-head
Timo Aaltonen (tjaalton) wrote :

totem works just fine here, so probably something you've messed up with the gstreamer settings?

Alin Andrei (nilarimogard) wrote :

It could be something on my system but I didn't do anything related to Gstreamer... And by the way, Opera with hardware acceleration (enabled in the Opera settings) now looks like a ghost window (repainting whatever it was behind it) and it's unusable. I think these two are related and both are related to the Intel driver update... Maybe you can try this and see if Opera works correctly for you?

To enable hardware accel for opera: type "about:config" and:
 Find "Enable Hardware Acceleration" and set value to 1
 Find "Enable WebGL" and set value to 1

Alin Andrei (nilarimogard) wrote :

The same "ghost window" bug is also occuring for Steam, so I can't even log in to Steam anymore. It used to work just fine before...

Alin Andrei (nilarimogard) wrote :

Update: after the last xserver-xorg-video-intel update (2.20.19-0ubuntu3) both Steam and Totem work and even mplayer with vaapi (and now the subtitle shadow displays properly too) - all with dual monitors and SNA enabled ('m still using the Kernel installed via http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/2013-01-24-raring/ though) . So I'll mark this as fixed.

Thank you!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.