xserver-xorg-video-intel does not work with 82852/855GM

Bug #108056 reported by Markus on 2007-04-20
60
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Gutsy
Undecided
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

I've got a Thinkpad X40 with a “Intel Corporation 82852/855GM Integrated Graphics Device” the driver from xserver-xorg-video-i810 worked for me all the time. Yesterday I discovered xserver-xorg-video-intel and installed it. When I rebooted my laptop today. Starting X resulted in very strange behavior. Most times it just froze with a black screen, once pressing any key resulted in strange letters being printed on the screen, sometimes it brought up a login screen, even though I use autologin, logging in resulted in a frozen black screen.

After changing i810 in /etc/X11/xorg.conf to vesa I was able to log in again. I uninstalled xserver-xorg-video-intel and reinstalled xserver-xorg-video-i810 and changed vesa back to i810. Now everything is working again.

ProblemType: Bug
Architecture: i386
Date: Fri Apr 20 13:50:16 2007
DistroRelease: Ubuntu 7.04
Uname: Linux fundstueck 2.6.20-15-386 #2 Sun Apr 15 07:34:00 UTC 2007 i686 GNU/Linux

Impact: Affects users of intel 855 graphics. Causes black screen on VT switch (including initial boot up). As this can prevent use of Ubuntu, it is considered a critical bug and should be backported to Gutsy.

Solution: Modifies the existing patch 04_fix_hw_restore.diff to conditionalize when pipes are restored so they don't get restored while in VGA pipeline mode. This driver has been tested by over half a dozen people and has been present in hardy for about a week.

Patch: http://launchpadlibrarian.net/10316259/xserver-xorg-video-intel_2.1.1-0ubuntu10.debdiff

Steps to reproduce:
1. Start Ubuntu
2. Black screen / freeze once X starts.
3. If not, then switch to vt1 and back, or do suspend/resume
4. Black screen / freeze

Regression potential: Low, as this is a small patch that affects only i830-class hardware. It has been tested on gutsy and rolled out into hardy without any subsequent bug reports

holzi (konrad-holzbauer) wrote :

I can confirm this bug with my Fujitsu-Siemens Lifebook E4010, also with 82852/855GM as graphics controller. To me happened exactly the same, I did the same things to resolve the situation.

Architecture: i386
Date: Fri Apr 20 13:50:16 2007
DistroRelease: Ubuntu 7.04
Uname: Linux schlepptop 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

stefan (weigi) wrote :

the same here. i always get the kdm to show up but i cannot log into kde. (flickers and returns to kdm the first time and if i try again it results in a total system hang)

TaopaiC (pctao) wrote :

It's the same here with my Acer TM3002 notebook.

Architecture: i386
Date: Thu May 17 07:47:23 CST 2007
DistroRelease: Ubuntu 7.10
Uname: Linux ubuntu 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Pierre (pierrot-102) wrote :

I can confirm the same problem with my acer travelmate 6003 with 82852/855GM. I am using ubuntu feisty. And using again succesfully the i810 driver.

Bryce Harrington (bryce) wrote :

This sounds like a combination of several bugs that have since been fixed in Gutsy.

Can those of you experiencing these issues please test gutsy-beta and report on if any issues remain?

Markus (markus-schmaus) wrote :

I am running an up date gutsy on a thinkpad X40
xserver-xorg-video-intel: 2:2.1.1-0ubuntu4
Uname: Linux gutsy 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Using the intel video driver principally works and the problems described above do no longer occur. But after waking from sleep the screen remains black. So I will still continue to use i810.

Shall I open a new bug report for this?

Bryce Harrington (bryce) wrote :

Yes, do open a new report for that issue if there isn't one already (I think there may already be). Thanks for confirming that the principle issues are fixed, I'll close this one.

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Mihai Capotă (mihaic) wrote :

The driver is not working in Gutsy. I'm running the RC live CD right now. The symptoms are the same as reported above. I have a G40 ThinkPad with the 82852/855GM chip.
When booting the CD, the screen goes black when starting X. I can't even switch to the console with Alt+F1.
Starting up in safe graphics mode works.
Using the "test" button in the "Screens and Graphics" utility to try the "intel" driver results in a blank screen and a "Configuration test failed" message. I attached the log produced by the test server.
The "i810" driver passes the test.

Mihai Capotă (mihaic) wrote :

I experienced the same issues using the Gutsy RC Live CD.

Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
Peter Clifton (pcjc2) wrote :

For anyone still having issues on 855 hardware, specifically when switching VTs, suspending, shutting down, (or even starting the X server up), and wanting to help debug this issue further, I'm put online a .deb (and sources etc..):
http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/debug/
http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/debug/xserver-xorg-video-intel_2.1.1-0ubuntu9~pcjc2.tst_i386.deb

This has the latest ubuntu version of the driver, with all known fixes that have been pushed to Ubuntu. It has an experimental patch of mine to avoid blinking the blackight like crazy when starting the server up, which also has possible side-effects for the load/restore path.

The useful bit, is a load of extra log output at nearly every stage of the restore path. If its failing there, we should be able to narrow down where.

I've added calls to sync() after every log messge I added, so _hopefully_ some of this will make it to disk if the machine hard-locks, although hardware write-caching on the disk may put pay to that.

You might try disabling that before VT switching with:
hdparm -W 0 /dev/HARD_DRIVE

Those who know how to attach strace from a remote machine will be able to see everything even if the machine locks.

I'd be interested to see log output from this for anyone who still has failures. (Running this test version of the driver).

Peter Clifton (pcjc2) wrote :

http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/debug/xserver-xorg-video-intel_2.1.1-0ubuntu9~pcjc2.tst2_i386.deb

Incorporates a possible fix on 85X hardware, but is still a debug patch.

If it doesn't fix the problem, please send the Xorg.0.log.

Peter Clifton (pcjc2) wrote :

http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/debug/xserver-xorg-video-intel_2.1.1-0ubuntu9~pcjc2.tst3_i386.deb

the .tst2 version didn't workaround the bug very well. This version might.

Peter Clifton (pcjc2) wrote :

http://www2.eng.cam.ac.uk/~pcjc2/ubuntu/xserver-xorg-video-intel_2.1.1-0ubuntu10~pcjc2_i386.deb

A non debug version of the above which doesn't mess up programming the palette like the last ones did. Seems to fix at least one persons 855 based problems, baring seeing the effects in Bug #133118.

Mihai Capotă (mihaic) wrote :

I just tested the .tst3 version of the patched driver with the final release of Gutsy. X still doesn't start.
I booted the Live CD in safe graphics mode, downloaded the driver and installed it with "dpkg -i".
I tested it using the "Test" button in the "Screen and Graphics Preferences" utility. I got the same "Configuration test failed" message I get with the driver included in Gutsy. I attached the log resulting from the test run (/var/log/Xorg.9.log).

unggnu (unggnu) wrote :

The Test button of displayconfig-gtk doesn't work with Intel hardware afaik and it should be greyed out so it is no proof.

Mihai Capotă (mihaic) wrote :

The "Test" button works on my 82852/855GM Intel hardware. The "i810" passes the test, as I mentioned in my first comment.

unggnu (unggnu) wrote :

But not with the new Intel driver afaik.

unggnu wrote:
> But not with the new Intel driver afaik.

I don't understand what you mean.
What is the "Test" button supposed to do but start a new X server with
the tested driver? It does exactly this, but the screen remains black,
just as when booting the Live CD normally (i.e. using the "intel" driver).
The test run of the X server produces a log (/var/log/Xorg.9.log) which
I attached.

Timo Aaltonen (tjaalton) wrote :

xserver-xorg-video-intel (2:2.1.1-0ubuntu10) hardy; urgency=low

  [ Bryce Harrington ]
  [Peter Clifton]
  * 08_fix_855_3D_state.diff
    - Emit the invariant 3D state to the GPU during EnterVT after
      marking the 3D state as clobbered. This fixes / works around
      textured surface corruption after resume on 855GM hardware.
      (Closes LP: #133118)
  * 07_fix_startup_blink.diff
    - Alter startup sequence to avoid blinking the display whilst
      initialising the graphics chip.
      (Closes LP: #148686)
  * 04_fix_hw_restore.diff
    - Only restore PIPE[AB]CONF if the DPLL for that PIPE is running
      and not in VGA pipeline mode.
      (Closes LP: #108056)

  [Kyle McMartin, Bryce Harrington]
  * 06_sync_quirks.diff:
    - Sync TV out quirks with upstream

 -- Timo Aaltonen <email address hidden> Thu, 01 Nov 2007 21:44:36 +0200

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :
Changed in xserver-xorg-video-intel:
milestone: none → gutsy-updates
Bryce Harrington (bryce) on 2007-11-09
description: updated
Bryce Harrington (bryce) wrote :

Subscribing ubuntu-sru.

Changed in xserver-xorg-video-intel:
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Fixed in hardy already.

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Ack'ed this patch for SRU.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: New → In Progress
Martin Pitt (pitti) wrote :

Sponsored and accepted into gutsy-proposed, please test.

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Committed
Petri Pennanen (suvarin) wrote :

The new xserver-xorg-video-intel in gutsy-proposed does not fix Bug #152654.

I'm not sure if Bug #152654 really is a duplicate of this bug. In Bug #152654 the xserver crashes if device driver "i810" is selected, while "intel" works. That is the exact opposite from what is happening here?

The issue in Bug #152654 is that "i810" worked in Feisty, and did not after dist-upgrading to Gutsy. Trying to reconfigure xorg selects the "i810" driver instead of the working "intel". Perhaps Bug #152654 is an issue with xorg configuration?

Do not hesitate to ask for logs or debugging information, but please point towards some detailed advice on to how a trace can be obtained (the computer freezes up completly and I do not know wich process I should try to attach to gdb).

Andreas Klien (x4nd1) wrote :

Also tested xserver-xorg-video-intel 2:2.1.1-0ubuntu9.1 (gutsy-proposed) and it does not fix it for me.

When using the 'intel' driver the screen stays black after starting xserver and it tends to hang.
I am successfully using the 'i810' driver.

Bryce Harrington (bryce) wrote :

It seems that patch 04_fix_hw_restore.diff causes a regression for some users, as described in bug 182865.

Bryce Harrington (bryce) wrote :

Petri, if bug #152654 is not fixed by this, please feel free to un-dupe the bug (go to Duplicate and delete 108056 from the input box). Make sure to attach a backtrace - directions are available at https://wiki.ubuntu.com/DebuggingXorg. Also attach your Xorg.0.log and any other evidence of the issue.

Martin Pitt (pitti) wrote :

There is no current gutsy SRU for xserver-xorg-video-intel, so I unsubscribed ubuntu-sru. Please resubscribe and/or upload if you have a fix for this. Thank you!

Changed in xserver-xorg-video-intel:
status: Fix Committed → New
Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Gutsy Gibbon 7.10 has reached its end of life -
http://www.ubuntu.com/news/ubuntu-7.10-eol . As a result, we are closing the
Gutsy task.

Changed in xserver-xorg-video-intel (Ubuntu Gutsy):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers