Sometimes after logging in screen goes blank

Bug #107380 reported by Shirish Agarwal
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

 Hi all,
        Many a times, after gdm login, the screen goes blank and never returns. This happens more so in 2.6.20-15 rather than 2.6.20-12 where the screen goes momentarily blank. Usually this is the workaround I follow in order to recover when it doesn't show anything on screen. :-

1. using 2.6.20-15 after login blank screen (black screen)
2. Do ALT+SYSRQ+ s then u then b for reboot
3. This time use 2.6.20-12
4. After GDM login , the screen goes blank (black) momentarily and then comes back.
5. Do some work, shutdown
6. Now choose 2.6.20-15
7. This time after GDM login , there would be blank (black) screen for a moment but then things would come back.

        Giving the latest .xsessions-errors file as well as x.org.conf as well as xorg.log

Revision history for this message
Shirish Agarwal (shirishag75) wrote :
Revision history for this message
Shirish Agarwal (shirishag75) wrote :
Revision history for this message
Shirish Agarwal (shirishag75) wrote :
Revision history for this message
Shirish Agarwal (shirishag75) wrote :

aptitude show xserver-xorg-video-intel
Package: xserver-xorg-video-intel
New: yes
State: installed
Automatically installed: no
Version: 2:1.9.94-1ubuntu3

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

Intel 845 G/GL/ Intel Express chipset

lspci | grep Graphics
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

 Please lemme know if you need any more info. Thanx in advance.

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

Intel 845 G/GL/ Intel Express chipset

lspci | grep Graphics
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

 Please lemme know if you need any more info. Thanx in advance. Another thing display is a 17" CRT monitor with VGA inputs, no fancy stuff.

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

self-rejecting it as I already have duplicated it in but #104223

Changed in xserver-xorg-video-intel:
status: Unconfirmed → Rejected
status: Rejected → Unconfirmed
Revision history for this message
Shirish Agarwal (shirishag75) wrote :

Decided its not a duplicate hence no rejection because although bug #104223 are similar here it does not go to login. More so this driver is a community maintained driver unlike 1.9.93 version.
       I did one change in xorg.conf . Changed the driver line to 'intel' from 'i810' but had no effect.

  The only thing is sometimes metacity crashes, No window borders, decorations etc. Also after logging out no GDM login screen, its a blank screen. I would be re-installing the OS after feisty is released so perhaps things may be better then ? Keep u guys posted.

Revision history for this message
Sebastian Heinlein (glatzor) wrote :

Use the driver 'vesa' instead of 'i810'. This way we would see if the error is realted to the driver or not.

Does this also happen using the live cd?

Cheers,

Sebastian

Changed in xserver-xorg-video-intel:
status: Unconfirmed → Needs Info
Revision history for this message
Shirish Agarwal (shirishag75) wrote :

Sebastian, with 'vesa' this doesn't happen. This happens with 'intel' & IIRC somebody said that 'i810' would be deprecated soon. I haven't tried the live CD, would be downloading one come tribe 5.

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

Forgot to add xserver-xorg-video-intel is

shirish@Mugglewille:~$ dpkg -l xserver-xorg-video-intel
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=====================-=====================-==========================================================
ii xserver-xorg-video-in 2:2.1.1-0ubuntu2 X.Org X server -- Intel i8xx, i9xx display driver

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers