Black screen with only mouse cursor when resuming from screen power saving mode

Bug #1058835 reported by Till Kamppeter on 2012-09-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

After some time of not using the PC the screen turns off for power saving. When moving the mouse to resume the screen stays black with only the moving mouse cursor.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xorg 1:7.7+1ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sun Sep 30 01:41:50 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:2040]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=270acb41-78a4-4df9-84b3-2e3943b4d4dd ro video=VGA1:d quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/09/2012
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BHZ7710H.86A.0085.2012.0809.1641
dmi.board.name: DZ77BH-55K
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG39008-400
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrBHZ7710H.86A.0085.2012.0809.1641:bd08/09/2012:svn:pn:pvr:rvnIntelCorporation:rnDZ77BH-55K:rvrAAG39008-400:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.8.2+bzr3377-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu2

Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :

Following the instructions from Maarten Lankhorst on IRC I have created /etc/X11/X2:

#!/bin/bash
exec /usr/bin/valgrind --freelist-vol=500000000 --track-origins=yes --leak-resolution=high --malloc-fill=ef --free-fill=df /usr/bin/Xorg "$@" -verbose 10 &>> /home/till/vg.$(hostname)

made it executable and redirected the /etc/X11/X link to it. I have also installed valgrind, xserver-xorg-core-dbg, xserver-xorg-input-evdev-dbg, xserver-xorg-input-synaptics-dbg, xserver-xorg-video-intel-dbg.

After that I have logged out and logged in again so that X runs under Valgrind.

The problem does not occur very often, only every few days. As soon as it happened I switched to a text console and first copiied the log file from vg.till to vg.till.1 (attached) and then ran "sudo apport-bug xorg" to create this bug report (the command starts a text mode browser).

The log file vg.till.1 is attached.

Till Kamppeter (till-kamppeter) wrote :

I have added "--error-limit=no" to the valgrind commend line in /etc/X11/X2 as valgrind told that it stopped reporting shortly before I have observed the problem the first time with X under Valgrind (comment #2). Then I have restarted X and waited for the problem to show up again which happened now. I copied vg.till to vg.till.2 and attached it to this comment.

Till Kamppeter (till-kamppeter) wrote :

Problem occured again, valgrind log under the same conditions as described in comment #3 attached.

Robert Hooker (sarvatt) wrote :

xserver-xorg-video-intel 2:2.20.9-0ubuntu1 has the fix for this in it, please update and close this bug if it's fixed or change it from incomplete if it's not

Changed in xorg (Ubuntu):
status: New → Incomplete
Robert Hooker (sarvatt) on 2012-09-30
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Till Kamppeter (till-kamppeter) wrote :

Right after my last comment I did a system update which included said version of xserver-xorg-video-intel. I will keep observing for some days and tell whether the problem has gone away.

Till Kamppeter (till-kamppeter) wrote :

It seems that the problem is fixed now as it does not occur any more for me. As running X under Valgrind slows down X significantly I have turned off the Valgrind observation again.

Marking bug as fixed ...

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers