Artifacts on screen with ivy bridge

Bug #1031784 reported by Stefan Berggren on 2012-08-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
mesa (Ubuntu)
Undecided
Unassigned
Precise
Critical
Timo Aaltonen
xserver-xorg-video-intel (Ubuntu)
High
Timo Aaltonen
Precise
Critical
Unassigned

Bug Description

[IMPACT]

renders IVB GT1 systems basically inoperable, with massive distortion on screen

also affects systems on the certification queue

[TESTCASE]

boot 12.04 on a IVB GT1 (HD2500) system

[Regression Potential]

None, the changes are oneliners to reduce the max thread count on IVB GT1, which matches the current (internal?) intel specs

[NOTE]

The mesa update is added on top of a current SRU in -proposed, which is already being tested elsewhere. This commit should not risk that SRU, or vise versa (mesa got an exception from the TB)

--

I have a Intel 3570 CPU (Ivy Bridge) with built in 2500 graphics [1].
There is a lot of artifacts on screen, both in lightdm and in unity. There more or less impossibly to read any text on screen.
I have tested quantal and the packages from ppa:xorg-edgers/ppa without any improvement. I had high hopes what xf86-video-intel 2.20.2 was the solution because it contains ivy bridge fixes, but still no result. [2]

Note (link 2):
"For the last 9 months, since 2.16.901, we have been shipping a driver that
does not work on IvyBridge GT1 systems (HD2500 graphics); we were telling
the GPU to use an invalid number of threads for the pixel shader and this
in turned caused the GPU to hang."

With a plain install of precise I only see artifacts, but X hangs (hard) when I'm using quantal or the packages from ppa:xorg-edgers/ppa

My current ugly workaround is to remove the intel driver and let X fall back to something else, not a perfect solution but the system is usable.

[1] http://ark.intel.com/products/65702/Intel-Core-i5-3570-Processor-%286M-Cache-3_40-GHz%29
[2] http://lists.freedesktop.org/archives/xorg/2012-July/054947.html

Currently the system is running 12.04 with ppa ppa:xorg-edgers/ppa.
I have xserver-xorg-video-intel 2:2.20.2+git20120731.fd3a1236-0ubuntu0sarvatt~precise installed, the system hangs hard after I log in, or sometimes the GPU hangs and the screen goes to power save.

The system is not in use and I'm free to install and test whatever version and/or packages you want me to install.

Created attachment 64520
Ubuntu 12.04 login screen

I'm getting Severe graphics corruption on my system. Graphics are fine in Windows 7. I have had the motherboard and CPU replaced, the issue still exists. Memory tests fine.

Symptoms:

1) The screen is covered in small wrong-color squares, almost like a corrupt JPG. Some screen elements render fine (e.g: the twm menu) while others are unreadable. Screen elements are not always drawn over when they go away. See the pictures attached for examples:

2) Driver hangs on any 3d type activity. glxgears, for example, will cause the screen to basicly freeze. The driver will then reset (as shown in dmesg). xorg-edgers drivers do not appear to freeze, but glxgears exits with "intel_do_flush_locked failed: Input/output error". glxgears registers 0.163fps or lower.

3) The image seems to display properly using the VESA driver. (Boot gentoo live-dvd with -nofb option)

4) With ubuntu and the xorg-edgers PPA, the corruption is present using both the "uxa" and "sna" AccelMethod options in xorg.conf

5) Sometimes, switching to a VT and back will clean up the image for a moment (i.e. until something moves) Also, after glxgears crashed with the error above, most applications were readable. However, redraw problems were still rampant, and trying to run glxgears again gives the do_flush_locked error above

I have confirmed these issues are present when booting the following distros:

Linux Mint 13 (64bit) Live-dvd
Ubuntu 12.04 (64bit) Install CD and Standard install
Gentoo 64bit Live-DVD 12.1 (regular boot, -nofb boots into vesa mode)
Ubuntu 12.04 with xorg-edgers PPA (As of July 22, 2012)

Hardware:
CPU: Intel i5-3470
Chipset: Intel Z77 (M/B: Asus P8Z77-V, bios rev 1205)
Memory: 2x 8GB Patriot G3 DDR3-12800 1600mhz
Monitor: VGA connected CRT or HDMI connected LCD

Currently Running kernel:
Linux Hoita 3.5.0-5-generic #5-Ubuntu SMP Wed Jul 18 07:35:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Installed packages (Up-to-date with xorg-edgers-ppa as of July22, 2012):
linux-generic 3.5.0.5.5
xorg 1:7.6+12ubuntu1
libdrm2 2.4.37+git20120713.992e2afd-0ubuntu0ricotz~precise
libgl1-mesa-dri 8.1~git20120720.cdad337f-0ubuntu0sarvatt~precise
xserver-xorg-video-intel 2:2.20.0+git20120720.f92a64dd-0ubuntu0sarvatt~precise

Created attachment 64521
Picture of screen artifacts (driconf open in twm)

Created attachment 64522
Xorg log

Created attachment 64523
dmesg output

Created attachment 64524
Listing of installed packages and versions

Created attachment 64525
/etc/drirc

Created attachment 64526
glxinfo

Created attachment 64527
i915 error state

Created attachment 64528
lspci -vvv output

Created attachment 64529
intel_reg_dumper output

Turns out that the GPU is hanging with the latest xorg-edgers packages, same as before (see the dmesg output). However, the monitor is not resetting like it was (as if the resolution had changed) which is why I had thought otherwise.

We have obviously angered the hw gods here.

Can you try sacrificing some rc6 to see if that appeases them? Please append i915.i915_enable_rc6=0 to your grub boot parameters and see if that makes a difference.

Adding the "i915.i915_enable_rc6=0" command to the kernel boot parameters did not make any change that I can see.

If it would help, I'm willing to checkout the required drivers and compile them with whatever debugging turned on you would like.

Just let me know, I'd really like to see this resolved.

Thanks!

Do you have any overclocking settings in your BIOS?

There are some, but none of them seem to make any difference as far as I can tell.

The Bios has a "Normal" setting in basic mode, which is supposed to disable all the overclocking features. It was the first thing I tried when I got the new motherboard and noticed the problem. In advanced mode, it gives you a LOT more overclocking options, but I'm not into overclocking, so I haven't used many.

Right now, almost everything is set to factory default except the RAM. It's set to 1600MHz, which is what the RAM is rated for. Previously, it was 1333MHz, and the problem still existed.

I have not tried fiddling with any of the more advanced settings. Right now, mostly they're all set to auto.

If there is any particular change you would like me to make, please let me know.

Thanks!

Can you please do a lspci -n? The question of the hour is whether this a 0x0152 (IvyBridge desktop GT1). I have two other bug reports for that specific chip, could this be a third?

I pushed a potential fix to http://cgit.freedesktop.org/~ickle/xf86-video-intel/log/?h=ivb-gt1 if you are able to test, that would be fantastic.

Created attachment 64746
Output from lspci -n

This is the output of lspci -n as requested

Thanks, so three very similar deaths, each on a 0x0152.

Created attachment 64751
Logs from running driver snapshot 4a7334eb... from git

These are the log files generated by running the driver version found here:

http://cgit.freedesktop.org/~ickle/xf86-video-intel/commit/?h=ivb-gt1&id=4a7334ebb0e31fa603139350160772ae37171990

Results: This _appears_ to fix the "corrupted jpg" look of the graphics on the initial login screen, and when running TWM.

However, when launching Unity (logging in), the computer crashes HARD. Previously, I could switch to a VT, and kill X. Now, I cannot. (I needed to ssh into the system to get these logs)

Also, glxgears crashes without showing anything.

I believe the ddx portion of this to be fixed with:

commit 1ced4f1ddcf30b518e1760c7aa4a5ed4f934b9f5
Author: Chris Wilson <email address hidden>
Date: Thu Jul 26 10:50:31 2012 +0100

    Reduce maximum thread count for IVB GT1 to avoid spontaneous combustion

    Somewhere along the way it seems that IVB GT1 was reduced to only allow
    a maximum of 48 threads, as revealed in the lastest bspecs.

    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=52473
    Signed-off-by: Chris Wilson <email address hidden>

Note that a corresponding patch for mesa is also required.

*** Bug 52442 has been marked as a duplicate of this bug. ***

*** Bug 52473 has been marked as a duplicate of this bug. ***

commit fbf86c7f0f1f12e52b927e3870535073879d0a4d
Author: Eric Anholt <email address hidden>
Date: Fri Jul 27 11:34:07 2012 -0700

    i965/gen7: Reduce GT1 WM thread count according to updated BSpec.

    Acked-by: Kenneth Graunke <email address hidden>

    https://bugs.freedesktop.org/show_bug.cgi?id=52382

also pushed to 8.0.

Stefan Berggren (nsg) wrote :
Stefan Berggren (nsg) wrote :

Output from dmesg.
12.04 with xorg-edgers.
normal boot -> no artifacts i lightdm -> login -> gpu "crash" (screen to power save, unable to get picture from tty, system lives (ssh working)).

Stefan Berggren (nsg) wrote :

From a fresh 12.04 install, a lot of artifacts during install, almost no artifacts in lightdm and unity fails to load (this may have nothing to do with the intel driver).
module version = 2.17.0

Stefan Berggren (nsg) wrote :

And Xorg.0.log from a daily build of quantal.
module version = 2.19.0

Stefan Berggren (nsg) wrote :

dmesg from 12.10

nicolaasuni (info-tecnick) wrote :

I am also experiencing screen atrifacts with xorg-edgers:

Linux xxxxxx 3.5.0-5-generic #5-Ubuntu SMP Wed Jul 18 07:35:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

xserver-xorg-video-intel 2:2.20.2+git20120731.fd3a1236-0ubuntu0sarvatt~precise

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

Thanks, this has been verified. Needs updates to xserver-xorg-video-intel and mesa.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
Keng-Yu Lin (lexical) wrote :

I confirm that i3-3220 and i5-3470S (both with HD 2500) are affected too.

Timo Aaltonen (tjaalton) on 2012-08-03
Changed in xserver-xorg-video-intel (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
Keng-Yu Lin (lexical) on 2012-08-03
tags: added: blocks-hwcert-enablement
Timo Aaltonen (tjaalton) wrote :

this is fixed in -intel 2.20.2 in quantal-proposed

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.4-1ubuntu1

---------------
mesa (8.0.4-1ubuntu1) quantal; urgency=low

  * Merge from unstable. (LP: #1031784)

mesa (8.0.4-1) unstable; urgency=low

  [ Sven Joachim ]
  * New upstream stable release (Closes: #682703).
  * Cherry-pick commit fbf86c7f0f (i965/gen7: Reduce GT1 WM thread count
    according to updated BSpec.) from upstream.

mesa (8.0.3-1) unstable; urgency=low

  [ Robert Hooker ]
  * New upstream stable release (Closes: #673532)
  * Refresh patches.
 -- Timo Aaltonen <email address hidden> Fri, 03 Aug 2012 09:27:48 +0300

Changed in mesa (Ubuntu):
status: New → Fix Released
Timo Aaltonen (tjaalton) on 2012-08-03
description: updated
description: updated
Timo Aaltonen (tjaalton) wrote :

The precise fix is committed in git, but there is already a pending SRU upload which I think needs to go through first before this can be uploaded.

I've pushed -intel and mesa to my ppa too so that you can verify the fix more quickly: https://launchpad.net/~tjaalton/+archive/ppa
(looks like they don't show up just yet)

Changed in mesa (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
Keng-Yu Lin (lexical) wrote :

I tested the -intel and mesa packages from comment #12 on a i5-3470s machine. The artifact issue is fixed.

Colin Watson (cjwatson) wrote :

I don't see a clear action here for ~ubuntu-archive. (You don't need to subscribe ~ubuntu-archive just because there's a pending SRU - that's handled fairly mechanically.) Unsubscribing us - if you need to resubscribe us, please be clearer about the action we need to take, and ensure that it isn't blocked on something else.

Stefan Berggren (nsg) wrote :

Applied packages from ppa:tjaalton/ppa on a clean 12.04, no artifacts.
The fix solves my problem.

Timo Aaltonen (tjaalton) on 2012-08-08
Changed in mesa (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Changed in xserver-xorg-video-intel (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
description: updated
description: updated
bugbot (bugbot) on 2012-08-09
tags: added: edgers
Timo Aaltonen (tjaalton) wrote :

This is critical to the OEM team.

Changed in mesa (Ubuntu Precise):
importance: High → Critical
Changed in xserver-xorg-video-intel (Ubuntu Precise):
importance: High → Critical

Hello nsg, or anyone else affected,

Accepted xserver-xorg-video-intel into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.17.0-1ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello nsg, or anyone else affected,

Accepted mesa into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/8.0.3+8.0.2-0ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Precise):
status: In Progress → Fix Committed
Keng-Yu Lin (lexical) wrote :

I confirmed the mesa package in -precise-proposed fixes the issue on an i5-3740s-based machine.

tags: added: verification-done
removed: verification-needed
Mark Henderson (mch-x) wrote :

Also tested this. Precise-proposed fixed the issue on my i5 3470 machine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.3+8.0.2-0ubuntu3.2

---------------
mesa (8.0.3+8.0.2-0ubuntu3.2) precise-proposed; urgency=low

  * Use a fake upstream version due to a rejected update.
  * Add 119_reduce_vm_thread_count_on_ivb_gt1.diff from upstream stable
    branch. (LP: #1031784)
 -- Timo Aaltonen <email address hidden> Tue, 14 Aug 2012 07:11:03 +0300

Changed in mesa (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.17.0-1ubuntu4.1

---------------
xserver-xorg-video-intel (2:2.17.0-1ubuntu4.1) precise-proposed; urgency=low

  * Add 105_reduce_ivb_gt1_max_thread_count.patch, backported commit
    from upstream to reduce the thread count on IVB GT1. (LP: #1031784)
 -- Timo Aaltonen <email address hidden> Fri, 03 Aug 2012 09:02:29 +0300

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Fix Committed → Fix Released
tags: added: rls-q-incoming
bluedream (wangjinfajimmy) wrote :

i have updated
ii libegl1-mesa 8.0.4-1ubuntu1 free implementation of the EGL API -- runtime
ii libegl1-mesa:i386 8.0.4-1ubuntu1 free implementation of the EGL API -- runtime
ii libegl1-mesa-drivers 8.0.4-1ubuntu1 free implementation of the EGL API -- hardware drivers
ii libegl1-mesa-drivers:i386 8.0.4-1ubuntu1 free implementation of the EGL API -- hardware drivers
ii libgl1-mesa-dri 8.0.4-1ubuntu1 free implementation of the OpenGL API -- DRI modules
ii libgl1-mesa-dri:i386 8.0.4-1ubuntu1 free implementation of the OpenGL API -- DRI modules
ii libgl1-mesa-glx 8.0.4-1ubuntu1 free implementation of the OpenGL API -- GLX runtime
ii libgl1-mesa-glx:i386 8.0.4-1ubuntu1 free implementation of the OpenGL API -- GLX runtime
ii libglapi-mesa 8.0.4-1ubuntu1 free implementation of the GL API -- shared library
ii libglapi-mesa:i386 8.0.4-1ubuntu1 free implementation of the GL API -- shared library
ii libglu1-mesa 8.0.4-1ubuntu1 Mesa OpenGL utility library (GLU)
ii libglu1-mesa:i386 8.0.4-1ubuntu1 Mesa OpenGL utility library (GLU)

and xorg
ii xserver-xorg-video-intel 2:2.17.0-1ubuntu4.1 X.Org X server -- Intel i8xx, i9xx display driver

but The system still report internal err " xserver-xorg-video-intel GPU lookup err" in 12.04

tags: added: regression-proposed
removed: rls-q-incoming
Timo Aaltonen (tjaalton) wrote :

bluedream: err, that has nothing to do with this bug. That mesa version is not in precise, and quantal has moved on as well. If you have issues file a new bug with 'ubuntu-bug xorg'.

Timo Aaltonen (tjaalton) wrote :

fixed in quantal too

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
bluedream (wangjinfajimmy) wrote :

hi Timo Aaltonen:
   I don't think so that the Qualtal is not fixed.
  I had upgraded 12.04 to 12.10 last night,this mornning I restarted my computer and login in desktop,wait about 5 minutes Quantal suddenly jump one dialog show the same Xorg error as Precise when I seen.

bluedream (wangjinfajimmy) wrote :

I don't think so that the Qualtal is fixed.

Timo Aaltonen (tjaalton) wrote :

bluedream: you don't have this bug then, file a new one

*** Bug 52473 has been marked as a duplicate of this bug. ***

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.